none
Установка Exchange Server 2013 RRS feed

  • Вопрос

  • Добрый день

    При установке Exchange Server 2013, шаг 8 из 15 Mailbox role: Transport service на 93 % вылезает ошибка:

    Error:
    The following error was generated when "$error.Clear();
                if ($RoleProductPlatform -eq "amd64")
                {
                    $useAttachMode = $false;
                    $fastInstallConfigPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\Installer";
                    $command = Join-Path -Path $fastInstallConfigPath -ChildPath "InstallConfig.ps1";
                    $fastDefaultDataFolderPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\HostController\Data";
                    $dataFolderPath = $fastDefaultDataFolderPath;
                   
                    if ([System.IO.Directory]::Exists($fastDefaultDataFolderPath))
                    {
                        $useAttachMode = $true;
                    }
                    else
                    {
                        if ($RoleIsDatacenter -eq $true)
                        {
                            $preferredDataFolderPathRoot = "D:\";
                            if ([System.IO.Directory]::Exists($preferredDataFolderPathRoot))
                            {
                                $dataFolderPath = Join-Path -Path $preferredDataFolderPathRoot -ChildPath "ExchangeSearchData";
                                if ([System.IO.Directory]::Exists($dataFolderPath))
                                {
                                    $useAttachMode = $true;
                                }
                            }
                        }
                    }
                   
                    if ($useAttachMode -eq $true)
                    {
                        &$command -action a -dataFolder $dataFolderPath -silent;
                    }
                    else
                    {
                        try
                        {  
                            &$command -action i -dataFolder $dataFolderPath -silent;
                        }
                        catch
                        {
                            $errorMsg = "Failure running SearchFoundation installconfig.ps1 - " + $_.Exception.Message;
                            Write-ExchangeSetupLog -Error $errorMsg;
                            &$command -action u -silent;
                            try
                            {
                                if ([System.IO.Directory]::Exists($dataFolderPath))
                                {
                                    [System.IO.Directory]::Delete($dataFolderPath, $true);
                                }
                            }
                            catch
                            {
                                $deleteErrorMsg = "Failure cleaning up SearchFoundation Data folder. - " + $dataFolderPath + " - " + $_.Exception.Message;
                                Write-ExchangeSetupLog -Error $deleteErrorMsg;
                            }
                        }
                    }
                }
            " was run: "Failure running SearchFoundation installconfig.ps1 - Error occurred while configuring Search Foundation for Exchange.System.TimeoutException: IndexNode1 initialization timed out.
       at Microsoft.Ceres.Exchange.PostSetup.NodeManager.InitializeNode(String nodeName)
       at Microsoft.Ceres.Exchange.PostSetup.NodeManager.DeployIndexNode()
       at Microsoft.Ceres.Exchange.PostSetup.DeploymentManager.Install(String installDirectory, String dataDirectoryPath, Int32 basePort, String logFile, Boolean singleNode, String systemName, Boolean attachedMode)
       at CallSite.Target(Closure , CallSite , Type , Object , Object , Object , Object , Object , Object , Boolean )".

    Подскажите что это за ошибка, как можно её исправить ?
    • Изменено 3dwin 12 января 2015 г. 11:13
    12 января 2015 г. 11:11

Ответы