none
Агент получает пакет управления, но не запускает discovery RRS feed

  • Вопрос

  • Доброго времени суток!

    Имеется SCOM 2007 R2, на нём установлен самописный MP (здесь и далее %MP_NAME% - имя MP, %GROUP_NAME% - имя группы управления). Проблема в том, что данный пакет воспринимается не всеми агентами в группе. Сразу после установки пакета идём на один из проблемных серверов, смотрим лог событий SCOM:

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:36 : Operations Manager : HealthService : 1204

    Пакет управления с идентификатором "%MP_NAME%" и версией "1.0.0.1" больше не используется службой работоспособности и будет удален из кэша.

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:36 : Operations Manager : HealthService : 1210

    Новая конфигурация стала активной. Группа управления "%GROUP_NAME%", идентификатор конфигурации "C9 6E F7 C6 28 30 91 27 49 3F B0 FB D0 83 D0 1F B8 3A F7 56 ".

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:30 : Operations Manager : HealthService : 1201

    Получен новый пакет управления с идентификатором "%MP_NAME%" и версией "1.0.0.1".

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:24 : Operations Manager : HealthService : 1200

    Запрошены новые пакеты управления. Группа управления "%GROUP_NAME%", идентификатор конфигурации "C9 6E F7 C6 28 30 91 27 49 3F B0 FB D0 83 D0 1F B8 3A F7 56 ".

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:22 : Operations Manager : HealthService : 7028

    Все учетные записи запуска от имени для группы управления %GROUP_NAME% имеют правильный режим входа.

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:22 : Operations Manager : HealthService : 7024

    Служба работоспособности успешно выполнила вход для всех учетных записей для группы управления %GROUP_NAME%

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:22 : Operations Manager : HealthService : 7025

    Служба работоспособности авторизовала все настроенные учетные записи запуска от имени для выполнения в группе управления %GROUP_NAME%.

    ---------------------------------------------------------------------------------------------------------------------------

    14.03.2011 10:00:22 : Operations Manager : HealthService : 7023

    Служба работоспособности успешно загрузила безопасную конфигурацию для группы управления %GROUP_NAME%.

    ---------------------------------------------------------------------------------------------------------------------------

     

    На серверах, где MP нормально воспринимается, в логах видны те же сообщения. И на проблемных, и на нормальных серверах стоит Windows Server 2008 Standard SP1. Для теста мы добавили в самое начало скрипта обнаружения (чтобы наверняка быть уверенными, что ошибка не в самом скрипте) вывод в лог событий. Как и ожидалось, лог пишется на всех серверах, кроме проблемных. В чём может быть дело?

    14 марта 2011 г. 8:00

Ответы

  • Предупреждения в логе есть? Другие модули на этих серверах работают?

    Попробуйте очистить кэш агента на одном из проблемных серверов.


    http://OpsMgr.ru/
    • Помечено в качестве ответа Aleksey Fedotov 23 марта 2011 г. 5:35
    15 марта 2011 г. 8:48
    Отвечающий

Все ответы

  • >Сразу после установки

    Как он устанавливается? Версии до и после обновления как я вижу - одинаковы. Какова частота запуска discovery? Сколько ждали на проблемных серверах события?

    Слишком мало информации...


    http://OpsMgr.ru/
    15 марта 2011 г. 7:56
    Отвечающий
  • >Сразу после установки

    Как он устанавливается? Версии до и после обновления как я вижу - одинаковы. Какова частота запуска discovery? Сколько ждали на проблемных серверах события?

    Слишком мало информации...


    http://OpsMgr.ru/
    SCOM -> Administration -> Пакеты управления -> Import Management Packs... (пакет не запечатанный, если это имеет значение). Сначала строка с версией действительно не менялась, однако фактические изменения в скриптах всё равно воспринимались всеми агентами, кроме проблемных. Потом мы попробовали также увеличивать версию - не помогло. Частота запуска discovery тестировалась разная - от нескольких минут (3-5) до 4 часов - во всех случаях проблема наблюдалась. Тестирования проводились в течение нескольких дней.
    15 марта 2011 г. 8:11
  • Если discovery просто не запускается, ни ошибок скриптов, ничего в лога - значит на "проблемных" серверах нет экземпляров класса, на который нацелен discovery.


    http://OpsMgr.ru/
    15 марта 2011 г. 8:20
    Отвечающий
  • Если discovery просто не запускается, ни ошибок скриптов, ничего в лога - значит на "проблемных" серверах нет экземпляров класса, на который нацелен discovery.

    Discovery нацелен на Microsoft.Windows.Server.Computer
    15 марта 2011 г. 8:38
  • Предупреждения в логе есть? Другие модули на этих серверах работают?

    Попробуйте очистить кэш агента на одном из проблемных серверов.


    http://OpsMgr.ru/
    • Помечено в качестве ответа Aleksey Fedotov 23 марта 2011 г. 5:35
    15 марта 2011 г. 8:48
    Отвечающий
  • Проблема полечилась очисткой кеша агента. Спасибо!
    23 марта 2011 г. 5:34