none
Проблема при публикации Exchange 2013 RRS feed

  • Общие обсуждения

  • Всем привет. Возникла проблема при публикации сервера Exchange 2013.

    Установлен Server 2012 + Exchange 2013, установка и настройка согласно библиотекам technet:

    • Установка и настройка - http://technet.microsoft.com/ru-RU/library/jj218640.aspx
    • Публикация - http://blogs.technet.com/b/exchange/archive/2010/07/16/3410408.aspx
    • Публикация через TMG через Web Farm - http://blogs.technet.com/b/exchange/archive/2012/11/21/publishing-exchange-server-2013-using-tmg.aspx

    Установка и настройка прошла успешно и почта отправляется и принимается, но не как не получается опубликовать CAS.

    Создал тестовую среду с доменом три VM , роли  cas и mail box на одном сервере, назвал mail.test.local все сертификаты стоят и настроены включая локальный пк.  Внутри сети OWA и ECP доступны и прекрасно работают. В браузере на вкладе соединения виден сертификат для mx.shine.local. 

    При входе с внешки получаю закрытое соединение, нажимаю продолжить, появляется страница 404 с сертификатом от Default-Web-Site и  надписью "

    404 - файл или каталог не найден.

    Запрашиваемый ресурс перемещен, переименован либо временно недоступен.

    "

    Подозреваю что проблема в IIS....

    Требуется помощь в решении.... Help


    19 декабря 2012 г. 19:12

Все ответы

  • Добрый день.

    Что показывает тестирование правила публикации на TMG?


    Blog - Smtp25.ru

    20 декабря 2012 г. 5:27
    Отвечающий
  • Все тесты успешны, горят зелёные галочки..

    20 декабря 2012 г. 6:45
  • Покажите пожалуйста закладку Paths из правила публикации.

    Blog - Smtp25.ru

    20 декабря 2012 г. 7:53
    Отвечающий

  • Что-то форум не даёт загрузить картинку, вот ссылка пожалуйста...

    http://img13.imageshost.ru/img/2012/12/20/image_50d32e3e4ab36.png

    • Изменено 1FAN 20 декабря 2012 г. 15:22
    20 декабря 2012 г. 15:20
  • Давайте тогда в лог IIS смотреть. Попробуйте зайти в OWA снаружи, чтобы ошибка появилась. Потом минут через 10 смотрите в последнем логе (лежат в папках C:\inetpub\logs\LogFiles\W3SVC* - должно быть 2 папки) и ищите в них ошибку 404.

    Или выложите куда-нибудь эти файлы (по последнему файл из каждой папки) - я посмотрю.


    Blog - Smtp25.ru

    20 декабря 2012 г. 15:35
    Отвечающий

  • Вот ссылка: http://www.sendspace.com/file/7wivv5

    Самому что-то не получилось найти...

    20 декабря 2012 г. 16:30
  • Вы какие-нибудь настройки относящиеся к External виртуального каталога для OWA на CAS меняли? Аутентификацию например?

    Я построил аналогичный тестовый стенд - все в порядке. Т.е. инструкция для 2010 подходит и для 2013.


    Blog - Smtp25.ru


    21 декабря 2012 г. 7:43
    Отвечающий
  • Нет не менял, разве что на IIS менял метод проверки подлинности, на каталогах OWA и ECP, так как на тесте правила на TMG все параметры горели красным, после изменений тест прошёл успешно. Вот опять поднял заново всю систему, установил и настроил Exchange, ничего не менял в IIS все правила аутентификации по умолчанию согласно библиотекам technet и опять не проходит тест на TMG все каталоги горят красным...полная  ж!

    24 декабря 2012 г. 6:10
  • А покажите, какая ошибка в тестировании правила в TMG.

    У меня, когда я менял методы аутентификации, в какой-то момент внутренняя owa показывала как раз ошибку 404.


    Blog - Smtp25.ru

    24 декабря 2012 г. 7:15
    Отвечающий
  • 1) http://img13.imageshost.ru/img/2012/12/25/image_50d8cfe13f72b.png

    2) http://img13.imageshost.ru/img/2012/12/25/image_50d8d01f47076.png

    Вот такая вот ошибка, вылезает..

    24 декабря 2012 г. 21:52
  • Это не совсем ошибка, просто различные методы аутентификации установлены.

    А если из браузера зайти в owa?


    Blog - Smtp25.ru


    25 декабря 2012 г. 7:27
    Отвечающий
  • Максим, может мы встретимся на удалённом помощнике? Я думаю так проще будет выявить проблему и найти решение..Буду благодарен!))

    Напиши мне пожалуйста office@stephanshine.com

    25 декабря 2012 г. 10:09
  • К сожалению, у меня ни времени, ни возможности нету подключиться.

    Blog - Smtp25.ru

    25 декабря 2012 г. 13:03
    Отвечающий
  • День добрый. Вы решили свою проблему? Просто у меня та же ошибка
    Решил я эту проблему правда открывается на ПК на планшете и телефоне нет, но появилась другая не открывается ECP а OWA открывается и внутри и из вне. При заходе на страницу ECP ошибка 400. Виртуальную папку ECP в IIS удалял создавал занова. Есть подозрение на сертификат который я перевыпустил на сервере сертификации под web форму.
    • Изменено Polo1978 18 января 2013 г. 15:48
    18 января 2013 г. 2:52
  • День добрый. Вы решили свою проблему? Просто у меня та же ошибка
    Решил я эту проблему правда открывается на ПК на планшете и телефоне нет, но появилась другая не открывается ECP а OWA открывается и внутри и из вне. При заходе на страницу ECP ошибка 400. Виртуальную папку ECP в IIS удалял создавал занова. Есть подозрение на сертификат который я перевыпустил на сервере сертификации под web форму.

    Если вы через TMG публиковали, то на правиле публикации проверьте чтобы присутствовал виртуальный каталог ECP.  А также настройте внешний адрес на ECP!


    • Изменено 1FAN 19 января 2013 г. 8:17
    19 января 2013 г. 8:16
  • Не помогло
    После того как набираю Логин пароль ошибка 400
    • Изменено Polo1978 21 января 2013 г. 7:25
    21 января 2013 г. 4:31
  • для теста уберите все пути и выставите корень /*


    Идти туда, где не ждут, Атаковать там, где не подготовились.

    22 января 2013 г. 12:04
  • Не помогло
    После того как набираю Логин пароль ошибка 400

    1. Попробуйте в IE отключить "HTTP Friendly Error" и посмотреть, какой именно код ошибки 400 возвращается (Disabling HTTP Friendly Error Messages in Internet Explorer)

    2. Либо посмотрите в логах IIS какая именно ошибка 400 выдается и к какому содержимому.

    The HTTP status code in IIS 7.0, IIS 7.5, and IIS 8.0

    How to troubleshoot HTTP 400 errors


    Blog - Smtp25.ru

    22 января 2013 г. 16:50
    Отвечающий
  • Судя по картинкам не совпадают методы аутентификации в правиле и в листене. Попробуйте вот так:


    MCP,MCTS
    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"

    19 февраля 2013 г. 12:01

  • MCP,MCTS
    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"

    19 февраля 2013 г. 12:01
  • И настройки OWA, так же и на ecp


    MCP,MCTS
    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"

    19 февраля 2013 г. 12:04