none
Ошибка веб-части в Мой профиль RRS feed

  • Общие обсуждения

  • Всем добрый день )

    У меня тут такая штука произошла, что-то туплю и не пойму где искать...

    на личных узлах в профиле не отображается один из элементов, где показываются коллеги в правом верхнем углу.

    и вот что пишет:

    Ошибка веб-части: Веб-часть или элемент управления веб-формы, расположенные на этой странице, невозможно отобразить или импортировать. Тип не найден или не зарегистрирован как безопасный.


    сталкивался кто-нибудь с этим?


    saakov.ru
    4 марта 2009 г. 8:47

Все ответы

  • Слава Сааков написал:

    Всем добрый день )

    У меня тут такая штука произошла, что-то туплю и не пойму где искать...

    на личных узлах в профиле не отображается один из элементов, где показываются коллеги в правом верхнем углу.

    и вот что пишет:

    Ошибка веб-части: Веб-часть или элемент управления веб-формы, расположенные на этой странице, невозможно отобразить или импортировать. Тип не найден или не зарегистрирован как безопасный.


    сталкивался кто-нибудь с этим?


    saakov.ru

    В логах сервера тишина ?


    Первое правило Windows - делай резервную копию. Коды ошибок смотрите по адресу http://eventid.net/
    4 марта 2009 г. 10:16
  • все тихо-мирно...


    saakov.ru
    4 марта 2009 г. 12:39
  • Врядли в логах таки тишина :) Можно просто не там смотрите?
    Откройте страницу в Sharepoint Designer и посмотрите, что там за компонент.
    После этого надо будет проверить, что этот компонент установлен в GAC и прописан как SafeControl в web.config.

    4 марта 2009 г. 19:19
  •  открыл этот страницу в дизайнере ничего не понял и закрыл ))

    в общем это произошло тогда, когда упал сервак и когда я его переставил и подключился к существуюей ферме (точнее в серверу, где находила база).

    потом поднял все, что нужно для работы фермы и даже проиндексировал все содержимое по-новой.

    а вот с этой фигней произошло такое вот... может я чего-то не сделал, что делается при обычной установке?
    saakov.ru
    5 марта 2009 г. 15:03
  • Доброго, вам поможет одно средство.

    1. нужно извлечь из .wsp  файла решения  все файлы (путем извлечения)

    2. отредактировать файл manifest.xml

    обязательно в конце 

    SafeControl Assembly ......     должен быть тег Safe="True"

    пример частичного кода ниже

    <?xml version="1.0" encoding="utf-8"?>
    <Solution xmlns="http://schemas.microsoft.com/sharepoint/" SolutionId="" 
    SharePointProductVersion="14.0">
      <Assemblies>
        <Assembly Location="ListFilter.dll" DeploymentTarget="GlobalAssemblyCache">
          <SafeControls>
            <SafeControl Assembly="ListFilter, Version=1.0.0.0, Culture=neutral, PublicKeyToken=" Namespace="ListFilter.ListFilterWebPart" TypeName="*" Safe="True" />
          </SafeControls>
        </Assembly>
      </Assemblies>
      <FeatureManifests>
        
    </Solution>
    

    3. необходимо по новой собрать cab файл

    для этого используем 

    https://academy.bindtuning.com/how-to-manually-edit-a-sharepoint-wsp-file/

    https://www.izarc.org/downloads

    после успешной сборки  переименуем cab в wsp

    и устанавливаем решение на ферму (предварительно удалив все старые версии)

    7 февраля 2018 г. 7:27