none
Обновление Exchange 2016 до CU8 RRS feed

  • Вопрос

  • Доброго всем дня!

    Необходимо обновить Exchange 2016 Build 15.1.225.42 до CU 8 (Build 15.1.1415.002).

    В наличии 4 mailbox сервера в DAG и 2 сервера EDGE. 

    Есть ли порядок установки CU, или можно устанавливать сразу последний CU8? 

    В сети информация потиворечивая, многие пишут - сразу ставить CU8.

    2 марта 2018 г. 8:24

Ответы

Все ответы

  • Сразу ставьте. Только на лабе проверьте как все устанавливается, без этого я бы не рискнул.

    Разумеется сначала выводите сервер из работы, чтобы на него не сыпались запросы.

    Читайте: https://practical365.com/exchange-server/installing-cumulative-updates-on-exchange-server-2016/

    2 марта 2018 г. 8:30
  • Конечно нельзя!

    Нужно чередовать с обновлением Net Framework.

    Схема обновления указана  тут


    scientia potentia est
    My blog

    • Помечено в качестве ответа m1148 2 марта 2018 г. 14:45
    2 марта 2018 г. 8:47
  • Все бы ничего, да только для загрузки обычно бывает доступен только последний накопительный апдейт...
    2 марта 2018 г. 9:17
  • Т.е. вы предлагаете идти по пути неработающего решения по этой причине?)

    scientia potentia est
    My blog

    2 марта 2018 г. 9:19
  • Нельзя, но вероятно придется, если вы предварительно не скачали CU4, сейчас уже нет возможности скачать его с сайта МС.
    2 марта 2018 г. 9:21
  • Скачать можно только два последних CU. Но дело в том, что как выше написали, проблема есть с фреймворком. Если мне не изменяет память, надо перед обновление последнего CU поставить 4.7 версию.
    2 марта 2018 г. 9:34
  • Т.е. вы предлагаете идти по пути неработающего решения по этой причине?)

    scientia potentia est
    My blog

    Михаил, ну почему сразу не рабочий? Мне пришлось пару раз по не поддерживаемому сценарию проехаться (CU8-18) по той же причине (дистрибов уже не достать). Коллегам досталось обновлять CU4-19 и ничего не сломали. Да, не по фэньшую конечно, но сразу предупреждали что сценарий не правильный и  ответственность и риски на том, кто допустил "долгострой" с установкой актуальных версий. Не с торрентов же теперь качать, мало ли что там поймаешь.

    P.S. в песочнице тестировали конечно предварительно.

    2 марта 2018 г. 9:35
  • Т.е. вы предлагаете идти по пути неработающего решения по этой причине?)

    scientia potentia est
    My blog

    Если у вас есть нужные апдейты и вы готовы ими поделиться, то это решит проблему))

    При отсутствии оных есть только один вариант, который неправильный, но который единственный возможный. 

    2 марта 2018 г. 9:38
  • Ну сопряжённый с большими рисками) А если в лабе обновится, а в проде обновится, но сломается. Что делать в такой ситуации?

    scientia potentia est
    My blog

    2 марта 2018 г. 9:43
  • Т.е. вы предлагаете идти по пути неработающего решения по этой причине?)


    scientia potentia est
    My blog

    Если у вас есть нужные апдейты и вы готовы ими поделиться, то это решит проблему))

    При отсутствии оных есть только один вариант, который неправильный, но который единственный возможный. 


    Если нет аплейтов, то единственно правильный вариант это поставить рядом сервер сразу с cu8 и в него все мигрировать) Но это геморойно, конечно. Все остальное на свой страх и риск;)

    scientia potentia est
    My blog

    2 марта 2018 г. 9:46


  • Если нет аплейтов, то единственно правильный вариант это поставить рядом сервер сразу с cu8 и в него все мигрировать) Но это геморойно, конечно. Все остальное на свой страх и риск;)

    scientia potentia est
    My blog

    Это если инфраструктура позволяет, а то я не уверен, что у кого-то есть излишки мощностей))
    2 марта 2018 г. 9:53
  • Ну сопряжённый с большими рисками) А если в лабе обновится, а в проде обновится, но сломается. Что делать в такой ситуации?

    scientia potentia est
    My blog

    Что бывает часто.. У меня на Exchage было такое два раза. Не говоря уже о прочих делах. "Лабу" приближенную к боевым - это просто второй такой сервер. Надо понятное дело обновить один и понять что и как.. Если не выстрелит, тогда уже переставить начисто CU8 и потом уже решать как быть дальше с другими.
    2 марта 2018 г. 10:19


  • Если нет аплейтов, то единственно правильный вариант это поставить рядом сервер сразу с cu8 и в него все мигрировать) Но это геморойно, конечно. Все остальное на свой страх и риск;)

    scientia potentia est
    My blog

    Это если инфраструктура позволяет, а то я не уверен, что у кого-то есть излишки мощностей))
    4 сервера же есть, один выводишь, апдейтишь и вводишь заново.

    scientia potentia est
    My blog

    2 марта 2018 г. 10:23
  • Т.е. вы предлагаете идти по пути неработающего решения по этой причине?)


    scientia potentia est
    My blog

    Михаил, ну почему сразу не рабочий? Мне пришлось пару раз по не поддерживаемому сценарию проехаться (CU8-18) по той же причине (дистрибов уже не достать). Коллегам досталось обновлять CU4-19 и ничего не сломали. Да, не по фэньшую конечно, но сразу предупреждали что сценарий не правильный и  ответственность и риски на том, кто допустил "долгострой" с установкой актуальных версий. Не с торрентов же теперь качать, мало ли что там поймаешь.

    P.S. в песочнице тестировали конечно предварительно.

    А у вас базы дистрибутивов нет? Понимаю, что не все, но хоть какие-то предыдущие. У меня Exchange 2016 CU4 есть, я постараюсь его выложить в ближайшее время.

    scientia potentia est
    My blog

    2 марта 2018 г. 11:05
  • Рядом раздавали, можно брать.
    2 марта 2018 г. 11:26
  • Т.е. вы предлагаете идти по пути неработающего решения по этой причине?)


    scientia potentia est
    My blog

    Михаил, ну почему сразу не рабочий? Мне пришлось пару раз по не поддерживаемому сценарию проехаться (CU8-18) по той же причине (дистрибов уже не достать). Коллегам досталось обновлять CU4-19 и ничего не сломали. Да, не по фэньшую конечно, но сразу предупреждали что сценарий не правильный и  ответственность и риски на том, кто допустил "долгострой" с установкой актуальных версий. Не с торрентов же теперь качать, мало ли что там поймаешь.

    P.S. в песочнице тестировали конечно предварительно.

    А у вас базы дистрибутивов нет? Понимаю, что не все, но хоть какие-то предыдущие. У меня Exchange 2016 CU4 есть, я постараюсь его выложить в ближайшее время.

    scientia potentia est
    My blog

    Ну как бы до недавнего времени хранить все CU особой необходимости не было, т.к. не было этой чехарды с дотнетом...  какие то конечно есть. Как началось, пришлось вертеться.  А вот что делать автору, когда ему надо обновляться, а у него нет нужных CU, а обновляться надо? Допустим это не его вина, он только устроился. Ставить рядом доп сервер не всегда есть возможность. И не рекомендуемый порядок обновлений не обязательно сломает вам сервер, проверено. MS отвечает как всегда уклончиво, что ничего не гарантировано и в случае фэйла путь в MSS.

    P.S. пока писал, Дмитрий подкинул линк на CU4) качаем на свой страх и риск)

    2 марта 2018 г. 11:44
  • Спасибо всем ответившим!

    Нашел таки CU4.

    А эти командлеты необходимо выполнять на каждом сервере mailbox и edge перед установкой CU?

    setup.exe /prepareschema /IAcceptExchangeServerLicenseTerms
    setup.exe /preparead /IAcceptExchangeServerLicenseTerms
    setup.exe /PrepareDomain /IAcceptExchangeServerLicenseTerms

    2 марта 2018 г. 13:35
  • на одном только

    scientia potentia est
    My blog

    • Помечено в качестве ответа m1148 2 марта 2018 г. 14:45
    2 марта 2018 г. 13:39