none
IIS 6.0 совместимость с сайтами, работающие на IIS 5.1 RRS feed

  • Общие обсуждения

  • Есть машина, на которой установлен Виндувс ХП, там же установлен IIS через добавление компонентов. был развернут сайт который прекрасно работает.

    Есть и другая машина, с Windows 2008 R2 на которой установлен IIS 6.0, на которой сайт ведет себя совсем некорректно. то проблемы с входом в меню, то некоторые кнопки совсем не кликабельны.

    подскажите в чем может быть проблема?

    13 марта 2014 г. 12:24

Все ответы

  • На win 2008R2 IIS 7.5. Попробуйте для пулов выставить "Managed pipeline mode" в classic.
    13 марта 2014 г. 12:52
  • Не подскажите, где или как это выставлять?

    -нашел

    • Изменено Magals 13 марта 2014 г. 13:39
    13 марта 2014 г. 13:33
  • Почитайте тут. Вам нужно настроить Режим управляемого конвейера выставить Классический.



    13 марта 2014 г. 13:39
  • непомогло
    13 марта 2014 г. 13:44
  • Проверьте логи на предмет ошибок с этим приложением.
    13 марта 2014 г. 14:00
  • есть сайт с авторизацией(написан на асп). при попытке нажать кнопку вход появляется это окно. при это на xp все работает
    16 марта 2014 г. 17:18
  • 1. Убедитесь, что COM-компонент с CLSID {48EE4DBA-DE11-4AF2-83B9-1F7FD6B6B3E3} у вас в системе установлен (AFAIK это коннектор "1С:Предприятия 8.x").

    2. Включите настройку "Разрешены 32-разрядные приложения" в  "Дополнительных параметрах" пула приложений, в котором рамещено ваше приложение.


    Слава России!

    16 марта 2014 г. 18:30
  • включил поддержку 32-х. вход выполняется, однако некоторые кнопки на сайте так и не работают. и ИЕ пишет что страница загружена с ошибками:

     
    16 марта 2014 г. 23:39
  • Чтобы изолировать ошибки на клиенте (в браузере) от ошибок на сервере, проверьте, как работает приложение, если подключаться к веб-серверу с клиента, работающего под XP (например, с того, где раньше было развернуто это приложение).

    Если там будет все нормально, то попробуйте на сервере Win2K8 R2 использовать IE с другой разрядностью (там есть 32-битный и 64-битный варианты).


    Слава России!


    • Изменено M.V.V. _ 17 марта 2014 г. 0:22
    17 марта 2014 г. 0:19
  • Добрый день, Magals.

    Вам удалось решить проблему?


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    19 марта 2014 г. 8:35
    Модератор
  • заходил и через 64 и через 32. проблема остается. в добавок выходит такая ошибка, когда происходщит добавление записи в базу. опять же на XP все работает
    25 марта 2014 г. 7:54
  • Поясните, а то я так и не понял: работает ли приложение в конфигурации, когда веб-сервер с приложением работает на Win2K8 R2,  а клиент (браузер), запускается с XP?

    Слава России!

    25 марта 2014 г. 10:40
  • Поясните, а то я так и не понял: работает ли приложение в конфигурации, когда веб-сервер с приложением работает на Win2K8 R2,  а клиент (браузер), запускается с XP?

    Слава России!


    я приложение устанавил на машину с XP и на  Win Server 2008 R2. И через localhost проверяю как оно работает. На XP все замечательно работает, на  Server 2008 нет. И как понимаю все упирается в IIS на Server 2008
    25 марта 2014 г. 10:53
  • А я вас спрашиваю, что будет, если установить приложение на Win2K8 R2 и подключаться к нему браузером из XP (не по localhost, естественно, а по имени сервера). Смысл вопроса - найти, где возникает ошибка: в IIS или в браузере. Для этого предлагается использовать заведомо правильно работащий браузер в XP.


    Слава России!

    26 марта 2014 г. 20:37