none
Восстановление сайта из шаблона RRS feed

  • Вопрос

  • Добрый день. Прошу помощи.

    Имею портал на Sharepoint Online. На этот портал нужно перенести сторонний сайт. Владелец сохранил его как шаблон с включенным контентом. Создал на портале новый сайт, пытаюсь загрузить шаблон - система выдаёт ошибку «К сожалению, что-то пошло не так. Возникла неожиданная ошибка»

    Пробовал создать новый сайт, сохранить его как шаблон и залить обратно, для того, чтобы протестировать работоспособность данной функции на нашем портале. Уже на этапе сохранения шаблона Sharepoint выдал аналогичную ошибку «что-то пошло не так...»

    Перед этим общался с техподдержкой, так же по поводу переноса портала, и один из ответов был следующим:

    Я обнаружил следующие ошибки на наших серверах: 
    Failed to open the file 'c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\Template\Features\PortalLayouts\Resources\Resources.ru-RU.resx'.
    Failed to read resource file "c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\Template\Features\PortalLayouts\Resources\Resources.ru-RU.resx" from feature id "5f3b0127-2f1d-4cfd-8dd2-85ad1fb00bfc".
    Failed to read resource file "c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\Template\Features\PortalLayouts\Resources\Resources.resx" from feature id "5f3b0127-2f1d-4cfd-8dd2-85ad1fb00bfc".
    Online: Failed to get default snapshot due to exception. Message: Value cannot be null.  Parameter name: spContext StackTrace:    at Microsoft.SharePoint.Flighting.Runtime.VariantConfigurationOnline.GetDefaultSnapshot(SPContext spContext)
    Online: Failed to get feature SPX_GU27 because snapshot is null
    Message=Error in Auditing Schema Validation;Property=UserId;Value=;Operation=FileFetched
    Leaving Monitored Scope: (SPRequest.EnableModuleFromXml) Execution Time=464.1116; CPU Milliseconds=144; SQL Query Count=33; Parent=Feature Activation: Activating Feature 'SearchWebParts' (ID: 'eaf6a128-0482-4f71-9a2f-b1c650680e77') at URLhttps://***.sharepoint.com/sites/<PII:H1(UyThs791VAtwy7DBveKHbZ73CM7RnNtpenxYI7xKO7M=)>.

    Как вариант получения дополнительной информации по вопросу, Вы можете обратиться на наш форум разработчиков.

    Прошу подсказать, в чём может быть проблема и как её можно попробовать решить. Заранее спасибо!


    2 июля 2015 г. 15:08

Ответы

Все ответы

  • Добрый день,

    скорее всего в шаблоне идет зависимость от доустановленных фич, которые не были перенесены на новый портал.

    Найдите фичи с ID: 5f3b0127-2f1d-4cfd-8dd2-85ad1fb00bfc и eaf6a128-0482-4f71-9a2f-b1c650680e77 и установите их на своем портале.

    2 июля 2015 г. 15:57
  • Но это не форум разработчиков SharePoint, это форум разработчиков собственного ПО для стека MicroSoft. Чем больше информации от вас получим, тем быстрее локализуем проблему.

    P.s. проверил futures ID: первая связана с Enterprise masterpages, вторая SearchWebPart.

    2 июля 2015 г. 16:06
  • Спасибо, завтра попробую доустановить данные компоненты. Но вообще странно, когда только получил шаблон сайта и попробовал его накатить, получил ошибку, в которой так и говорилось - для завершения операции не хватает компонентов со следующими ID...
    2 июля 2015 г. 19:34