none
Не устанавливается Exchange 2007 sp1 после удаления его же самого. RRS feed

  • Вопрос

  • Добрый день! Возникла проблема,
    не могу заново установить Exchange 2007 sp1 после удаления его же самого, выдает следующую ошибку:


    Общие сведения: всего элементов: 5. Успешно: 0, с ошибками: 1.
    Прошло времени: 00:00:02


    Копирование файлов Exchange
    Ошибка

    Ошибка:
    Ошибка установки продукта D:\netshare\Дистрибутивы\sp1\exchangeserver.msi. Это действие допускается только для установленных продуктов. Код ошибки 1605.

    Это действие допускается только для установленных продуктов


    При удалении не смог удалить роль Transport, сносил вручную, удалил все папки, службы, а так всю ветку Exchange с помощью ADSIEDIT.

    Нигде о подобной ощибки никакой информации  не нашел, видноя я че-то накосячил (((((.
    Посоветуте что-нибудь, гуру, кроме переустановки системы? ))))




    • Перемещено Hengzhe Li 12 марта 2012 г. 10:43 forum merge (От:Exchange Server 2007)
    4 апреля 2008 г. 5:24

Ответы

  •  Хубо написано:
    приведите полный лог ошибки установки, когда запускаете установку из чистого EX07


    Да я вроде приводил на предыдущей странице, но уже все  - помогла только полная переинсталяция сервера (((.

    Всем спасибо!
    18 апреля 2008 г. 7:18

Все ответы

  • setup.exe тоже самое говорит?

    4 апреля 2008 г. 5:46
  •  melcin написано:

    setup.exe тоже самое говорит?



    Так это он и говорит
    4 апреля 2008 г. 5:57
  •  fbird1 написано:
    Ошибка:
    Ошибка установки продукта D:\netshare\Дистрибутивы\sp1\exchangeserver.msi. Это действие допускается только для установленных продуктов. Код ошибки 1605.

    Это действие допускается только для установленных продуктов



    Приведите полностью ошибку из Event log

    4 апреля 2008 г. 5:57
  •  melcin написано:

    Приведите полностью ошибку из Event log



    В Event Log вообще ничего на эту тему нет ((((
    4 апреля 2008 г. 6:51
  •  fbird1 написано:
    не могу заново установить Exchange 2007 sp1 после удаления его же самого, выдает следующую ошибку
    а вы пробовали запускать с параметрами восстановления?

    Setup /m:RecoverServer

    более подробнее тут: http://technet.microsoft.com/en-us/library/aa998656(EXCHG.80).aspx

    хотя наверное после правки через adsiedit это уже может не помочь...

     

    сделайте еще раз все рекомендации по подготовке домена вручную.

    затем перезапустите установку.

    убедитесь что удаление произведено полностью... запустите еще раз команду

    Setup /mode:Uninstall

    вы случайно не на контролер домена пытаетесь поставить?

     

    4 апреля 2008 г. 6:53
  •  D.Ilyin написано:

     fbird1 написано:
    не могу заново установить Exchange 2007 sp1 после удаления его же самого, выдает следующую ошибку
    а вы пробовали запускать с параметрами восстановления?

    Setup /m:RecoverServer

    более подробнее тут: http://technet.microsoft.com/en-us/library/aa998656(EXCHG.80).aspx

    хотя наверное после правки через adsiedit это уже может не помочь...

     

    сделайте еще раз все рекомендации по подготовке домена вручную.

    затем перезапустите установку.

    убедитесь что удаление произведено полностью... запустите еще раз команду

    Setup /mode:Uninstall

    вы случайно не на контролер домена пытаетесь поставить?

     



    RecoverServer пробовал, не помогло,

    Подготовить домен вручную сейчас попробую, ставлю на контроллер, знаю что не рекомендуется, но других вариантов нет.
    4 апреля 2008 г. 7:03
  • Сделал все, не помогает. Такое впечатление, что в реестре где-нить ключик сидит какой то и все портит (((
    4 апреля 2008 г. 7:46
  • посмотрите тут:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchange

    может что нибудь осталось?

    эспортируйте а потом удалите эту ветку...

    после чего перезагрузитесь и запустите установку еще раз.

     

    4 апреля 2008 г. 8:25
  • Везде где мог уже все потер, не помогает (((
    4 апреля 2008 г. 9:16
  • Вот setup log че пишет:


    [04.04.2008 13:20:06] [0] Starting Microsoft Exchange 2007 Setup
    [04.04.2008 13:20:06] [0] **********************************************
    [04.04.2008 13:20:06] [0] Operating System version: Microsoft Windows NT 5.2.3790 Service Pack 2.
    [04.04.2008 13:20:06] [0] Setup version: 8.1.240.6.
    [04.04.2008 13:20:06] [0] Logged on user: FMG\administrator.
    [04.04.2008 13:20:07] [0] Command Line Parameter Name='mode', Value='Install'.
    [04.04.2008 13:20:07] [0] Command Line Parameter Name='sourcedir', Value='D:\netshare\Дистрибутивы\sp1'.
    [04.04.2008 13:20:07] [0] Command Line Parameter Name='fromsetup', Value=''.
    [04.04.2008 13:20:07] [0] ExSetupUI was started with the following command: '-mode:install -sourcedirBig Smile:\netshare\Дистрибутивы\sp1 /FromSetup'.
    [04.04.2008 13:20:08] [0] Setup is choosing the domain controller to use
    [04.04.2008 13:20:08] [0] Setup is choosing a local domain controller...
    [04.04.2008 13:20:10] [0] Setup has chosen the local domain controller adc.FMG.local for initial queries
    [04.04.2008 13:20:11] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use adc.FMG.local
    [04.04.2008 13:20:11] [0] Setup is choosing a global catalog...
    [04.04.2008 13:20:11] [0] Setup has chosen the global catalog server adc.FMG.local.
    [04.04.2008 13:20:11] [0] Setup will use the domain controller 'adc.FMG.local'.
    [04.04.2008 13:20:11] [0] Setup will use the global catalog 'adc.FMG.local'.
    [04.04.2008 13:20:11] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=FMG,DC=local'.
    [04.04.2008 13:20:11] [0] Exchange organization container for the organization is 'CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=FMG,DC=local'.
    [04.04.2008 13:20:11] [0] Setup will search for an Exchange Server object for the local machine with name 'ADC'.
    [04.04.2008 13:20:11] [0] No Exchange Server with identity 'ADC' was found.
    [04.04.2008 13:20:11] [0] The following roles are unpacked:
    [04.04.2008 13:20:11] [0] The following roles are installed:
    [04.04.2008 13:20:11] [0] The local server does not have any Exchange files installed.
    [04.04.2008 13:20:11] [0] Setup will use the path 'D:\netshare\Дистрибутивы\sp1' for installing Exchange.
    [04.04.2008 13:20:11] [0] The server is cluster type: 'None'.
    [04.04.2008 13:20:11] [0] The requested cluster type: 'None'.
    [04.04.2008 13:20:11] [0] The installation mode is set to: 'Install'.
    [04.04.2008 13:20:11] [0] An Exchange organization with name 'First Organization' was found in this forest.
    [04.04.2008 13:20:11] [0] Active Directory Initialization status : 'True'.
    [04.04.2008 13:20:11] [0] Schema Update Required Status : 'False'.
    [04.04.2008 13:20:11] [0] Organization Configuration Update Required Status : 'False'.
    [04.04.2008 13:20:11] [0] Domain Configuration Update Required Status : 'False'.
    [04.04.2008 13:20:11] [0] Applying default role selection state
    [04.04.2008 13:20:12] [0] Setup is determining what organization-level operations to perform.
    [04.04.2008 13:20:12] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
    [04.04.2008 13:20:12] [0] Setup will run from path 'D:\netshare\Дистрибутивы\sp1\Setup\ServerRoles\Common'.
    [04.04.2008 13:20:12] [0] InstallModeDataHandler has 3 DataHandlers
    [04.04.2008 13:20:12] [0] Setup is determining what organization-level operations to perform.
    [04.04.2008 13:20:12] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
    [04.04.2008 13:20:12] [0] Setup will run from path 'D:\netshare\Дистрибутивы\sp1\Setup\ServerRoles\Common'.
    [04.04.2008 13:20:12] [0] InstallModeDataHandler has 4 DataHandlers
    [04.04.2008 13:20:12] [0] Setup is determining what organization-level operations to perform.
    [04.04.2008 13:20:12] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
    [04.04.2008 13:20:12] [0] Setup will run from path 'D:\netshare\Дистрибутивы\sp1\Setup\ServerRoles\Common'.
    [04.04.2008 13:20:12] [0] InstallModeDataHandler has 5 DataHandlers
    [04.04.2008 13:20:12] [0] Setup is determining what organization-level operations to perform.
    [04.04.2008 13:20:12] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
    [04.04.2008 13:20:12] [0] Setup will run from path 'D:\netshare\Дистрибутивы\sp1\Setup\ServerRoles\Common'.
    [04.04.2008 13:20:12] [0] InstallModeDataHandler has 5 DataHandlers
    [04.04.2008 13:20:12] [0] RootDataHandler has 1 DataHandlers
    [04.04.2008 13:20:23] [0] Validating options for the 0 requested roles
    [04.04.2008 13:20:23] [0] Validating options for the 0 requested roles
    [04.04.2008 13:20:25] [0] **************
    [04.04.2008 13:20:25] [0] Setup will run the task 'test-setuphealth'
    [04.04.2008 13:20:26] [1] Setup launched task 'test-setuphealth -DomainController 'adc.FMG.local' -DownloadConfigurationUpdates $true -ExchangeVersion '8.1.240.6' -Roles 'Bridgehead' -ScanType 'PrecheckInstall' -SetupRoles 'AdminTools','Bridgehead','ClientAccess','Mailbox' -TargetDir 'C:\Program Files\Microsoft\Exchange Server'' 
    [04.04.2008 13:20:26] [1] Beginning processing.
    [04.04.2008 13:20:38] [1] Beginning processing.
    [04.04.2008 13:20:38] [1] Параметры сеанса Active Directory администратора:  Просмотреть весь лес: "True", Контроллер домена конфигурации: "adc.FMG.local", Предпочтительный глобальный каталог: "adc.FMG.local", Предпочтительные контроллеры домена: "{ adc.FMG.local }"
    [04.04.2008 13:20:38] [1] Searching objects of type "SmtpSendConnectorConfig" with filter "$null", scope "SubTree" under the root "Administrative Groups".
    [04.04.2008 13:20:38] [1] Previous operation run on domain controller 'adc.FMG.local'.
    [04.04.2008 13:20:38] [1] Preparing to output objects. Maximum result set size "unlimited".
    [04.04.2008 13:20:38] [1] Ending processing.
    [04.04.2008 13:20:38] [1] [WARNING] Программе установки не удается определить соединитель SMTP или соединитель отправки с адресным пространством "*". Поток почты в Интернет может отправляться неправильно.
    [04.04.2008 13:20:38] [1] Ending processing.
    [04.04.2008 13:20:38] [0] **************
    [04.04.2008 13:20:38] [0] Setup will run the task 'test-setuphealth'
    [04.04.2008 13:20:38] [1] Setup launched task 'test-setuphealth -DomainController 'adc.FMG.local' -DownloadConfigurationUpdates $false -ExchangeVersion '8.1.240.6' -Roles 'ClientAccess' -ScanType 'PrecheckInstall' -SetupRoles 'AdminTools','Bridgehead','ClientAccess','Mailbox' -TargetDir 'C:\Program Files\Microsoft\Exchange Server' -IISInstalled $true' 
    [04.04.2008 13:20:38] [1] Beginning processing.
    [04.04.2008 13:20:43] [1] Ending processing.
    [04.04.2008 13:20:43] [0] **************
    [04.04.2008 13:20:43] [0] Setup will run the task 'test-setuphealth'
    [04.04.2008 13:20:43] [1] Setup launched task 'test-setuphealth -DomainController 'adc.FMG.local' -DownloadConfigurationUpdates $false -ExchangeVersion '8.1.240.6' -Roles 'Mailbox' -ScanType 'PrecheckInstall' -SetupRoles 'AdminTools','Bridgehead','ClientAccess','Mailbox' -CreatePublicDB $true -TargetDir 'C:\Program Files\Microsoft\Exchange Server' -IISInstalled $true' 
    [04.04.2008 13:20:43] [1] Beginning processing.
    [04.04.2008 13:20:48] [1] Ending processing.
    [04.04.2008 13:22:08] [0] Setup is determining what organization-level operations to perform.
    [04.04.2008 13:22:08] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
    [04.04.2008 13:22:08] [0] Setup will run from path 'D:\netshare\Дистрибутивы\sp1\Setup\ServerRoles\Common'.
    [04.04.2008 13:22:08] [0] InstallModeDataHandler has 5 DataHandlers
    [04.04.2008 13:22:08] [0] RootDataHandler has 1 DataHandlers
    [04.04.2008 13:22:09] [0] **************
    [04.04.2008 13:22:09] [0] Setup will run the task 'install-msipackage'
    [04.04.2008 13:22:09] [1] Setup launched task 'install-msipackage -logfile 'C:\ExchangeSetupLogs\ExchangeSetup.msilog' -targetdirectory 'C:\Program Files\Microsoft\Exchange Server' -features 'AdminTools','Bridgehead','ClientAccess','Mailbox' -packagepath 'D:\netshare\Дистрибутивы\sp1\exchangeserver.msi' -updatesdir 'D:\netshare\Дистрибутивы\sp1\Updates' -PropertyValues 'DISABLEERRORREPORTING=0 PRODUCTLANGUAGELCID=1049 DEFAULTLANGUAGENAME=RUS DEFAULTLANGUAGELCID=1049 INSTALLCOMMENT="Установленный язык для этого продукта: Russian (Russia)"'' 
    [04.04.2008 13:22:09] [1] Beginning processing.
    [04.04.2008 13:22:09] [1] ProductCode is '24b2c164-de66-44fe-b468-a46d9d5e6b31'.
    [04.04.2008 13:22:09] [1] PackagePath was set to 'D:\netshare\Дистрибутивы\sp1\exchangeserver.msi'; normalizing to 'D:\netshare\Дистрибутивы\sp1\exchangeserver.msi'.
    [04.04.2008 13:22:10] [1] ProductCode is '24b2c164-de66-44fe-b468-a46d9d5e6b31'.
    [04.04.2008 13:22:10] [1] Installing MSI package 'D:\netshare\Дистрибутивы\sp1\exchangeserver.msi'.
    [04.04.2008 13:22:10] [1] [ERROR] Unexpected Error
    [04.04.2008 13:22:10] [1] [ERROR] Installing product D:\netshare\Дистрибутивы\sp1\exchangeserver.msi failed. Это действие допускается только для установленных продуктов. Error code is 1605.
    [04.04.2008 13:22:10] [1] [ERROR] Это действие допускается только для установленных продуктов
    [04.04.2008 13:22:10] [1] Ending processing.
    [04.04.2008 13:22:14] [0] End of Setup
    [04.04.2008 13:22:14] [0] **********************************************

    4 апреля 2008 г. 10:18
  •  

    Извините, а вы точно устанавливаете E2K7 with SP1 ? А то аткое чувство что он ставит только SP1 .

     

    попробуйте поставить чистый E2K7, а SP1 потом

    4 апреля 2008 г. 10:51
  •  kkvkkv написано:

     

    Извините, а вы точно устанавливаете E2K7 with SP1 ? А то аткое чувство что он ставит только SP1 .

     

    попробуйте поставить чистый E2K7, а SP1 потом



    Да, ставлю E2K7 with SP1, но пробовал и чистый ставить - та же самая ошибка.
    Подозреваю, что где то сидит бяка, котора дает понять установщику, что E27K уже установлен, и он пытается обновить - а не получается.
    4 апреля 2008 г. 10:59
  • Я так понимаю у вас в организации нету больше Exchange .

     

    Что находится в "Active Directory Sites and Services" -> Services -> Microsoft Exchange ?

    4 апреля 2008 г. 11:17
  •  kkvkkv написано:


    Что находится в "Active Directory Sites and Services" -> Services -> Microsoft Exchange ?



    Ну там много чего ))). Я это все удалял через adsiedit, потом пробовал установить Exchange - ошибка что в первом посте, потом выполнил подготовку домена:

    setup /prepareschema
    setup /prepareAD
    setup /prepareDomain

    это все отработало нормально, опять пытаюсь установить - ошибка та же (((
    4 апреля 2008 г. 11:54
  •  

    Если вы полностью удаляете exchange из домена то в этой папке ничего быть не должно
    4 апреля 2008 г. 12:07
  • приведите полный лог ошибки установки, когда запускаете установку из чистого EX07
    18 апреля 2008 г. 6:22
  •  Хубо написано:
    приведите полный лог ошибки установки, когда запускаете установку из чистого EX07


    Да я вроде приводил на предыдущей странице, но уже все  - помогла только полная переинсталяция сервера (((.

    Всем спасибо!
    18 апреля 2008 г. 7:18
  • Подскажите, пожалуйста, после удаления exchange 2007 x64 ru и установки exchange 2007 SP1 x64 ru на Windows 2003 Server SP2 x64 ru, во время подготовки установки в разделе "Роль транспортного сервера-концентратора" выскакивает предупреждение:
    "Программе установки не удается определить соединитель SMTP или соединитель отправки с адресным пространством "*". Поток почты в Интернет может отправляться неправильно."

    Как это исправить?
    3 декабря 2008 г. 14:44
  • Немного позднова-то конечно. Но не было ли случаем "свежего" архива System State контроллера домена? Очень возможно, что после его восстановления сработала бы установка с ключом recovery.

    4 декабря 2008 г. 17:28
  • Всё решается очень просто.
    Взял из лога сообщение об ошибке, вытащил из него ProductCode.
    В вашем логе - это:

    ProductCode is '24b2c164-de66-44fe-b468-a46d9d5e6b31'.

    Запустил поиск по реестру и почистил всё что относится к этому значению.
    И всё заработало.

    • Предложено в качестве ответа pashacap 18 мая 2009 г. 16:39