none
Не работает RDP после установки vipnet csp на windows server 2012r2 RRS feed

  • Вопрос

  • Добрый день!

    Настроили RDS на windows server 2012 r2 (пока что триальные 120 дней). После установки криптопровайдера vipnet csp и последующей перезагрузки пропадает возможность подключиться к серверу по RDP. В логах сервера в этот момент появляются ошибки вида:

    Оповещение о неустранимой ошибке было создано и отправлено удаленной конечной точке. Это может привести к разрыву соединения. Определенный в протоколе TLS код оповещения о неустранимой ошибке: 80. Состояние ошибки Windows SChannel: 1250.

    При каждой попытке соединения, их появляется 3 штуки с разными Windows SChannel (еще бывают 1050 и 603). Если в настройках vipnet убрать галочку "microsoft crypto api", ничего не происходит (так же не подключиться, в логах те же ошибки). После удаления vipnet, подключение проходит с первого раза. Подключаемся по белому ip (по локалке так же пробовали, те же ошибки). Из версий vipnet пробовали 4.0, 4.1(бета), 3.2(после нее виртуалка вывалилась в синий экран, анализ крэшдампа указал на драйвер itckcng64.sys). Куда копать дальше?

    20 октября 2014 г. 5:59

Ответы

Все ответы

  • Куда копать дальше?

    1.Обратиться в тех.поддержку Vipnet.

    2. Попробовать изменить уровень шифрования RDP соединений, например на "Совместимый с клиентским"("Client Compatible"), если будет работать, использовать как временное решение.

    20 октября 2014 г. 6:52
    Отвечающий
  • Куда копать дальше?

    1.Обратиться в тех.поддержку Vipnet.

    2. Попробовать изменить уровень шифрования RDP соединений, например на "Совместимый с клиентским"("Client Compatible"), если будет работать, использовать как временное решение.


    п2. уже пробовали. Так же не помогает. В техподдержку обратились сегодня утром, у них пока решений нет, думают. На форуме vipnet полно вопросов касаемо работы vipnet и windows 8\server 2012. Ответов на них техподдержка не дает.
    20 октября 2014 г. 7:18
  • За последние полгода было несколько обновлений, которые повлияли на крипто подсистему Windows, как следствие некоторое крипто ПО пострадало.

    В частности было обновление https://support.microsoft.com/kb/2973337?wa=wsignin1.0, которое включило sha512. Попробуйте удалить обновление или выключить sha512.


    Сазонов Илья http://isazonov.wordpress.com/

    25 октября 2014 г. 15:45
    Модератор
  • мне помогло вот это решение:

    В ветке реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\

    отредактируйте параметр Security Packages:

    замените sspp или itcssp на schannel и перезагрузитесь.

    В Windows 8 редактировать нужно подключ OSConfig

    • Предложено в качестве ответа Kislov-EA 15 июля 2020 г. 2:09
    15 июля 2020 г. 2:08