none
Отсутствует подключение к Microsoft Exchange RRS feed

  • Вопрос

  • Получаю "стандартное" сообщение об ошибке при попытке подключить оутлук к MS Exchange 2013 CU7:

    Отсутствует подключение к Microsoft Exchange. Для завершения операции требуется постоянное или временное подключение Outlook к серверу.

    Это происходит с клиентских машин. А если подключаться с сервера терминалов (2008 r2) к тому же серверу, то все проходит нормально.

    Вопрос - куда копать?

    26 января 2015 г. 7:55

Ответы

  • Антивирус?

    Если зайти под пользователем на проблемной машине, у которого все работает на соседей, тоже проблемы? И на оборот.

    • Помечено в качестве ответа Aleksey Shimanov 27 января 2015 г. 13:44
    26 января 2015 г. 12:05

Все ответы

  • Навскидку: Сертификаты, сетевые проблемы. Вы мало предоставили информации для анализа. В одной подсети рабочие станции и серверы Exchange? Какие сертификаты используются Exchange? Попробуйте подключиться посредством OWA.

    Do not multiply entities beyond what is necessary

    26 января 2015 г. 8:12
  • Локальная сеть 10.67.0.0-10.67.1.255 (все станции физически в одной сети), пинги идут, tracert работает, DNS работает в обе стороны, брендмауэр на сервере эксченжа выключен. Есть локальный центр сертификатов - работает с самоподписным сертификатом, эксченж работает с сертификатом выданным локальным ЦС. Через Web - почта работает (OWA).

    Антивирус не установлен.

    26 января 2015 г. 8:47
  • Версии клиентов на рабочей станции и на сервере терминалов (откуда вы показали успешное подключение тестового пользователя) одинаковы?

    Do not multiply entities beyond what is necessary

    26 января 2015 г. 10:05
  • Офис на раб. станциях совпадает с терминалом, пробовали и другие версии офиса, результат тот же.

    26 января 2015 г. 11:04
  • версия ОС на рабочей станции, откуда было неудачное подключение какая?

    Do not multiply entities beyond what is necessary

    26 января 2015 г. 11:10
  • Windows 8.x x64

    В процессе "ковыряния" нашел несколько unhealth статусов:

    [PS] C:\Users\Shimanov\Desktop>Get-HealthReport -Server rd-s-exchange | where { $_.alertvalue -ne "Healthy" }

    Server              State               HealthSet           AlertValue          LastTransitionTime  MonitorCount
    ------              -----               ---------           ----------          ------------------  ------------
    rd-s-exchange       NotApplicable       MailboxTransport    Unhealthy           23.01.2015 12:09:03 27
    rd-s-exchange       NotApplicable       Network             Unhealthy           20.01.2015 10:31:07 3
    rd-s-exchange       NotApplicable       FfoMonitoring       Disabled            01.01.0001 3:00:00  23

    [PS] C:\Users\Shimanov\Desktop>Get-ServerHealth rd-s-exchange | ?{$_.HealthSetName -eq "MailboxTransport"} | ft name,alertvalue

    Name                                                                                                         AlertValue
    ----                                                                                                         ----------
    Mapi.Submit.Monitor                                                                                           Unhealthy
    TransportDeliveryFailuresDeliveryStoreDriver560Monitor                                    Disabled

    [PS] C:\Users\Shimanov\Desktop>Get-ServerHealth rd-s-exchange | ?{$_.HealthSetName -eq "network"} | ft name,alertvalue

    Name                                                                                                         AlertValue
    ----                                                                                                         ----------
    NetworkAdapterRssMonitor                                                                                      Unhealthy

    Насколько я понимаю это не криминал?

    Еще уточнения, часть клиентских машин подключается к серверу без проблем, Windows 8.x x64, но офис 32 битный (2010). Причем подключаются опять таки не все... Доходит до смешного - одна машина подключается, а соседняя нет. :(

    Windows XP виснет на запросе пароля пользователя (может и не виснет, но в течении 5 минут отклика не было, дальше ждать не стал).

    Все обновления ставятся через WSUS сервер.

    26 января 2015 г. 11:59
  • Антивирус?

    Если зайти под пользователем на проблемной машине, у которого все работает на соседей, тоже проблемы? И на оборот.

    • Помечено в качестве ответа Aleksey Shimanov 27 января 2015 г. 13:44
    26 января 2015 г. 12:05
  • Прокси-сервер есть в сети?? Включен на проблемных машинах??

    И еще, с проблемных машин сделайте тестирование подключения и скрин покажите.

    26 января 2015 г. 12:31
  • Антивирус?

    Если зайти под пользователем на проблемной машине, у которого все работает на соседей, тоже проблемы? И на оборот.

    Судя по всему вы правы... Буду экспериментировать в этом направлении.

    27 января 2015 г. 6:09
  • Прокси-сервер есть в сети?? Включен на проблемных машинах??

    И еще, с проблемных машин сделайте тестирование подключения и скрин покажите.

    Есть, как правило настраивается в IE, в качестве шлюза по умолчанию у основной массы компьютеров указан не прокси, а роутер.

    Однозначно не из-за сетевых проблем. Это мы уже выяснили. Как указал RK3DNP скорее всего дело в антивирусе, у него есть аддон, который к оутлуку подключается, попробуем с ним повозиться.

    27 января 2015 г. 6:12
  • У Вас не дрвеб случаем 10 версия?? У него есть проблема с тем, что он пытается проверять PST файлы, при этом сам аутлук конечно не может получить доступ к нему. 

    Про сетевые проблемы зря Вы так..  Если в проксе не прописано в исключениях сервер Exchange, то точно такая же проблема получается. И если Вы заходите на проблемную машину под другим юзером у кого как раз нет прокси, то у Вас конечно все сразу срабатывает. 

    27 января 2015 г. 6:42
  • Нет, от вебера мы ушли, сейчас используется G-Data.

    Дело в том, что проблема при подключении из локальной сети, про наружный доступ речи пока не идет. А в проксе прописано, что любой локальный трафик разрешен.

    Еще раз просмотрю сетевые настройки. Но на мой взгляд, либо есть проблемы с сетью, либо их нет... Промежуточных состояний не бывает.

    27 января 2015 г. 7:32
  • А причем тут "снаружи"?? Именно в локалке и надо добавлять в исключения. Чтобы трафик не на роутер шел, а на сервер напрямую. К сожалению, Exch не такое ПО, которое " либо есть проблемы с сетью, либо их нет..."

    "А в проксе прописано, что любой локальный трафик разрешен.

     А вот это как?? галка что и стоит?? Она ни о чем, я Вам говорю, пропишите в исключения ручками https://имя_сервер

    И еще, а у Вас в DNS все прописано?? и Autodiscover(должен быть Псевдоним(CNAME))  тоже??

    27 января 2015 г. 7:42
  • С клиентами под XP дело несколько сложнее. Эта ось своеобразно работает с SAN сертификатами и требует указания CN сертификата в параметре EXPR командлета Set-OutlookProvider.

    Что касается остальных рабочих станций - необходимо, чтобы версии клиентов соответствовали требованиям для Exchange 2013 (здесь)


    Do not multiply entities beyond what is necessary

    27 января 2015 г. 7:50
  • Подводя итоги - виноват Антивирус G Data. Сносим - подключается без вопросов. Поэтому будем разбираться что и как с ним делать, в крайнем случае снесем, создадим учетку оутлука, поставим антивирь.


    27 января 2015 г. 15:31
  • А причем тут "снаружи"?? Именно в локалке и надо добавлять в исключения. Чтобы трафик не на роутер шел, а на сервер напрямую. К сожалению, Exch не такое ПО, которое " либо есть проблемы с сетью, либо их нет..."

    "А в проксе прописано, что любой локальный трафик разрешен.

     А вот это как?? галка что и стоит?? Она ни о чем, я Вам говорю, пропишите в исключения ручками https://имя_сервер

    И еще, а у Вас в DNS все прописано?? и Autodiscover(должен быть Псевдоним(CNAME))  тоже??

    1. На проксе прописано (а не галка стоит), что разрешены любые проктоколы внутри локальных адресов.

    2. В DNS ничего не прописано. Сервер дисковерится и клиент коннектится (уже) нормально. Я не спец по эксченджу (я только учусь), это рекомендация микрософта?

    27 января 2015 г. 15:35
  • С клиентами под XP дело несколько сложнее. Эта ось своеобразно работает с SAN сертификатами и требует указания CN сертификата в параметре EXPR командлета Set-OutlookProvider.

    Что касается остальных рабочих станций - необходимо, чтобы версии клиентов соответствовали требованиям для Exchange 2013 (здесь)


    Do not multiply entities beyond what is necessary

    Опробовал и XP, сертификат слопала без вопросов, задисковерила и подцепилась нормально, единственно запросила пароль к учетке.

    По поводу клиентов по требованиям не ниже 2007 офиса, на клиентах стоит 2010 или 2013.

    27 января 2015 г. 15:37