none
FTP IIS 7.5 RRS feed

  • Вопрос

  • Установил ftp 7.5 на IIS. Хочу предоставить всем анонимным пользователям доступ на чтение и все.
    ftp authentication: anonymous=enabled и basic=enabled
    ftp authorization rules: anonymous users read allow и all users read allow
    ftp ssl settings: sertificate=not selected и ssl policy= allow connections
    NTFS Разрешения на корневую папку ftp: users, guests,  domain users у всех права на чтение и выполнение.
    Пишет -  "отсутствует доступ к папке, убедитесь что имя файла задано правильно и у вас имеются разрешения на доступ к папке. подробности - не удается установить связь с сервером."    Но служба запущена и с самого сервака локально заходит.
    Пробовал удалять методы аутентификации и добавлять IIS_USRS, анонимный вход к ntfs разрешениям - таже фигня.
    Как решить проблему - уже 4 раз на различных машинах такие грабли с фтп:(
    • Перемещено Nikita Panov 22 сентября 2010 г. 19:06 IIs (От:Windows Server 2008)
    11 декабря 2009 г. 5:22

Ответы

  • не знаю где там в пошаговых инструкциях было назначить NTFS Permissions для Networks Service на чтение папки C:\Windows\system32\inetsrv\config  - но спасибо иисовскому форуму. зато для ftproot сейчас ничего не добавлял - такие же разрешения как на др папки и работает!
    • Помечено в качестве ответа kosmich74 9 сентября 2010 г. 9:42
    8 сентября 2010 г. 20:20

Все ответы

  • А учетная запись, от которой исполняется пул приложений ("Application Pool"), исполняющий сайт (по умолчанию - "IIS APPPOOL\<имя пула приложений>"), имеет доступ к этой папке?..
    11 декабря 2009 г. 7:26
    Отвечающий
  • В общем нашел где собака зарыта :) В разрешениях диспетчера IIS добавить группу Guests и дать ей права на чтение в папке. Просто в мануалах пишется в диспетчере обычно задаются свои пользователи отличные от виндовских...
    А то я уже всем кому тока нельзя дал права к папке и LocalSystem и NetworkService и Users...
    • Помечено в качестве ответа Nikita Panov 17 декабря 2009 г. 11:47
    • Снята пометка об ответе kosmich74 5 сентября 2010 г. 16:15
    11 декабря 2009 г. 10:05
  • красотень а не фтп! каждый раз ставлю каждый раз мучаюсь. минимум часа 3 он мне моск *****. на 2008р2 хочу сотворить фтп с базовой авторизацией без анонимных подключений по AD учеткам. basic autentification включено остальное disabled. в authorization rules делаю allow specific roles or user groups - DomainName\Domain Admins - read\write. В ftp ip4 adress and domain resrictions указываю что allow диапазон 10.196.80.0 mask 255.255.255.0

    на ftproot дал разрешения full access для local и network service, Domain Admins на изменение и IIS_USRS на чтение и выполнение.

    в брандмауэре есть и включены 3 правила для фтп сервера дефолтовые. и хоть тресни пишет - ошибка папки фтп отсутствует доступ к папке, убедитесь что имя файла задано правильно. даже на самом серваке от админа домена не пускает! Data Channel Port Range 50000-65000. IIS Manager Permissions тоже стоит DomainName\Domain Admins. переустановка и перезагрузки не помогают. на серваке стоят контроллер домена с днс и дхцп. я не знаю какой ман мне еще выкурить чтоб эта шняга начала работать :((

    5 сентября 2010 г. 15:50
  • после n-ного раза переустановки служб iis и удаления папок со всеми атрибутами начал пускать на фтп по адовским логинам паролям но только вручную вводя в окошке DomainName\Username - Password не цепляя их с самого сеанса пользователя в винде что в общем то геморойно. решил включить заодно iis manager users и разрешить входить им по своему логину\паролю для тех кто не в домене - не тут то было! пишет что error 530 user cannot logged in . а для ранее работавших адовских учеток тут же началась старя песня что нет прав на папку. через какую Ж это все работает я ваще не пойму)
    7 сентября 2010 г. 18:58
  • Вот подробное описание процесса настройки http://learn.iis.net/page.aspx/305/configuring-ftp-75-user-isolation/

    Я думаю, вы просто что-то пропустили в настройках, а так все предельно просто.


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    8 сентября 2010 г. 7:04
    Модератор
  • не знаю где там в пошаговых инструкциях было назначить NTFS Permissions для Networks Service на чтение папки C:\Windows\system32\inetsrv\config  - но спасибо иисовскому форуму. зато для ftproot сейчас ничего не добавлял - такие же разрешения как на др папки и работает!
    • Помечено в качестве ответа kosmich74 9 сентября 2010 г. 9:42
    8 сентября 2010 г. 20:20