none
ограничение размер внешней почты RRS feed

  • Вопрос

  • Привет всем !

    Корпоративная  сеть на базе Win2k8 R2 серверов. Поднят домен установлен Exchange 2010
    Проблема в следующем:
    Надо увеличить квоту на объем письма и/или вложения:
    в общем делал  как тут сказано: http://social.technet.microsoft.com/Forums/en/exchangesvrgeneral/thread/9c44d4aa-cf81-47dd-ba38-c28171c750e2

    но при этом получилось, что внутри у меня до 24 мегабайт ходит почта, а вот снаружи не приходит уже и 15 Мб. возвращается с ошибкой
    The error that the other server returned was: 552 552 5.3.4 Message size exceeds fixed maximum message size (state 18)
    вот такая конфигурация через PowerShell выдается на почтовик :


    [PS] C:\Windows\system32>Get-TransportConfig

    ClearCategories                                      : True
    DSNConversionMode                                    : UseExchangeDSNs
    ExternalDelayDsnEnabled                              : True
    ExternalDsnDefaultLanguage                           :
    ExternalDsnLanguageDetectionEnabled                  : True
    ExternalDsnMaxMessageAttachSize                      : 10 MB (10,485,760 bytes)
    ExternalDsnReportingAuthority                        :
    ExternalDsnSendHtml                                  : True
    ExternalPostmasterAddress                            :
    GenerateCopyOfDSNFor                                 : {}
    HygieneSuite                                         : Standard
    InternalDelayDsnEnabled                              : True
    InternalDsnDefaultLanguage                           :
    InternalDsnLanguageDetectionEnabled                  : True
    InternalDsnMaxMessageAttachSize                      : 10 MB (10,485,760 bytes)
    InternalDsnReportingAuthority                        :
    InternalDsnSendHtml                                  : True
    InternalSMTPServers                                  : {}
    JournalingReportNdrTo                                : <>
    MaxDumpsterSizePerDatabase                           : 40 MB (41,943,040 bytes)
    MaxDumpsterTime                                      : 7.00:00:00
    MaxReceiveSize                                       : 24.41 MB (25,600,000 bytes)
    MaxRecipientEnvelopeLimit                            : 5000
    MaxSendSize                                          : 24.41 MB (25,600,000 bytes)
    MigrationEnabled                                     : False
    OpenDomainRoutingEnabled                             : False
    Rfc2231EncodingEnabled                               : False
    ShadowHeartbeatRetryCount                            : 3
    ShadowHeartbeatTimeoutInterval                       : 00:05:00
    ShadowMessageAutoDiscardInterval                     : 2.00:00:00
    ShadowRedundancyEnabled                              : True
    OrganizationRelationshipForExternalOrganizationEmail :
    SupervisionTags                                      : {Reject, Allow}
    TLSReceiveDomainSecureList                           : {}
    TLSSendDomainSecureList                              : {}
    VerifySecureSubmitEnabled                            : False
    VoicemailJournalingEnabled                           : True
    HeaderPromotionModeSetting                           : NoCreate
    Xexch50Enabled                                       : True




    [PS] C:\Windows\system32>Get-TransportConfig | fl max*


    MaxDumpsterSizePerDatabase : 40 MB (41,943,040 bytes)
    MaxDumpsterTime            : 7.00:00:00
    MaxReceiveSize             : 24.41 MB (25,600,000 bytes)
    MaxRecipientEnvelopeLimit  : 5000
    MaxSendSize                : 24.41 MB (25,600,000 bytes)


    Помогите пожалуйста разобраться  ? :)


    14 января 2010 г. 14:46

Ответы

  • Проблема в том что в связи с использованием SMTP протокола размер передаваемого по нему письма больше фактического. Соответственно нужно выставлять большее значение для достижения нужного эффекта
    • Помечено в качестве ответа alexsc11Editor 15 января 2010 г. 9:46
    15 января 2010 г. 9:07

Все ответы

  • А как же настройки Internet Send Connector?
    А как же настройки пользователей?

    Ограничения суммируются в данном случае (отправка наружу)
    MCSE
    14 января 2010 г. 19:37
  • Наружу почта 20 мб уходит, а вот снаружи к нам не приходит
    15 января 2010 г. 6:24
  • Какой обем выставлен в Receive Connector ?
    MCP/MCSA/MCTS:Exchange
    15 января 2010 г. 7:14
  • перед Exchange не стоит никакого релея?
    антивирусы, антиспам установлен на сервере ?

    MCP/MCSA/MCTS:Exchange
    15 января 2010 г. 7:33
  • стоит ORF только что поставленный, в течении пары дней приедет Каспер для Exchange больше ничего не стоит, шлюз - ISa 2006 в скоре поменяется на TMG
    15 января 2010 г. 7:44
  • ОRF не может блокировать ?

    MCP/MCSA/MCTS:Exchange
    15 января 2010 г. 8:15
  • 20480 kb

    Попробуйте увеличить до 30
    15 января 2010 г. 8:39
  • Проверял, при выключенном ORF`е такая же ошибка приходит на gmail, при том что у Gmail максимальный объем вложения - 25 МБ

    РЕШИЛ проблему : без бубна не обошлось - в общем есть такая статья:
    http://forums.msexchange.org/552_5%253%254_Message_size_exceeds_fixed_maximum_message_size_:_Im_stumped%25/m_1800488482/tm.htm
    даже форум - в общем там написано, что они тоже пытаются отправить сообщение больше 20 МБ, и там они ставят в Global Settings  - безлимита, а в ресив конекторах ставят по 100 МБ
    У меня в Global settings стоит по 25000 kb на прием и отправку
    В Default Recieve Connector  у меня до этого было значение 20480 kb - было установлено через power shell Exchange 2010 заданием числа 20 МБ (!)
    вот, сейчас я поставил на Default Recive Connector  - значение - 40840 (уже через EMC), и письмо с gmail пришло - внутри аттачмент на 14,6 МБ (15 400 960 байт)

    у меня есть подозрение (могу конечно заблуждатся), но в поле Max Message Size  Recieve Connector что то не то, потому как установка заведомо большего значения приводит к работе ограничений как надо :) вот!
    15 января 2010 г. 8:46
  • пока я писал сообщение, Pavel Dugaev уже написал решение :)
    15 января 2010 г. 8:51
  • Проблема в том что в связи с использованием SMTP протокола размер передаваемого по нему письма больше фактического. Соответственно нужно выставлять большее значение для достижения нужного эффекта
    • Помечено в качестве ответа alexsc11Editor 15 января 2010 г. 9:46
    15 января 2010 г. 9:07