locked
"Требуется настройка веб-консоли" - не настраивается (работает только как localhost) RRS feed

  • Вопрос

  • Поставил для ознакомления SCOM 2012, включил все оповещения.

    Приходит письмо с ссылкой вида https://SCOM/OperationsManager/default.aspx#/web(url='/monitoringview/default.aspx?DisplayMode=Pivot&AlertID=%257b8580fdc8-39e4-4061-b4aa-aa0f16300640%257d')

    Перехожу по ссылке и вижу "Требуется настройка веб-консоли"; нажимаю "настроить"; запускаю файлик; вижу окошко "веб-консоль настроена успешно"; обновляю страницу и снова вижу приглашение настроить консоль...

    Пробовал на разных машинах (Windows 7/2008R2 x64, IE9) везде одно и тоже. Если нажать "пропустить" в основной части консоли вижу "компьютер не настроен, обновите браузер".


    24 октября 2012 г. 5:34

Ответы

  • Решение из поста сверху работает.

    Краткий обзор.

    Надо на сервере заменить файлы на скачанные с вот этой ссылки http://sdrv.ms/W09hGC .

    Потом надо почистить кеш браузера и снова настроить "сильвер", после появления ошибки, обновить (F5).

    28 февраля 2013 г. 4:09

Все ответы

  • Скорее всего у вас UAC отключен, запустите браузер от имени администратора.


    Vladimir Zelenov | http://systemcenter4all.wordpress.com

    24 октября 2012 г. 10:04
    Отвечающий
  • Да, UAC отключен, однако проблема сохраняется и от имени администратора, и от имени другого пользователя...
    24 октября 2012 г. 11:36
  • Попробуйте себе на компьютер скопировать папку C:\Program Files\System Center 2012\Operations Manager\WebConsole\WebHost\ClientBin и запустить SilverlightClientConfiguration.exe.


    Vladimir Zelenov | http://systemcenter4all.wordpress.com


    25 октября 2012 г. 5:14
    Отвечающий
  • Скопировал - эффекта 0; пробовал даже в такую же папочку на своём ПК.
    25 октября 2012 г. 11:12
  • Проверьте настройку зон безопасности в IE. Вебконсоль должна быть в Local Intranet. Если настройки в зоне Local Intranet не менялись - все должно работать нормально.


    http://OpsMgr.ru/

    26 октября 2012 г. 3:54
    Отвечающий
  • У меня на этом же сервере стоят SCDPM 2012 и SCCM 2012. С отчётами проблем нет. С сертификатами тоже. На моём ПК сервер добавлен в "надежные узлы" - уровень защиты низкий, всё разрешено.

    Проблема есть и по https и по http.

    А SilverlightClientConfiguration.exe - это какая то надстройка для IE? просто в IE в надстройках или где-либо еще нет никаких упоминаний об OperationsManager. 


    26 октября 2012 г. 5:46
  • Нет, это не надстройка.

    Включите UAC. Запустите IE от имени администратора. Зайдите на сайт веб-консоли и запустите конфигуратор когда его попросят запустить.


    http://OpsMgr.ru/

    26 октября 2012 г. 9:32
    Отвечающий
  • К сожалению безрезультатно. Пробовал в IE и IE x64, запуская от администратора; пробовал запускать отдельно конфигуратор от Администратора. С включенным UAC и с выключенным.
    29 октября 2012 г. 5:27
  • Объясните пожалуйста кратко, что делает SilverlightClientConfiguration.exe. Может procmon'ом получится увидеть что-нибудь.

    31 октября 2012 г. 8:51
  • Создает сертификат в Trusted Publishers и ключ в реестре

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Silverlight]    
    "AllowElevatedTrustAppsInBrowser"=dword:00000001

    или для 32-битных систем:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Silverlight]    
    "AllowElevatedTrustAppsInBrowser"=dword:00000001


    http://OpsMgr.ru/

    6 ноября 2012 г. 8:57
    Отвечающий
  • Проверил реестр и сертики - всё перечисленное выше есть. В процмоне (запуск IE по ссылке из письма от SCOM) записей о каких-либо отказах в доступе нет. Пробовал переустанавливать silverlight.

    эффекта 0.

    7 ноября 2012 г. 5:57
  • переустановил роль веб-консоли на сервере - на самом сервере если заходить как https://localhost/operationsmanager/ - всё хорошо, но если https://scom/operationmanager - "требуется настройка обозревателя"...

    как так?

    7 ноября 2012 г. 8:07
  • Имею аналогичную проблему.

    https://localhost/operationsmanager/ - всё хорошо.

    Сообщите, пожалуйста, если решили.

    7 ноября 2012 г. 21:48
  • переустановил роль веб-консоли на сервере - на самом сервере если заходить как https://localhost/operationsmanager/ - всё хорошо, но если https://scom/operationmanager - "требуется настройка обозревателя"...

    как так?


    Потому что на локальном сервере уже всё настроено.

    Vladimir Zelenov | http://systemcenter4all.wordpress.com

    13 ноября 2012 г. 8:30
    Отвечающий
  • переустановил роль веб-консоли на сервере - на самом сервере если заходить как https://localhost/operationsmanager/ - всё хорошо, но если https://scom/operationmanager - "требуется настройка обозревателя"...

    как так?


    Потому что на локальном сервере уже всё настроено.

    Vladimir Zelenov | http://systemcenter4all.wordpress.com


    это я на локальном сервере и пробую обе URL. Если на сервере всё настроено, то почему localhost открывается, а <servername> или <serverFQDN> на этом же сервере требуют настройки? Для всех 3х адресов зона "интрасеть", уровень безопасности - ниже среднего.
    14 ноября 2012 г. 5:12
  • Привет, попробуй удалить Web-компонент и установить его заново

    также несколько похожих тем которые могут помочь решить проблему

    http://social.technet.microsoft.com/Forums/en-US/operationsmanagergeneral/thread/546fb6f4-76b1-4832-ba95-02721f2bab0f/

    http://social.technet.microsoft.com/Forums/en-US/operationsmanagergeneral/thread/e16bfea2-eb20-43d2-a3c9-1e30261acedc

     
    14 ноября 2012 г. 18:03
  • Привет, попробуй удалить Web-компонент и установить его заново

    также несколько похожих тем которые могут помочь решить проблему

    http://social.technet.microsoft.com/Forums/en-US/operationsmanagergeneral/thread/546fb6f4-76b1-4832-ba95-02721f2bab0f/

    http://social.technet.microsoft.com/Forums/en-US/operationsmanagergeneral/thread/e16bfea2-eb20-43d2-a3c9-1e30261acedc

     

    1. пробовал - не помогло.

    2. по ссылке 1 - моя учётка и учётка используемая на сервере не входит в "много security groups"; имя моего сервера не содержит символов вроде "_" - SC2012

    3. по ссылке 2 - я не испытываю трудностей с авторизацией; для входа в web-console использую Windows 7 Pro SP1 IE9 либо Windows Server 2008R2 SP1 IE9; и как писал раньше, все ключи и сертификаты на местах т.е. silverlightclientconfiguration.exe отрабатывает корректно (так же проверял procmon'ом).

    P.S. на сервере пробовал открывать консоль по ip: 127.0.0.1 открывается, а 192.168.1.115 (ip сервера) - просит настройку консоли.
    15 ноября 2012 г. 4:36
  • Там ведь и другие решения есть

    1. The solution was to create a entry in DNS which was pointing towards the webserver hosting console. Hope this helps if anyone encounters this strange and bizare error. (именно SCOM) 

    2. Скачать и установить новый Silverlight (еще раз)

    3. Проверить корректность SPNs (http://blogs.technet.com/b/kevinholman/archive/2008/09/24/installing-the-web-console-on-a-2008-management-server-using-windows-authentication.aspx) 

    после всех манипуляций желательно снова удалить IIS и Web компонент SCOM и все переустановить. 

    15 ноября 2012 г. 5:09
  • Все эти решения либо не применимы, либо не помогли. Проблема сохраняется.

    устновил web-консоль на другой сервер - история повторилась: localhost открывается, <servername> требует настройки браузера.

    15 ноября 2012 г. 12:57
  • Без SSL тоже самое?
    15 ноября 2012 г. 13:10
  • Да. На втором сервере специально выполнил установку (переустановку) без использования SSL. Смешно, но localhost открывается, а <servername> просит настроить браузер.
    15 ноября 2012 г. 13:37
  • Привет, попробуй на этом новом сервере установить для начала в ручную SilverLight и уже затем загрузить web консоль через IE и сконфигурировать ее посредством  SilverlightClientConfiguration.exe. Также еще раз проверь SPNs (http://blogs.technet.com/b/stefan_stranger/archive/2012/07/31/opsmgr-2012-what-should-the-spn-s-look-like-visual-representation.aspx). Все должно нормально работать, у себя на нескольких компах потестировал.
    19 ноября 2012 г. 14:42
  • SilverLight я пробовал переустанавливать и на самом SCOP сервере и на втором сервере и на своей рабочей станции; конфигурировал раз 15 и до и после. Не был прописан SPN для http/<servername>:80, 443 - прописал. Поменял учетку запуска SQL инстанса. Снова проверил все SPN, переустановил консоль - не помогло.

    Вернулся к началу - на втором серваке удалил консоль, на основном установил.

    Объясните почему localhost и 127.0.0.1 открываются нормально, а <servername> или <serverip> на самом серваке - дурят?! Я уже не говорю про свою рабочую станцию. Кто проверяет браузер на "настроенность"?

    Может проблема в том, что у меня на серваке есть еще 4 SQL инстанса (SCCM, SCVMM, SCDPM, WSUS)?

    20 ноября 2012 г. 4:53
  • У меня проблема 1 в 1. Так же не могу побороть.

    Переустанавливал IIS, компоненту веб-консоль, silverlight - всё без толку

    Грешу на CU3

    26 декабря 2012 г. 11:22
  • Печально, но установка SP1 не решила проблему...
    28 декабря 2012 г. 5:09
  • Проблема обнаружена, конечного решения нет, но есть обходное: http://social.technet.microsoft.com/Forums/en-US/operationsmanagergeneral/thread/b4145010-ce6c-4ae0-be31-4e97bf7bd1c4

    • Предложено в качестве ответа Vladimir Kovalevskiy 18 ноября 2013 г. 11:07
    24 января 2013 г. 9:25
  • Решение из поста сверху работает.

    Краткий обзор.

    Надо на сервере заменить файлы на скачанные с вот этой ссылки http://sdrv.ms/W09hGC .

    Потом надо почистить кеш браузера и снова настроить "сильвер", после появления ошибки, обновить (F5).

    28 февраля 2013 г. 4:09
  • Да, данный метод работает. Либо ждём апдейт либо используем "обходное" решение
    1 марта 2013 г. 7:57
  • А можно перезалить файл еще раз?
    2 декабря 2019 г. 14:42
  • А можно перезалить файл еще раз?

    Приветствую.

    Уважаемый catbgmt, данная тема отвечена и не актуальна.

    Если у вас вопрос, пожалуйста создайте новую тему.

    Тема закрыта.

    Надеюсь на понимание


    Я не волшебник, только учусь. MCTS, CCNA. Если Вам помог чей-либо ответ, пожалуйста, не забывайте нажать на кнопку "Отметить как ответ" или проголосовать за "полезное сообщение". Disclaimer: Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции работодателя. Вся информация предоставляется как есть, без каких-либо на то гарантий. Блог IT Инженера, Яндекс Дзен, YouTube, GitHub.

    2 декабря 2019 г. 15:14
    Модератор