none
На работает VPN подключение l2tp over IPSEC RRS feed

  • Общие обсуждения

  • Добрый день!

    Внезапно перестало работать соединение с VPN-сервером. Никаких установок или изменений системы не было, только были установлены несколько обновлений в начале января 2019 года.

    После соединения висит окошко Проверка имени пользователя и пароля. В файле C:\Windows\tracing\RASMAN.log последние записи:

    [6624] 01-15 11:38:48:687: ProtocolStart: Domain:
    [6624] 01-15 11:38:48:687: DwCacheCredMgrCredentials
    [6624] 01-15 11:38:48:687: DwCacheCredMgrCredentials: 0x0
    [6924] 01-15 11:38:48:688: ProtocolStarted...VPN2-1

    Никак не можем найти причину. Может кто-то подсказать?

    • Изменен тип Anton Sashev Ivanov 29 января 2019 г. 6:41 Отсутствие активности
    15 января 2019 г. 9:19

Все ответы

  • Добрый день!

    Внезапно перестало работать соединение с VPN-сервером. Никаких установок или изменений системы не было, только были установлены несколько обновлений в начале января 2019 года.

    После соединения висит окошко Проверка имени пользователя и пароля. В файле C:\Windows\tracing\RASMAN.log последние записи:

    [6624] 01-15 11:38:48:687: ProtocolStart: Domain:
    [6624] 01-15 11:38:48:687: DwCacheCredMgrCredentials
    [6624] 01-15 11:38:48:687: DwCacheCredMgrCredentials: 0x0
    [6924] 01-15 11:38:48:688: ProtocolStarted...VPN2-1

    Никак не можем найти причину. Может кто-то подсказать?

    Логи на стороне сервера гляньте, почему не пускает. 
    15 января 2019 г. 9:34
  • Разбирались.

    Производитель сказал, что такой информации у них в логах нет, а мы видим только одну запись :

    2019-01-14T16:45:55+00:00 connect_pppol2tp: Unable to connect UDP peer. Terminating.

    16 января 2019 г. 7:17
  • Разбирались.

    Производитель сказал, что такой информации у них в логах нет, а мы видим только одну запись :

    2019-01-14T16:45:55+00:00 connect_pppol2tp: Unable to connect UDP peer. Terminating.

    На чем VPN поднят? 
    16 января 2019 г. 7:45
  • VPN настроен на сервисном маршрутизаторе esr-200 типа межсетевого экрана cisco, в конфигурации L2TP(IPSec) с белым IP-адресом + доменный ПК клиент Win7SP1x64 в другом городе, у которого подключение доходит до проверки имени пользователя и пароля, далее так висит бесконечно, оставляли на несколько часов.
    17 января 2019 г. 13:57
  • VPN настроен на сервисном маршрутизаторе esr-200 типа межсетевого экрана cisco, в конфигурации L2TP(IPSec) с белым IP-адресом + доменный ПК клиент Win7SP1x64 в другом городе, у которого подключение доходит до проверки имени пользователя и пароля, далее так висит бесконечно, оставляли на несколько часов.

    Я посмотрел по руководству по данному маршрутизатору, там сказано,что аутентификация L2TP over IPSec производится на Radius сервере. 

    Следовательно, из вашего описания, что висит во время проверки, радиус сервер не доступен. ПРоверьте его.  

    Попробуйте создать нового пользователя и попробовать подключиться. Так же советую попробовать выключить firewall и посмотреть, изменится ли ситуация. Что бы исключить блок firewall

    17 января 2019 г. 15:33
  • Настройка L2TP over IPsec имеет два режима аутентификации удаленных пользователей и задается командой authentication mode { local | radius }, у нас local - режим, использующий локальную базу пользователей конфигурируемого профиля, т.е. состоящий из общего PSK ключа с отдельной для каждого связкой логина и пароля.

    Другой ПК подключается без проблем, как и маршрутизатор, пробовали подключаться в другом городе NAT за натом, все прекрасно подключается. Меняли на другого пользователя, выключали firewall, антивирус, сбрасывали Winsock catalog командой netsh winsock reset, в свойствах подключения ставили галочку "обязательное шифрование" и "необязательное", снимали галочку напротив «Сохранить пароль» и пробовали подключиться без этой галочки, в настройках TCP/IP соединения VPN прописывали IP-адрес вручную и автоматически, удаляли VPN соединение и настраивали заново, удаляли все поставленные обновления в этом году. Ничего не помогло.

    До этого этот ПК подключался в прошлом году весь год без проблем.

    18 января 2019 г. 6:36
  • Настройка L2TP over IPsec имеет два режима аутентификации удаленных пользователей и задается командой authentication mode { local | radius }, у нас local - режим, использующий локальную базу пользователей конфигурируемого профиля, т.е. состоящий из общего PSK ключа с отдельной для каждого связкой логина и пароля.

    Другой ПК подключается без проблем, как и маршрутизатор, пробовали подключаться в другом городе NAT за натом, все прекрасно подключается. Меняли на другого пользователя, выключали firewall, антивирус, сбрасывали Winsock catalog командой netsh winsock reset, в свойствах подключения ставили галочку "обязательное шифрование" и "необязательное", снимали галочку напротив «Сохранить пароль» и пробовали подключиться без этой галочки, в настройках TCP/IP соединения VPN прописывали IP-адрес вручную и автоматически, удаляли VPN соединение и настраивали заново, удаляли все поставленные обновления в этом году. Ничего не помогло.

    До этого этот ПК подключался в прошлом году весь год без проблем.

    Проверяли подключение другого компьютера с Windows 7 в этом же домене, нормально подключается, но у него в отличие от проблемного не устанавливались обновления вообще. Возможно дело как раз в них?
    29 января 2019 г. 9:23

  • Проверяли подключение другого компьютера с Windows 7 в этом же домене, нормально подключается, но у него в отличие от проблемного не устанавливались обновления вообще. Возможно дело как раз в них?
    Я бы попробовал удалить обновы до которых работало нормально.  После удаления перезагрузить не забудьте машину
    29 января 2019 г. 9:31
  • Были удалены все обновления установленные в этом году, в том числе конфликтные KB4480960 (Security only) и KB4480970 (Monthly Rollup), о которых писалось, что они вызывают сетевые проблемы. Но они не помогли.

    После них также были удалены KB4480063 и вместе с ним KB971033, о котором писалось, что конфликтует с KB4480960 и KB4480970. Возможно удаление какого-то из них помогло, т.к. стали подключаться, но после перезагрузки одно из них, а именно KB4480063, поставилось вновь, и проблема вернулась. Удалили опять, не помогло, и больше мы его уже не видели (может его убрали или включили в другие), после поиска обновлений не предлагается установить и в скрытых обновлениях его нет. Не исключаем вариант, что все это совпадение, если нет, то выходит обновления поломали систему.

    29 января 2019 г. 11:50
  • Попробуйте командой  wusa /uninstall /kb:номеробновы, выше указанные обновы прогоните этой командой. Может так найдет

    Всё же я бы на вашем месте удалил все обновы, которые ставились за этот месяц и конец декабря и отключить на время проверок Автоматическое обновление, что бы не поставилось сразу. После проверить подключение.

    29 января 2019 г. 14:33