none
Перестали открываться сайты по доменному имени (только по IP) RRS feed

  • Вопрос

  • После обновления системы в браузере перестали открываться сайты по доменному имени, можно зайти только по IP. Win2012Server установлена по умолчанию. Подключили инет, активировались, все работало, обновились - получили проблему.

    Никаких манипуляций с DNS-службами не проводилось, работает штатно. DNS сервер как таковой в ролях не поднимался (все работало и без него)...

    ping ya.ru - не работает
    ping 87.250.251.3 - проходит нормально

    nslookup вроде отдает ip-шники...

    5 октября 2013 г. 6:49

Ответы

  • Спасибо за участие. Проблема решилась не сразу.

    После применения всех известных мне сбросов /flushdns, winsock reset, int ip rest (+ sfc/scannow)- пинг заработал ровно, но в браузерах (IE и Chrome) по имени сайты не открывались. В сети увидел схожую проблему с советом перезаписать ветку реестра HKLM\System\CCS\Services\Winsock2 с работающей машины. Поднял виртуалку, установил этот же дистрибутив, скопировал ветку оттуда в криво работающую машину.

    В свойствах  адаптеров появились глюки, (не мог назначить IP адреса для IP4 протокола). Снес все адаптеры, перезагрузился, смог прописать IP в адаптерах и все заработало нормально.

    Что это было так и не понял...

    • Помечено в качестве ответа SolenoidEditor 6 октября 2013 г. 8:32
    5 октября 2013 г. 18:36

Все ответы

  • Вроде?

    приведите пример того же ping ya.ru

    5 октября 2013 г. 7:14
  • Добрый день!

    Можно получить результат выполнения команд tracert google.ru например, nslookup google.ru, ipconfig /all.

    И для успокоения души попробуйте в настройках сети указать в качестве DNS сервера 8.8.8.8 (8.8.4.4).

    Посмотрите файл hosts на всякий случай, проверьте нет ли в нём чего-нибудь лишнего.

    P.S. результат выполнения команды route тоже не будет лишним.

    5 октября 2013 г. 14:56
  • Спасибо за участие. Проблема решилась не сразу.

    После применения всех известных мне сбросов /flushdns, winsock reset, int ip rest (+ sfc/scannow)- пинг заработал ровно, но в браузерах (IE и Chrome) по имени сайты не открывались. В сети увидел схожую проблему с советом перезаписать ветку реестра HKLM\System\CCS\Services\Winsock2 с работающей машины. Поднял виртуалку, установил этот же дистрибутив, скопировал ветку оттуда в криво работающую машину.

    В свойствах  адаптеров появились глюки, (не мог назначить IP адреса для IP4 протокола). Снес все адаптеры, перезагрузился, смог прописать IP в адаптерах и все заработало нормально.

    Что это было так и не понял...

    • Помечено в качестве ответа SolenoidEditor 6 октября 2013 г. 8:32
    5 октября 2013 г. 18:36