none
Помогите разобраться с OWA Redirect RRS feed

  • Вопрос

  • Здравствуйте.
    Опубликовал Outlook Web Access и сдела правило, запрещающее mail.domain.ru и перенаправляющее на mail.domain.ru/owa
    (Чтоб пользователям не набирать owa в конце строки адреса) Всё работает, но вот какой момент:
    Если набрать в адресной строке браузера mail.domain.ru , то получаю форму авторизации от ISA сервер:
    http://s45.radikal.ru/i107/0904/08/4306b9db5715.jpg
    Если же набрать в адресной строке браузера mail.domain.ru/owa , то получаю форму авторизации от Exchange:
    http://s45.radikal.ru/i107/0904/b8/68c123f42bbd.jpg

    В приницпе, это не принципиально, но хотелось бы сделать так, чтобы в любом случае появлялась форма авторизации от Exchange.
    Если правилу OWA Redirect делаю Disable, то переадресация естественно не работает.

    12 апреля 2009 г. 5:57

Ответы

  • Проблема была простая: на правиле deny, в разделе users, по умолчанию стоит "все авторизованные пользователи". Надо было просто заменить на all users.
    • Предложено в качестве ответа Aleksey Potapov 20 апреля 2009 г. 5:22
    • Помечено в качестве ответа Vinokurov YuriyModerator 30 апреля 2009 г. 11:40
    20 апреля 2009 г. 4:23

Все ответы

  • ты наверна в запрещающем правиле аутенфикацию и делегирование не так настроил как в разрешающем
    я вообще редирект делаю совсем по другому и в одном правиле, буквально недавно в другом треде тут писал:
    на вкладке Paths правила публикации добавляем строчку
    external path "/"
    internal path "/Exhange\"
    без кавычек конечно же
    не знаю какой у тебя exchange но на 2003 публикуется каталог exchange а не owa

    • Предложено в качестве ответа Aleksey Potapov 12 апреля 2009 г. 17:05
    12 апреля 2009 г. 6:44
    Отвечающий
  • Здравствуйте.
    Опубликовал Outlook Web Access и сдела правило, запрещающее mail.domain.ru и перенаправляющее на mail.domain.ru/owa
    (Чтоб пользователям не набирать owa в конце строки адреса) Всё работает, но вот какой момент:
    Если набрать в адресной строке браузера mail.domain.ru , то получаю форму авторизации от ISA сервер:
    http://s45.radikal.ru/i107/0904/08/4306b9db5715.jpg
    Если же набрать в адресной строке браузера mail.domain.ru/owa , то получаю форму авторизации от Exchange:
    http://s45.radikal.ru/i107/0904/b8/68c123f42bbd.jpg

    В приницпе, это не принципиально, но хотелось бы сделать так, чтобы в любом случае появлялась форма авторизации от Exchange.
    Если правилу OWA Redirect делаю Disable, то переадресация естественно не работает.

    Форма авторизации от Exchange отображается только для тех правил, которые созданы мастером публикации Exchange.
    Возможно, одно из ваших правил было создано вручную.
    • Предложено в качестве ответа Konstantin Frantsev 14 апреля 2009 г. 12:55
    14 апреля 2009 г. 12:55
  • Форма авторизации от Exchange отображается только для тех правил, которые созданы мастером публикации Exchange.
    Возможно, одно из ваших правил было создано вручную.
    Так для публикации OWA всего одно правило Publish Exchange Web Access и оно работает и форма авторизации от exchange появляется.
    Повторюсь: задача - не набирать в конце строки /owa, для это делаю правило deny. А правило Deny - оно конечно делается вручную.
    20 апреля 2009 г. 4:12
  • Проблема была простая: на правиле deny, в разделе users, по умолчанию стоит "все авторизованные пользователи". Надо было просто заменить на all users.
    • Предложено в качестве ответа Aleksey Potapov 20 апреля 2009 г. 5:22
    • Помечено в качестве ответа Vinokurov YuriyModerator 30 апреля 2009 г. 11:40
    20 апреля 2009 г. 4:23