none
Не подключаются диски у пользователей через логон-скрипт RRS feed

  • Вопрос

  • Доменная сеть

    контроллер win2003

    пользователи win xp

    Пользователям подключаются диски через скрипт VB который указан в групповой поитике

    Конфигурация пользователя- конфигурация виндовс-сценарий вход/выход

    Все работало тип-топ

    Встала задача добавить еще один диск с другого сервера.

    На новом сервере расширил диск, дал права на чтение/запись для определенной группы пользователей

    Проблема:

    Диск не подключается

    Подключаются все диски, кроме вновь добавленного 

    Теперь странности:

    Если запустить скрипт вручную, то все подключается отлично, значит в скрипте ошибок нет.

     

    сейчас вышел из положения, через командный файл в профиле у пользователя, но это как то не спортивно

     

     

     

    • Перемещено Denis DyagilevEditor 5 марта 2011 г. 7:53 (От:Виртуализация)
    5 марта 2011 г. 7:41

Ответы

Все ответы

  • а скрипт точно отрабатывает через политику? быть может он вообще не применяется и "старые" диски не подключаются а просто остаются подключенными
    5 марта 2011 г. 8:40
  • Проверьте с помощью rsop.msc отрабатывается ли на клиенте эта политика.


    MCSA
    5 марта 2011 г. 9:29
  • а скрипт точно отрабатывает через политику? быть может он вообще не применяется и "старые" диски не подключаются а просто остаются подключенными

    Скрипт во время работы проверяет наличие уже подключенных дисков

    если эта буква занята, тогда подключение сбрасывается и подключается заново.

     

    Если после запуска быстренько открыть "Мой компьютор" то можно застать работу скрипта

    Видно как отключаются диски (если были подключены) и заново подключаются

    Так что можно с уверенность утверждать что скрипт применяется.

    5 марта 2011 г. 9:40
  • Начал проверять у клиентов результирующую политику через rsop.msc

    Посмотрел в раздел

    Конфигурация пользователя- конфигурация виндовс-сценарий вход/выход

    есть назначенный скрипт

     

    а потом начал в меня сыпать ошибками

     

    http://screencast.com/t/eJ1IJvuWU

    и дважды

    http://screencast.com/t/wij1Z84VLc

    а потом

    http://screencast.com/t/xVsV2lsWYsXi

    может в этом дело?

     

    5 марта 2011 г. 9:50
  • врядли, это ошибки административных шаблонов, к скриптам отношения не имеющим
    5 марта 2011 г. 10:18
  • я думаю что поблема во в этом

     

    • Помечено в качестве ответа BadimB 9 марта 2011 г. 6:43
    9 марта 2011 г. 6:43