none
Для новых списков не работает анонимный доступ RRS feed

  • Общие обсуждения

  • Доброго дня коллеги.

    Имеется сайт на SharePoint 2013 выпущенный в интернет и доступный анонимно. Были созданы некоторые списки, к ним добавлены рабочие процессы, все работает для анонимных пользователей, как и должно. Но! Сегодня создаю новый список и он уже не доступен анонимно!? Он наследует разрешения от основного сайта, как и все другие доступные списки, но к нему все ровно нет доступа. Я пытался убрать наследование, но это не помогает. Перезагружал пул и сайт, сбрасывал галочки анонимного доступа в провайдере, в политиках, на сайте и для списка. Ничего не помогает… Сколько бы списков я не создал, все новые не доступны анонимно… Если создать страницу, то к ней доступ есть, но не к списку…

    Заметил особенность такую, если у семейства сайтов отключить фичу «Режим блокировки разрешения ограниченного доступа пользователей» и потом создать список, то он доступен анонимно, но если потом фичу включить обратно, доступ пропадает…

    Если создать список и выключить фичу, то доступа нету. Ведь эта фича распространяется только на системные библиотеки, которые идут с шариком.

    Что могло случится с порталом, что он не понимает настройки анонимности для новых пользователей!?

    12 ноября 2013 г. 14:42

Все ответы

  • Здравствуйте
    “Limited-access user permission lockdown mode” необходимо отключить для того, чтобы анонимные пользователи имели доступ к спискам.
    SharePoint 2013 and anonymous users accessing lists and libraries


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    13 ноября 2013 г. 9:21
    Модератор
  • Эта фича была включена у меня в процессе всех изменений и созданий списков. И эти списки доступны анонимно даже с активной опцией "Limited-access user permission lockdown mode".

    Сейчас же, даже те списки которые создаются и почему-то не доступны анонимно, по прежнему не анонимны даже с выключенной фичей "Limited-access user permission lockdown mode"

    15 ноября 2013 г. 6:26
  • Друзья, проблема все еще актуальна... Есть у кого какие соображения?
    6 декабря 2013 г. 15:50
  • Попробуйте выполнить следующие действия:

    1. Проверить свои настройки согласно мануалу:

    http://blog.vitalyzhukov.ru/ru/sharepoint-2013-enable-anonymous-access.aspx

    2. Предоставить доступ выполнив скрипт в powershell:

    $web = Get-SPWeb http://sps2013/
    $web.AnonymousPermMask64
    $web.AnonymousState = [Microsoft.SharePoint.SPWeb+WebAnonymousState]::Enabled
    $web.AnonymousPermMask64 = "ViewListItems, ViewVersions, ViewFormPages, Open, ViewPages, UseClientIntegration"
     $web.update()

    3. Проверить отключение фичи в разделе коллекции сайта на вашем портале :Режим блокировки разрешения ограниченного доступа пользователей

    4. Попробовать еще раз создать новый объект и выдать в его настройках разрешения анонимного доступа.

    У меня после проделанных действий получилась возможность создания анонимных опросов.


    23 июля 2014 г. 8:31