none
Удаленное управление службами RRS feed

  • Вопрос

  • Здравствуйте. В силу обстоятельств мне периодически приходится останавливать и запускать службы на удаленном сервере (win server 2003) через консоль. Делал я это с помощью команд такого плана:

    net use \\93.95.***.***\IPC$ "password" /user:93.95.***.***\admin
    sc \\93.95.***.*** stop servicename

    И делать это приходится на нескольких машинах. Прямого доступа к машинам у меня нет (они находятся в Москве, я во Владивостоке, использую mstsc если нужно), и этими серверами пользуются ещё несколько человек. И вот с недавних пор на одной из машин эти команды (а точнее первая) перестали выполняться и стала выдаваться ошибка:

    Системная ошибка 64

    Указанное сетевое имя более недоступно

    Возможно один из пользователей что-то установил или изменил, и теперь что-то блокирует консольные команды. На всех остальных машинах эти команды продолжают работать. Подскажите, в чём может быть причина и где её искать?

     

     

     

    17 июля 2010 г. 1:39

Ответы

Все ответы

  • а по RDP (mstsc) удается на нее зайти?
    Вернигора Андрей, http://eosfor.blogspot.com MCP, MCDBA, MCSA, MCSE
    18 июля 2010 г. 18:48
  • а по RDP (mstsc) удается на нее зайти?
    Да, с этим проблем нет. Т.е. вручную на сервере можно сделать с этими службами что угодно, но мне нужно их отключать и включать именно удаленно через команды консоли. Т.к. мне нужно делать остановку и запуск службы через PHP скрипт. Там, на сколько я понял, можно использовать только команды консоли windows. Если у кого-нибудь есть другие варианты, как это сделать (через браузер), я буду рад их узнать =)
    18 июля 2010 г. 21:46
  • А служба Server (lanmanserver) работает на удаленной машине?

    19 июля 2010 г. 6:57
  • А служба Server (lanmanserver) работает на удаленной машине?


      Да, действительно, эта служба была отключена на сервере, который выдавал ошибку, а на остальных работала. Спасибо огромное за ответ. Теперь снова всё работает. Осталось найти, почему эта служба при перезагрузке сервера не запускается, хотя тип запуска "авто" =)
    19 июля 2010 г. 7:15
  •   Да, действительно, эта служба была отключена на сервере, который выдавал ошибку, а на остальных работала. Спасибо огромное за ответ. Теперь снова всё работает. Осталось найти, почему эта служба при перезагрузке сервера не запускается, хотя тип запуска "авто" =)

    Проверьте по EventLog (Система) причину остановки службы. Очень часто служба вылетает из-за сетевых атак, поэтому советую проверить также установку последних обновлений безопасности в системе.
    19 июля 2010 г. 7:29