none
Почта не попадает в папку DROP RRS feed

  • Вопрос

  • Почта доходит до сервера на котором установлн SharePoint и поднята служба IIS SMTP но вместо папки DROP попадает в папку Queue. В чем проблема?

    6 марта 2008 г. 8:57

Все ответы

  •  

    Не нужно "плодить" одни и те же темы
    6 марта 2008 г. 9:01
    Отвечающий
  • Больше  не буду. Сорри. Есть идеи по регению проблемы?

     

    6 марта 2008 г. 9:40
  • Честно говоря с таким не сталкивался, но по опыту, если все делать как здесь и + то, что Вы уже скачали, то должно работать. проверено многократно.

    6 марта 2008 г. 11:22
    Отвечающий
  • блин, иногда задумываешься, нахрена придумали логирование в приложениях?!

    посмотри логи smtp сервера, в них всё будет.

    похоже сервер недоступен или не принимает почту от этого smtp.

    в дропы падает почта которую невозможно доставить вообще, в очередь ставится при проблемах с отправкой.

     

    кстати, а зачем тебе почта в дропах??? чего ты добиваешься?

    7 марта 2008 г. 9:32
  •  Roman Padalko написано:

    в дропы падает почта которую невозможно доставить вообще, в очередь ставится при проблемах с отправкой.

     

    кстати, а зачем тебе почта в дропах??? чего ты добиваешься?

    При отправке почты в библиотеки (или группам рассылки) в sharepoint письма сначала помещаются именно в drop, через небольшое время (30-60 сек) идут по адресу.

    7 марта 2008 г. 10:20
    Отвечающий
  • Почта доходит до сервера на котором установлн SharePoint и поднята служба IIS SMTP но вместо папки DROP попадает в папку Queue.

    Когда перетягиваю ручками файлик NTFS_1a......................... .EML в папку DROP то через некоторое время файлик из папки DROP исчезает, в библиотеке не появляется а в логах появляются следующие строчки:

    03/11/2008 10:37:23.05  OWSTIMER.EXE (0x0824)                    0x0844 Windows SharePoint Services    E-Mail                         6872 Critical При обработке файла входящих сообщений "C:\Inetpub\mailroot\Drop\NTFS_0b42c7b401c8835200000017.EML" произошла критическая ошибка. Ошибка: Bad senders or recipients.. 
    03/11/2008 10:37:23.05  OWSTIMER.EXE (0x0824)                    0x0844 Windows SharePoint Services    E-Mail                         6871 Information Служба входящей почты завершила обработку пакета. Потрачено времени: 00:00:00.0468738. Всего сообщений, обработанных службой: 0.

     

    Что это может значить? Делал все по документациям.

    11 марта 2008 г. 8:55
  •  KoTV написано:

    03/11/2008 10:37:23.05  OWSTIMER.EXE (0x0824)                    0x0844 Windows SharePoint Services    E-Mail                         6872 Critical При обработке файла входящих сообщений "C:\Inetpub\mailroot\Drop\NTFS_0b42c7b401c8835200000017.EML" произошла критическая ошибка. Ошибка: Bad senders or recipients.. 

    Проверьте в настройках входящей почты в центральном администрировании, от кого можно получать письма...Safe e-mail servers кажется....
    12 марта 2008 г. 11:23
    Отвечающий
  • не сориентировался, что речь про входящую почту.

    12 марта 2008 г. 15:09
  • В Safe e-mail servers указан IP сервера exch2007.

    Может такое быть из-за того, что неправильно прописан SendConnector? и из-за этого почта попадает не туда куда надо.... и т.д. 

    Можно попросить для примера рабочий SendConnector с небольшим объяснением?

     

    я прописал SendConnector следующего вида:

    New-SendConnector -Name 'Connect1' -AddressSpaces 'SMTP:mydomen.local;1' -DNSRoutingEnabled $false -SmartHosts comp2.mydomain.local -SmartHostAuthMechanism 'None' -SourceTransportServers 'comp1'

    на comp1 установлен Exch2007, на comp2 - MOSS + IIS SMTP

    12 марта 2008 г. 15:37
  • Хм... возможно все дело в том, что ссылка-руководство кот. я вам давал описывала настройки с Exchange 2003. Посмотрите на том же сайте есть guid для 2007 версии.

     

    12 марта 2008 г. 21:26
    Отвечающий
  • Мне оч неудобно, но руководства по 2007Эксч не нашёл. Поделитесь пожалуйста ссылочкой.

     

    Ещё 2 вопроса: для создания коннектора необходимо пользоваться командой New-SendConnector или New-ForeignConnector? В Эксч2007 в параметрах кантакта при указании e-mail обязательно указывать X400 или нет?

    13 марта 2008 г. 11:41
  •  KoTV написано:

    Мне оч неудобно, но руководства по 2007Эксч не нашёл. Поделитесь пожалуйста ссылочкой.

     

    Ещё 2 вопроса: для создания коннектора необходимо пользоваться командой New-SendConnector или New-ForeignConnector? В Эксч2007 в параметрах кантакта при указании e-mail обязательно указывать X400 или нет?

     

    У вас коннектор настроен и работает должным образом - еще раз повторяю Exch здесь не при чем !!!

    13 марта 2008 г. 14:20
  • Всем кто откликнулся - большое спасибо.

    Проблема была в неправильно настроенном коннекторе и неправильно настроенном контакте в Exch2007.

    14 марта 2008 г. 11:31
  •  KoTV написано:

     

    Проблема была в неправильно настроенном коннекторе и неправильно настроенном контакте в Exch2007.

     

    Разумеется в коннекторе (ибо вы не внимательно читали что вам приводили в пример)

     

    Это ваш коннектор , ошибка в адресном пространстве ( не думал , что вы не поймете сразу о чем я писал)

     

    Code Snippet

    New-SendConnector -Name 'Connect1' -AddressSpaces 'SMTP:mydomen.local;1' -DNSRoutingEnabled $false -SmartHosts  comp2.mydomain.local -SmartHostAuthMechanism 'None'  -SourceTransportServers 'comp1'

     

     

    14 марта 2008 г. 13:17