none
Windows7 не выполняет скрипт из Netlogon RRS feed

  • Вопрос

  • в сетиработает контроллер домена, на машинках с ХР все отлично работает, но т.к. новые компы все покупаются с семеркой, то начинаются проблемы. одна из них - невыполняется автоматически скрипт назначенный через ГПО для всех копьютеров домена.

    сам нетлогон видится, доступ к нему есть.

    в скрипте подключаются сетевые диски (одна часть скрипта)  так вот если вывести на рабочий стол ярлык с папки с сетевого диска, и запустить его, то диск подключится.

    еслди вручную зайти в нетлогон и хапустить файл скрипта, то тоже все отрабатываетсябез ошибок.

    куда копать подскажите.

     

    23 января 2012 г. 5:18

Ответы

  • Откатывайте систему на то время, пока еще все это работало :) И переделайте скрипт.  Можете выложить его здесь вместе с описанием - попробуем посоветовать, как можно исхитриться. Либо задайте вопрос по переделке в разделе Windows Scripting


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow us on TwitterFollow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    • Помечено в качестве ответа Andrey099 27 января 2012 г. 2:08
    26 января 2012 г. 18:14
    Модератор

Все ответы

  • Что в журналах системы?

    23 января 2012 г. 9:17
  • на клиенте нашел запись, что нетлогон не может установить связь с контроллером домена. уже интересно стало.

    наверное надо копать в эту сторону. хотя сервер времени синхронизировался без проблем с КД.

    23 января 2012 г. 9:53
  • Сервер времени не показатель в данной ситуации, так же как и ping...

    А вот синхронизацию времени клиентов и сервера проверить стоит (как один из вариантов).


    23 января 2012 г. 10:38
  • в журнале на клиенте есть запись, что сервер времени получает точное время от  далее адрес КД.

     

     

    23 января 2012 г. 11:10
  • удалил все фаерволы, отключил брендмауер винды - тольку ноль.

    ошибок больше нет по нетстату.

    куда дальше копать? время синхронизировано.

    23 января 2012 г. 12:28
  • Т.е. ошибок в журналах больше нет?

    Какая редакция клиентской ОС?

    Вопрос глупый, но спрошу. Машина заведена в домен?

    Куда конкретно привязана неотрабатывающая политика?

    23 января 2012 г. 12:54
  • машинка в домене, захожу доменным пользователем. локальные пользователи отключены.

    скрипт стоит на user -> windows settings -> logon -> script

    windows 7 pro sp1 ver 6.1.7601

    в безопасности есть ошибки.

    аудит отказа, и там как раз wscript упоминается.

    получается прав нехватает? захожу доменным админом. права есть на все.

    23 января 2012 г. 13:05
  • Имелось ввиду куда привязана политика: к сайту, домену, конкретному OU.

    Через gpresult видно, что данная политика применяется?

    Под администратором домена политика также не отрабатывает?

    23 января 2012 г. 13:29
  • подозреваю что скрипт то на vbs. это uac срабатывает, либо придется все делать через одно место либо отказываться от vbs логон-скриптов. с bat и cmd такой проблемы нет.

    23 января 2012 г. 16:20
  • да, именнно на vbs скрипт.

    в батнике такой скрипт не сделаешь. какие варианты еще м.б.

     

    24 января 2012 г. 4:28
  • да, именнно на vbs скрипт.
    Давно уже известны особенности: в Google по строке "launchapp.wsf"
    24 января 2012 г. 7:42
    Отвечающий
  • ага, метод через одно место, его и через cmd делали тоже. суть проста - при старте создается шедуленая таска которая выполняет уже vbs. мы не стали так извращаться а перевели все что делалось через vbs на gpo, gpp, ps или bat
    24 января 2012 г. 17:26
  • в общем я не знаю что сделал.

     но теперь при входе получаю сообщение, что невозможно установить безопасную связь с контроллером домена. и не входит под доменной учеткой.

    перепробовал все уже и заного в домен вводил и выводил.

    куда еще копать. началось после экспериментов с фаером др.веба.

    сейчас его совсем удалил, и все равно не пускает.

    в домен комп вводится без проблем, с КД управляется

    24 января 2012 г. 17:42
  • Откатывайте систему на то время, пока еще все это работало :) И переделайте скрипт.  Можете выложить его здесь вместе с описанием - попробуем посоветовать, как можно исхитриться. Либо задайте вопрос по переделке в разделе Windows Scripting


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow us on TwitterFollow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    • Помечено в качестве ответа Andrey099 27 января 2012 г. 2:08
    26 января 2012 г. 18:14
    Модератор
  • так и сделал. похоже что проблема в кривом управлении брендмауэра др.веба. он закрыл порты.

    откатил, назад вогнал в домен и все заработало. всем спасибо.

     

    • Предложено в качестве ответа rudomanenko igorBanned 24 августа 2012 г. 16:37
    27 января 2012 г. 2:11