none
HyperTerminal ???? RRS feed

  • Вопрос

  • Потребовалось сконфигурировать свитч по последовательному порту. Подцепил к нему свой ноутбук с недавно установленной Вистой и...., обнаружил, что Гипертерминала то в нет нет.....

    В справке сказано, что типа используете телнет, да вот только связываться по COM-портам Телнет так и не научили.

    Проблему я конечно решил - полно в сети бесплатных терминальных программ, да и можно просто скопировать Гипертерминал с любой XP-шной машины, но зачем потребовалось его выкидывать из системы ? И что теперь MS предлагает взамен для связи по последовательным портам ? Или там считают, что СОМ-порты уже вымерли как мамонты ?

    10 марта 2007 г. 8:46

Ответы

  • Из стандартных компонентов Windows Vista - ничего.

    Note that a terminal-emulation program called Hyperterminal was available in Windows XP, but it is not available in Windows Vista.

    Взято отсюда. Но вы совершенно правы, что в свободном доступе и в продаже имеется большое число эмуляторов терминалов с различными возможностями.

    10 марта 2007 г. 12:12
    Модератор

Все ответы

  • Из стандартных компонентов Windows Vista - ничего.

    Note that a terminal-emulation program called Hyperterminal was available in Windows XP, but it is not available in Windows Vista.

    Взято отсюда. Но вы совершенно правы, что в свободном доступе и в продаже имеется большое число эмуляторов терминалов с различными возможностями.

    10 марта 2007 г. 12:12
    Модератор
  •  Andrew Mishechkin написано:

    Или там считают, что СОМ-порты уже вымерли как мамонты ?

    А Вы в курсе, что большинство компьютеров (особенно лаптопов) продается сейчас в США без ком-портов вообще?

    И, кстати, без флоппи-дисководов тоже ;)

    На дворе 21 век, однако :)

    10 марта 2007 г. 22:29
  • Скажите, а как вы включили возможность посылать комманды в hyperterminal?

     

    Объясняю ситуацию:

    У меня Vista buisness и необходимо через hyperterminal по COM port отправить запрос на модуль для аппаратной прошивки EDGE модуля установленного на COM4 порте. Устанавливая HT private edition  6.3 и похожие программы (в т.ч. встроенного в XP) получаю в результате одно:

    в коммандной строке не проходят (не печатаются) комманды: такие как AT. может чего-то я делаю не так?

    15 апреля 2007 г. 8:19
  • причем, простите забыла добавить, TELNET cLient и service включены ( в дополнительных настройках:  /control panel/programms... /turn on windows features/)

     

    какие вообще могут быть бъяснения происходящему. не могу понять: по мануалу таких проблем не описано.

    15 апреля 2007 г. 8:23
  • К клиенту и серверу telnet ваша проблема не имеет отношения. Важно убедиться, что ваша терминальная программа является приложением Win32, а порт com4 присутствует в Диспетчере устройств. Windows запрещает приложению прямую запись в порт и генерирует исключение в случае такой попытки. Исключение обрабатывается драйвером порта, и приложению "кажется", что оно напрямую передает информацию в порт.
    15 апреля 2007 г. 11:23
    Модератор
  • Конечно в курсе, поскольку мой ноут без COM-порта и флопа, хотя куплен не в США.

    А Вы в курсе, что не смотря на 21-й век на дворе практически во всем активном сетевом оборудовании (причем и для супер-современных SAN-сетей) есть порты RS-232 с "несовременным" 9-контактным разъемом, через которое и осуществляется его первоначальное конфигурирование. А отсутствие RS-232 на ноуте легко фиксится с помощью переходника USB2COM. Вот только вот идеологи Windows Vista (Вы случайно не из их числа) посчитали, что "типа не круто"  работать в 21м веке через СОМ-порты.

     

    PS: проблема решилась простым копирование в Висту гипертерминала с WinXP