none
Контекстное меню в windows xp RRS feed

  • Вопрос

  • Вчера столкнулся с проблемой. У одного из пользователей что то случилось с виндой и после перезагрузки. Теперь когда пытаешься открыть папку двойным щелчком мыши, то она не открывается. А открыть ее можно только кликнув на правую кнопку мыши и нажать кнопку "Открыть" (кстати в контекстном меню стало 2 пункта "Открыть"). Теперь вопрос, что надо поправить, чтоб папка открывалась как обычно по двойному щелчку мыши? И чтоб из контекстного меню убрать второе слово "Открыть"?
    15 апреля 2009 г. 5:44

Ответы

  • Посмотрите следующие ключи реестра и при возможности сравните с другим "эталонным" компьютером:

  • [HKCR\Folder\Shell\]

  • [HKCR\Folder\ShellEx\ContextMenuHandlers\]

  • [HKCR\Directory\Shell\]

  • [HKCR\Directory\ShellEx\ContextMenuHandlers\]

  • [HKCR\AllFilesystemObjects\shell\]

  • [HKCR \ AllFilesystemObjects \ shellex \ ContextMenuHandlers\]

    Посмотрите эту статью:

    http://windowsxp.mvps.org/context_folders.htm

16 апреля 2009 г. 12:13
Модератор
  • Сейчас снова попробывал, только теперь экспортировал все рекомендованые выше ветви целиком, а именно:
  • [HKCR\Folder\]

  • [HKCR\Directory\]

  • [HKCR\AllFilesystemObjects\]
    перезагрузил комп и все стало ОК.
    Огромное спасибо osr_MVP, ты лучший.

    • Помечено в качестве ответа otec1980 17 апреля 2009 г. 8:14
    17 апреля 2009 г. 8:13

    Все ответы

    • Для начала на вирусы проверится.


      Абсолютно нормальный парень...
      15 апреля 2009 г. 5:52
    • My Computer - Tools - Folder Options - закладка File Types, найдите тип Folder (Папка) и нажмите кнопку Advanced. Посмотрите, какие сделаны сопоставления.
      15 апреля 2009 г. 5:52
      Модератор
    • Стоит Каспер 6.0 корпоративный при проверке ничего не обнаружил.
      В сопоставлениях для папки
      My Computer - Tools - Folder Options - закладка File Types, найдите тип Folder (Папка) и нажмите кнопку Advanced для folder стоит explore и open вроде все как обычно.
      Может другим антивирусником прогнать попробывать? Какие непосредственно еще сопостовления надо глянуть?
      15 апреля 2009 г. 6:18
    • Антивирус обновляется?


      Абсолютно нормальный парень...
      15 апреля 2009 г. 6:23
    • Конечно. Тыкаешь на папку открывается окно открыть с помошью.
      15 апреля 2009 г. 6:26
    • Вероятнее всего вирус. Просканируй AVZ 4 и HijackThis как указано на форуме Кашперского, там же создай тему и прикрепи файлы, опиши ситуацию. Помогут достаточно быстро.


      Самые мистические проблемы, в конце обнаруживаются твоими тупейшими ошибками.
      15 апреля 2009 г. 6:54
    • Сегодня попробую другими антивирусниками прогнать отпишу по итогам.
      15 апреля 2009 г. 7:09
    • Проверил другими антивирусниками, ничего не найдено.
      Есть еще какие нибудь мысли? Может какие ветви в реестре надо поправить?
      15 апреля 2009 г. 11:48
    • у меня было что то подобное, я включил отображение системных файлов и увидел какойто очень подозрительный инишник в корне C: и на десктопе (что то похожее на авторан.ини) так вот я ето файл поудалял и всё заработало нормально


      сила в справедливости
      15 апреля 2009 г. 12:46
    • Проверил другими антивирусниками, ничего не найдено.
      Есть еще какие нибудь мысли? Может какие ветви в реестре надо поправить?

      Другми это какими? AVZом проверяли, как я советовал?
      Самые мистические проблемы, в конце обнаруживаются твоими тупейшими ошибками.
      15 апреля 2009 г. 12:53
    • К сожалению AVZ под рукой не оказалось, проверял DrWebom и Panda Antivirus, ни тот ни другой ничего не нашли.
      По поводу вот этого:
      у меня было что то подобное, я включил отображение системных файлов и увидел какойто очень подозрительный инишник в корне C: и на десктопе (что то похожее на авторан.ини) так вот я ето файл поудалял и всё заработало нормально
      с этим тоже встречался когда то, но в данном случае не похоже на это.
      Еще раз попытаюсь обрисовать ситуацию. Чтото глюкануло у пользователя в Винде или он сам чтото сделал я не знаю (товарищ высокопоставленный по этому права у него локального админа). Теперь когда 2 раза кликаешь на папку открывается окошко, такое же, как если бы ткнуть на правую кнопку мыши и выбрать "Открыть с помощью" далее если выбрать из списка представленных программ Internet explorer, то папка прекрасно открывается, но галочка always used the selected program to open this kind of file не активна (нельзя поставить галочку, чтоб заработало сопоставление). И так приходится открывать все папки, что крайне не удобно. Переставлять винду не хотелось бы, так как стоит туча разного софта. И все таки первый вопрос:
      Почему галочка не активна и как ее сделать активной, чтоб включить сопоставление?
      и второй вопрос
      Почему в контекстном меню появилось 2 слова "Открыть"?
      Кстати когда нажимаешь на паке правую кнопку и надимаешь "Открыть" все также благополучно открывается.
      16 апреля 2009 г. 5:54
    • Start > панель управления > Свойства папки > Типы файлов

      Найдите в списке "Папка" и нажмите ниже кнопку "Дополнительно". В списке действий должно быть "explore" и "open". Все лишнее убирайте! Если действий нет, то их придется создать.

      16 апреля 2009 г. 7:53
    • Там уже смотрел  "explore" и "open" там есть., но редактировать не представляется возможным, можно только новые создать.
      Так всетаки не получил ответ на вопрос
      Почему галочка не активна и как ее сделать активной, чтоб включить сопоставление?
      16 апреля 2009 г. 7:59
    • В "нормальной" системе сопоставления для папки тоже не редактируются через Типы файлов.
      16 апреля 2009 г. 8:19
      Модератор
    • Коллеги еще раз кто нибудь может дать четкий и внятный ответ на вот эти 2 вопроса:
      Почему галочка не активна и как ее сделать активной, чтоб включить сопоставление?
      Почему в контекстном меню появилось 2 слова "Открыть"?
      А не разводить полемику, что да как и почему.
      16 апреля 2009 г. 8:23
    • Посмотрите следующие ключи реестра и при возможности сравните с другим "эталонным" компьютером:

    • [HKCR\Folder\Shell\]

    • [HKCR\Folder\ShellEx\ContextMenuHandlers\]

    • [HKCR\Directory\Shell\]

    • [HKCR\Directory\ShellEx\ContextMenuHandlers\]

    • [HKCR\AllFilesystemObjects\shell\]

    • [HKCR \ AllFilesystemObjects \ shellex \ ContextMenuHandlers\]

      Посмотрите эту статью:

      http://windowsxp.mvps.org/context_folders.htm

    16 апреля 2009 г. 12:13
    Модератор
  • Последний ответ стал первым, который реально чтото поправил. Экспортировал настройки реестра с моего компа, добавил на комп на котором проблема. После этого некоторые вещи изменились например второе слово Открыть пропало. Но появился другой трабл, основным стало слово Найти и теперь когда тыкаешь 2 раза на папку открывается не папка а окно поиска. Как исправить данный трабл?
    17 апреля 2009 г. 7:24
  • А перезагрузились после внесения изменений? Далее откройте Folder Options - File Types. Убедитесь, что среди типов есть и Folder, и File Folder. Щелкните на Folder, нажмите кнопку Advanced, выберите Actions: Open и нажмите Set Default. Напишите о результате.
    17 апреля 2009 г. 7:40
    Модератор
  • После того как файлы реестра применил, перегрузил комп и случился трабл описаный выше.
    По поводу
    Далее откройте Folder Options - File Types. Убедитесь, что среди типов есть и Folder, и File Folder.
    То я сразу обратил внимание на это. сразу туда залез Folder, и File Folder. присутствуют открыл фолдер дополнительно, выбрал Open (там присутствовал еще и explore) и нажал Set Default.  После этого попробывал все осталось по прежнему, папки так и не стали открываться, правда комп после последней операции не перегружал. Сейчас товарищ отошел и я не имею вожможности извращаться дальше. Как только придет покручу еще и по итогам отпишу.
    17 апреля 2009 г. 7:50
  • Сейчас снова попробывал, только теперь экспортировал все рекомендованые выше ветви целиком, а именно:
  • [HKCR\Folder\]

  • [HKCR\Directory\]

  • [HKCR\AllFilesystemObjects\]
    перезагрузил комп и все стало ОК.
    Огромное спасибо osr_MVP, ты лучший.

  • 17 апреля 2009 г. 8:13