none
Lync 2010 и OWA. проблемы в работе RRS feed

  • Вопрос

  • Добрый день!

    Возникла проблема с отображением статусов пользователей и вообще списком контактов в Exchange OWA.

    Ранее все было настроено и работало корректно, потом в один момент закончился сертификат на Exchange, который был благополучно обновлен на всех почтовых серверах и практически в тот же момент пропали контакты в OWA:

    Служба мгновенных сообщений в данных момент недоступна. Список контактов появится, когда служба мгновенных сообщений будет снова доступна.

    В этот момент мой статус в письмах через веб интерфейс отображается корректно (я зелененьким отображаюсь), все другие - серые.

    На Exchange серверах выполняли подобную команду:

    Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -InstantMessagingType OCS -InstantMessagingEn abled:$true -InstantMessagingCertificateThumbprint (Thumbprint нового сертификата) -InstantMessagingServerName (FQDN имя линка)

    На Lync сервере exchange (FQDN name) находится в TrustedApp - и делали рестарт iis, но проблема так не решилась.

    Можете подсказать в каком направлении примерно можно идти или где можно снять логи для более точной локализации и решении данной проблемы ?

    Lync 2010.

    Exchange 2007



    • Изменено Akhmerov88 23 мая 2013 г. 8:17

Ответы

  • Все-таки я порекомендовал бы выпустить для Exchange несамоподписанный сертификат и оперировать уже с ним. проблема скорее всего именно в этом.

    Do not multiply entities beyond what is necessary

    • Помечено в качестве ответа Akhmerov88 5 июня 2013 г. 13:39

Все ответы

  • Добрый день!

    Для проверки логов можете воспользоваться lync logging tool, посмотрите статью Troubleshooting Lync-Exchange OWA Integration.

    Также посмотрите подобную тему: No Lync presence in OWA.


    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"


    Модератор
  • Добрый вечер !

    Специально выбрал время чтоб меньше людей пользовались линком, запустил логирование SIP Stack (все флаги выделил, все как в инструкции), зашел несколько раз - получил сообщение

    Служба мгновенных сообщений в данных момент недоступна. Список контактов появится, когда служба мгновенных сообщений будет снова доступна.

    Специально еще несколько раз выполнил вход и выход - получил данную ошибку, остановил логирование.

    Но Snooper ошибок не нашел - вообще ниодной ошибки нет.

    Можете подсказать в какую сторону дальше идти ?

  • Сначала не обратил внимания на версию Exchange. Но вот в анлоязычной ветке форума говорится о том, что Exchange 2007 не поддерживает обмен мгновенными сообщениями через OWA. 

    Do not multiply entities beyond what is necessary

  • Моя опечатка была... - 2010 версия Exchange
  • тогда вопрос. Вы после того, как добавили доверенный пул приложений в топологию Lync, публикацию топологии делали?

    Do not multiply entities beyond what is necessary

  • да, публикация у нас была.

    Со стороны линка никаких работ или изменений не проводилось, на Exchange просто менялся сертификат (1:1 только новый) и все.

    сейчас пойду попробую заново топологию проинсталировать

  • Попробовал опубликовать заново + сделал рестарт IIS сервера (почтовика) - результат все тот же.

  • стоп. Вы говорите что на Exchange поменялся сертификат. Пусть он один в один, отпечаток то у него другой теперь. Вам надо снова выполнить конвейер

    Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -InstantMessagingType OCS -InstantMessagingEnabled:$true -InstantMessagingCertificateThumbprint (Thumbprint нового сертификата) -InstantMessagingServerName (FQDN имя линка)

    и переопубликовать топологию.

    Кстати, перевыпущенный сертификат вы привязывали к службам Exchange?


    Do not multiply entities beyond what is necessary


    • Изменено Dmitry.I 27 мая 2013 г. 11:20
  • да сертификат привязан, на стороне Exchange данную процедуру (Get-OwaVirtualDirectory | Set-OwaVirtualDirectory ) проводили, службы iis перезапускали.

    Топологию сегодня повторно опубликовали.

    результата все нет.

  • Сервер Exchange у вас один?

    попробуйте следующее:

    1. Удалите созданный доверенный пул из топологии. Опубликуйте топологию.

    2. создайте новый пул в Topology Builder

    3. Для нового пула выполните в LSMS: New-CsTrustedApplication -ApplicationId < имя приложения> -TrustedApplicationPoolFqdn <FQDN пула> -Port <номер порта>

    3. Опубликуйте топологию.

    более подробно


    Do not multiply entities beyond what is necessary


    • Изменено Dmitry.I 27 мая 2013 г. 11:43
    • Предложено в качестве ответа Dmitry.I 27 мая 2013 г. 11:43
  • Exchange один, но кластерный вариант (все x2)

    Сегодня в районе обеда попробую все это сделать, по результатам отпишусь

  • Если у вас создан CAS Array (есть балансировка), то доверенный пул приложений создается для балансировщика CAS (используется его FQDN, при условии, что сертификат включает его доменное имя).  

    Do not multiply entities beyond what is necessary

  • Удалил доверенный пул, опубликовал, потом создал заново доверенный пул с указанием FQDN имени балансировщика (в сертификат он включен), добавил TrustedApplication (все как по инструкции).резетнул иис на exchang, но проблема все еще осталась.

  • А порт, который вы указали при создании доверенного приложения, ничем другим не занят?

    Do not multiply entities beyond what is necessary

  • Порты пробовал использовать разные, резльтата все нет (

    Порт свободен

  • Еще тогда вопрос. Все требуемые предварительные условия выполнены (включая предустановку необходимого ПО)?

    Do not multiply entities beyond what is necessary

  • Воспроизвел пошагово все действия на демо стенде

    Win 2008 R2 SP1 – все системы

    3 сервера

    1. AD, Enterpeise CA (имя dc.contoso.com)
    2. Lync 2010 (lync.contoso.com)
    3. Exchange 2010 (mail.contoso.com)

    На Exchange установлены все необходимые оснастки для OWA, сертификат привязан в серверу  

    На exchange прописал все для OWA

    На Lync прописал следующее (пробовал как через консоль создавать так и через тополоджи билдер)

    Далее написал Enable-CsTopology и для надежности перезагрузил iis на сервере Exchange.

    После попытки авторизации через веб интерфейс получаю опять же следующую ошибку:

    В этот момент если я веду логирование SipStack то никаких ошибок не появляется.


    • Изменено Akhmerov88 30 мая 2013 г. 5:45
  • Сертификат Exchange самоподписанный. А чтобы Lync ему доверял, он должен быть выпущен внутренним (корпоративным) CA. Конечно, как вариант, можно попробовать через экспорт-импорт разместить его в хранилище доверенных корневых центров сертификации сервера Lync, но обычно так не делается.

    Do not multiply entities beyond what is necessary

  • Я так и сделал ранее, проблема не исчезла

    Установлен на линке.


    • Изменено Akhmerov88 30 мая 2013 г. 6:06
  • попробуйте его же на любого клиента поставить. В такое же хранилище. И запустите с него OWA.

    Do not multiply entities beyond what is necessary

  • Установил на другой компьютер данный сертификат, проблема не исчезла
  • Все-таки я порекомендовал бы выпустить для Exchange несамоподписанный сертификат и оперировать уже с ним. проблема скорее всего именно в этом.

    Do not multiply entities beyond what is necessary

    • Помечено в качестве ответа Akhmerov88 5 июня 2013 г. 13:39
  • это дублирующая проблема была,

    на основном exchange и Lync используются сертификаты от startssl. Но проблема аналогичная 1:1

  • На демо стенде проблему решили (пересоздал от корпоративного центра сертификации сертификат правильный) - там действительно была проблема с сертификатами.

    сейчас на продуктиве сверяю старый и новый сертификат, где что могли ошибиться

  • На продуктиве провели анализ сертификата, сделали несколько экспериментов с топологией.

    Анализ помог - поставили правильный fqdn согласно сертификату и все пошло

    5 июня 2013 г. 13:39