none
IIS 7.5 непонятная работа броузеров в локальной сети RRS feed

  • Вопрос

  • Имеем IIS сервер на Windows 2008 std сервере, на нем крутится корпоративный сайт (dotnetnuke v.7.02). Два дня назад, сайт периодически стал падать, причем поднять его помогала только перезагрузка сервера. Глубоко не копая, подняли его на аналогичном сервере Windows 2008 std (сервера оба Intel одинаковые, Xeon, 32Gb память). И вот случай, просто ломающий мозг: на компьютерах пользователей, это Win XP, Win 7, Win 8.1, на некоторых перестал открываться наш сайт, причем на моем компьютере на IE8 - открывается, на Chrome - нет (белый экран). На других компьютерах открывается на всех броузерах, на третьих ни на одном. Проверили сервера на вирусы, поставили обновления для Framework 4.0, обновили сами сервера, компьютеры у нас обновляются все автоматически. Результат нулевой на компах юзеров ничего не поменялось, где открывается, где нет. Компьютеры проверены на вирусы, но ситуацию не переломить. Куда смотреть не знаю, на сервер, на рабочие станции, может на dotnetnuke? Ситуация похожая на бред...

    Вот трассировка с компьютера на котором сайт открывается:

    Вот трассировка с компьютера на котором сайт не открывается:

     
    23 января 2014 г. 8:56

Ответы


  • Пока видно только разницу в статусах, 304 и 404 и то, что в первом случае контент закеширован, но удалось проверить его валидность. Могу посоветовать Fiddler для трассировки с клиентской стороны и Failed request tracing для трассировки со стороны сервера.
    • Предложено в качестве ответа Happy_hippie 23 января 2014 г. 13:13
    • Помечено в качестве ответа Elina Lebedeva 24 января 2014 г. 7:11
    23 января 2014 г. 9:58
  • Спасибо, за бесценный инструментарий! Особенно который на стороне сервера. Будем изучать. Но ситуация пока исправилась (не хочу говорить сама собой), перегрузили стойку со свитчами, возможно ситуация возникла из-за сети, но при чем здесь сетка??? Не понимаю, но пока наблюдаем...
    • Предложено в качестве ответа Happy_hippie 23 января 2014 г. 13:13
    • Помечено в качестве ответа Elina Lebedeva 24 января 2014 г. 7:11
    23 января 2014 г. 10:33

Все ответы

  • Удалить куки, сбросить кеш в браузерах пробовали? Желательно сделать такое как на машинах на которых открывается сайт, так и на тех, на которых не открывается.

    23 января 2014 г. 9:17
  • Не только кэш и куки удалил, я Chrome у себя переставил, та же ситуация, все сайты открывает, этот, нет! Пробовал запускать Chrome с параметрами   --in-process-plugins, --no-sandbox, тоже мимо.
    23 января 2014 г. 9:24

  • Пока видно только разницу в статусах, 304 и 404 и то, что в первом случае контент закеширован, но удалось проверить его валидность. Могу посоветовать Fiddler для трассировки с клиентской стороны и Failed request tracing для трассировки со стороны сервера.
    • Предложено в качестве ответа Happy_hippie 23 января 2014 г. 13:13
    • Помечено в качестве ответа Elina Lebedeva 24 января 2014 г. 7:11
    23 января 2014 г. 9:58
  • Спасибо, за бесценный инструментарий! Особенно который на стороне сервера. Будем изучать. Но ситуация пока исправилась (не хочу говорить сама собой), перегрузили стойку со свитчами, возможно ситуация возникла из-за сети, но при чем здесь сетка??? Не понимаю, но пока наблюдаем...
    • Предложено в качестве ответа Happy_hippie 23 января 2014 г. 13:13
    • Помечено в качестве ответа Elina Lebedeva 24 января 2014 г. 7:11
    23 января 2014 г. 10:33