none
Перестает работать сетевой адаптер на виртуальной машине RRS feed

  • Вопрос

  • Добрый день! проблема в следующем:

    имеется Hyper-V Server 2008 R2  на нем созданы три виртуальные машины, у одной из машин наблюдается следующая проблема раз в неделю перестает работать сетевой интерфейс, в логах машины никаких  сообщение об ошибках нет просто отрубается, гостевая ОС windows server 2008R2 standart edition проблема решается перезагрузкой виртуальной машины. На других двух виртуальных машинах точно такие же системы, проблем нет.

    На физическом хосте один сетевой интерфейс

    сервер Supermicro CSE 745TQ-R800/MB X8DT6

    сетевая карта Intel® 82574L Gigabit Ethernet Controllers

Ответы

Все ответы

  • Обновление, описанное в KB2263829 установлено?
    • Помечено в качестве ответа PePTo_1 7 июня 2012 г. 5:26
    Модератор
  • Обновление, описанное в KB2263829 установлено?
    Это обновление так же актуально и для Hyper-V Server 2008 R2?
  • Да.

    У Вас SP1 установлен вообще?

    Модератор
  • Да.

    У Вас SP1 установлен вообще?

    Да установлен
  • PePTo_1, обновление помогло?


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий


    4 июня 2012 г. 11:04
  • PePTo_1, обновление помогло?


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий


    не знаю что именно помогло: отключение поддержки IPv6 или обнова, но пока  работает стабильно
    4 июня 2012 г. 14:30
  • Для чистоты эксперимента включите IPv6 и проверьте.
    4 июня 2012 г. 15:12
    Модератор
  • Для чистоты эксперимента включите IPv6 и проверьте.
    Включил, полет нормальный, всем спасибо за участие!
  • Доброго всем времени суток.

    Подскажите пожалуйста, может кто сталкивался…

    Имеем:

    Установленный Hyper-V Server 2008 R2 (без SP1), в нем крутится виртуальная машина под управлением Windows Server 2008 Enterprise SP2. На физической машине стоят два сетевых адаптера Intel PRO/1000, один их них отдан под virtual switch.
    Сервер работает на платформе Intel S5000 PAL.

    Проблема похожа на те, что описаны в статьях Microsoft и на ту, что описывает топикстартер, но есть особенность, а именно:

    При старте ВМ, гостевая ОС рапортует о том, что сетевой кабель не подключен, при этом, что интересно, внешняя сеть спокойно пингуется из виртуалки и наоборот, из внешней сети пинги проходят на виртуальную машину, но по RDP гостевая ОС недоступна и еще ряд сетевых сервисов не отрабатываются (клиентские приложения не видят серверной части). Иногда по прошествии 5-10 минут сетевой кабель «вдруг подключается», но чаще приходится ребутать виртуалку до тех пор пока она не заведется с подключенным сетевым кабелем, как правило на второй, третий раз. Иногда и с первого раза заводится нормально. При этом, если уж она завелась нормально, то потом на протяжении всего времени работы (бывает более 3-ех месяцев) никаких сетевых сбоев не наблюдается, все сетевые сервисы работают в штатном режиме, и так собственно до следующей перезагрузки.


    В статье KB2263829 описана похожая проблема, но она относится к Windows Server 2008 R2 SP1. Однако, в ней же есть сноски на материал для Windows Server R2 без пакета SP1, речь идет о статьях 974909 и 2264080. Мне прислали ссылку из Microsoft на хотфикс, описываемый в статье 974909, с акцентом но то, что исправление не протестировано до конца и применимо только для случая, описанного в статье.


    Тем не менее до конца не ясно: применимо ли данное обновление именно к Hyper-V Server 2008 R2, а не Windows Server и входит ли моя ситуация в разряд проблемы описанной в статье? Просто речь идет об очень важной машине и не хотелось бы ухудшить ситуацию или вообще ее сложить.

    Если кто в курсе поделитесь опытом пожалуйста.




    • Изменено CandRecto 9 августа 2012 г. 7:32
    9 августа 2012 г. 7:17
  • А я поделюсь! немного не в ту тему, но суть будет ясна! Лично я сталкивался с такими траблами. Приходит новый сервер, на него льется 2008r2. Сеть есть, но после пары перезагрузок узла она отваливается, адаптеры на месте, а кабель якобы не подключен. Ребут снова - все ок! Суть проста - обязательно ставьте драйвера для сет карт. Не знаю как для hyper v сервера обстоят дела с дровами, но надо обязательно ставить на хост! Я бы даже ради эксперемента поставил бы в гостевую Ос, если бы проблемы продолжались. Хотя может это зря!
    • Изменено It-Kirill 9 августа 2012 г. 17:34
    9 августа 2012 г. 17:33