none
DPM 2012 is out of disk space. Auto growth does not work. RRS feed

  • Вопрос

  • Hi.

    I have a problem with DPM 2012. Even though I have configured DPM to use auto growth, the following error shows in the log regularly.

    I don't want to allocate disk space manually. I want DPM to handle that.

    Does someone have a solution for that?

    Regards
    MHem

    Affected area: Computer\System Protection
    Occurred since: 11-07-2012 09:51:34
    Description: The replica of System Protection Computer\System Protection on "computername" is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. You can recover data from existing recovery points, but new recovery points cannot be created until the replica is consistent.

    For SharePoint farm, recovery points will continue getting created with the databases that are consistent. To backup inconsistent databases, run a consistency check on the farm. (ID 3106)
     DPM is out of disk space for the replica. (ID 58 Details: Internal error code: 0x80990ED2)
     More information
    Recommended action: Ensure there are no pending disk threshold alerts active for this data source and rerun the job. DPM may have automatically grown the volume and resolved the alerts.
     Synchronize with consistency check.
     Modify Disk Allocation ...
     Run a synchronization job with consistency check...
    Resolution: To dismiss the alert, click below
     Inactivate

    Another error message:

    Affected area: F:\
    Occurred since: 11-07-2012 09:56:00
    Description: Since 11. juli 2012 09:56:00, synchronization jobs for F:\ on "computername"have failed. The total number of failed jobs = 1. The last job failed for the following reason: (ID 3115)
     DPM has run out of free space on the recovery point volume and will fail synchronization for F:\ on macoedu01.dhi.dk in order to prevent existing recovery points from being deleted. (ID 30195 Details: Internal error code: 0x80990AB2)
     More information
    Recommended action: Ensure there are no pending recovery point volume threshold alerts active for this data source and rerun the job. DPM may have automatically grown the volume and resolved the alerts.
     Run a synchronization job...
    Resolution: To dismiss the alert, click below
     Inactivate

    Another error: (Remember auto growth is enabled)

    Status: Recovery point creation failed
    Replica path: Click to view details
    Latest recovery point: 10-07-2012 18:04:07
    Oldest recovery point: 09-07-2012 16:19:20
    Total recovery points: 4
    Disk allocation: Replica volume: 64,66 GB allocated, 31,56 GB used | Recovery point volume: 32,26 GB allocated, 21,69 GB used

    • Изменено MHem 11 июля 2012 г. 9:11
    11 июля 2012 г. 8:53

Ответы

  • Hi Mhem,

    it's an internal timer that prevents more than one autogrow operation to occur in any 15 minute time interval to prevent unexpected growth. It's by Design, meaning you couldn't change this behaviour.

    Did you take a look at Windows event viewer ? If you see a lot of events 33143 and 3314 it's maybe because you have underallocated disk allocation.

    Then You should consider to manually modify your disk allocation with for example a minimum of 10 GB.

    (Autogrowth add a minimum of 10Gb or 25% of the volume size to the recovery point volume)

    http://blogs.technet.com/b/dpm/archive/2011/06/06/how-to-use-and-troubleshoot-the-auto-heal-features-in-dpm-2010.aspx

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    • Помечено в качестве ответа MHem 11 июля 2012 г. 12:09
    11 июля 2012 г. 10:47

Все ответы

  • Hi Mhem,

    DPM will only auto-grow a volume one time in any 15 minute, so DPM may have auto-grown the volume, but if it got filled again within 15 minutes, job will fail. 

    Look in the Windows application event log for autogrow events 33143 and 33144 from source MSDPM.

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    11 июля 2012 г. 9:22
  • Hi Stephane.

    How do i change that. First of all I don't want to get these errors and second if I get these errors I don't want to wait 15 minutes every time before I can start the backup job again.

    MHem

    11 июля 2012 г. 9:32
  • Hi Mhem,

    it's an internal timer that prevents more than one autogrow operation to occur in any 15 minute time interval to prevent unexpected growth. It's by Design, meaning you couldn't change this behaviour.

    Did you take a look at Windows event viewer ? If you see a lot of events 33143 and 3314 it's maybe because you have underallocated disk allocation.

    Then You should consider to manually modify your disk allocation with for example a minimum of 10 GB.

    (Autogrowth add a minimum of 10Gb or 25% of the volume size to the recovery point volume)

    http://blogs.technet.com/b/dpm/archive/2011/06/06/how-to-use-and-troubleshoot-the-auto-heal-features-in-dpm-2010.aspx

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    • Помечено в качестве ответа MHem 11 июля 2012 г. 12:09
    11 июля 2012 г. 10:47
  • Hi,

    Is there a way to change this parameter (internal timer that prevents more than one auto grow operation to occur in any 15 minute time interval)?

    Lior

    16 сентября 2014 г. 7:43
  • Hi,

    No - the auto-grow is hard coded as we don't want runaway growth without understanding the requirement based on the data source size and churn rate.   Lets DPM reached equilibrium where deleted snapshots equaled daily churn so all was running smoothly. Now say some user dumped 50GB of pictures on a protected volume temporarily then deleted them.  If DPM auto grew the replica to accommodate that 50GB the replica would grow and as a result of the file deletions, the recovery point volume may also get bloated.  By preventing runaway growth we won't continue to auto grow if done more than once in a 15 minute window.  This gives DPM administrators a chance to investigate why the space is required and see if it's a permanent requirement, or just a temporary condition that may not be desirable to fix. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Предложено в качестве ответа Lior_f 16 сентября 2014 г. 12:25
    • Отменено предложение в качестве ответа Lior_f 16 сентября 2014 г. 12:25
    • Предложено в качестве ответа Lior_f 16 сентября 2014 г. 12:26
    • Отменено предложение в качестве ответа Lior_f 16 сентября 2014 г. 12:26
    • Предложено в качестве ответа Lior_f 16 сентября 2014 г. 12:26
    16 сентября 2014 г. 12:13
    Модератор
  • Hi,

    Thank you Mike for clarifying this. I had the same "problem" but when understanding the underlying

    parameters it really is't a problem.

    Great post.

    Peter Å. Stockholm

    3 октября 2014 г. 9:04