none
авторизация доменных пользователей RRS feed

  • Вопрос

  • Добрый день, прошу помочь разобраться.

    Есть сервер Exchange 2010. Последнее время начали получать письма с поддельным полем "От" (якобы сотрудник сам себе отправляет)

    Открываю telnet с внешнего рабочего места, подключаюсь и происходит вот такой диалог:

    220 MAIL.MYCOMPANY.RU Microsoft ESMTP MAIL Service ready at Wed, 9 Oct 2019 13:45:21 +0300
    helo
    250 MAIL.MYCOMPANY.RU Hello [83.220.238.147]
    mail from: ivanov@mycompany.ru
    250 2.1.0 Sender OK
    rcpt to: ivanov@mycompany.ru
    250 2.1.5 Recipient OK
    data
    354 Start mail input; end with <CRLF>.<CRLF>
    subject: subject
    message
    .
    250 2.6.0 <53118033-d248-4275-99a3-db2e1573b94f@MAIL.MYCOMPANY.RU> [InternalId=1078856] Queued mail for delivery              

    Т.е. никакой проверки подлинности отправителя из обслуживаемого этим сервером домена не требуется.

    Иду в Конфигурация сервера - Транспортный сервер-концентратор - Соединители получения - Default.

    Если убираю галку "Анонимные пользователи", то перестает приходить входящая почта с ошибкой отправителю "530 5.7.1 Client was not authenticated"

    Вот вывод Get-SenderFilterConfig:

    RunspaceId                   : 8a1a3250-5b7a-408d-ab27-a54753a2e4af
    Name                         : SenderFilterConfig
    BlockedSenders               : {}
    BlockedDomains               : {}
    BlockedDomainsAndSubdomains  : {mycompany.ru}
    Action                       : Reject
    BlankSenderBlockingEnabled   : True
    RecipientBlockedSenderAction : Reject
    Enabled                      : False
    ExternalMailEnabled          : True
    InternalMailEnabled          : False
    AdminDisplayName             :
    ExchangeVersion              : 0.1 (8.0.535.0)
    DistinguishedName            : CN=SenderFilterConfig,CN=Message Hygiene,CN=Transport Settings,CN=mycompany,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=MYCOMPANY,DC=RU
    Identity                     : SenderFilterConfig
    Guid                         : ca3f0259-e40d-4ecc-accf-ac724b3625ba
    ObjectCategory               : MYCOMPANY.RU/Configuration/Schema/ms-Exch-Message-Hygiene-Sender-Filter-Config
    ObjectClass                  : {top, msExchAgent, msExchMessageHygieneSenderFilterConfig}
    WhenChanged                  : 08.08.2019 15:02:53
    WhenCreated                  : 04.07.2013 22:26:29
    WhenChangedUTC               : 08.08.2019 12:02:53
    WhenCreatedUTC               : 04.07.2013 19:26:29
    OrganizationId               :
    OriginatingServer            : mail.mycompany.ru
    IsValid                      : True

    Как правильно настроить Exchange, чтобы запретить отправку писем без авторизации от внутренних пользователей ?


    9 октября 2019 г. 11:02

Ответы

  • Добрый день.

    Для Exchange 2010 работает вот это:

    Remove-ADPermission <ReceiveConnector Name> –user “NT AUTHORITY\Anonymous Logon” –ExtendedRights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender

    Сделайте и проверьте пожалуйста.
    • Помечено в качестве ответа Павел Lipser 9 октября 2019 г. 12:14
    9 октября 2019 г. 11:40

Все ответы

  • Добрый день.

    Для Exchange 2010 работает вот это:

    Remove-ADPermission <ReceiveConnector Name> –user “NT AUTHORITY\Anonymous Logon” –ExtendedRights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender

    Сделайте и проверьте пожалуйста.
    • Помечено в качестве ответа Павел Lipser 9 октября 2019 г. 12:14
    9 октября 2019 г. 11:40
  • Да, после применения команды все работает. Вначале диалог с сервером идет как обычно, получаем Sender OK, но после попытки передать сообщение ("." в конце сеанса) вываливается: 550 5.7.1 Client does not have permissions to send as this sender

    Спасибо большое

    P.s. Для тех у кого русскоязычная версия Exchange - команда будет выглядеть вот так:

    Remove-ADPermission "ReceiveConnector Name" –user “NT AUTHORITY\АНОНИМНЫЙ ВХОД” –ExtendedRights ms-Exch-SMTP-Accept-Authoritative-Domain-Sender

    9 октября 2019 г. 12:14