none
SPS update error "There are no products affected by this package installed on this system" RRS feed

  • Общие обсуждения

  • Здравствуйте.

    При попытке установить обновление на сервер Sharepoint, получаю сообщение о том что

    "There are no products affected by this package installed on this system"

    Если указываю ключ "PACKAGE.BYPASS.DETECTION.CHECK=1", сразу пишет что обновление удачно установлено.

    Обновления ставил поочередно на все сервера и все шло удачно. Но на последнем возникла проблема.

    Чистил кеш  Sharepoint'a перезапускал службы, рестартил сервер. Все безрезультатно.

    В админке вижу такую надпись "Внимание! На серверах фермы в настоящее время установлены различные продукты с различным уровнем обновления. Не следует выполнять обновление ни одного из серверов до тех пор, пока набор установленных на них продуктов и обновлений не будет одинаковым."

    Но как установить одинаковый набор когда обновления не устанавливаются?

    В мастере настроек так же ошибки о том что такой то пакет отсутствует или не установлен.

    На сервер крутится пара сайтов.

    15 сентября 2015 г. 13:50

Все ответы

  • Здравствуйте,
    Посмотрите пригодится ли Вам нижеуказанная статья:

    CU installation error - "There are no products affected by this package installed on this system"

    Также я нашел и следующее решение данной ошибки:

    Fix: I removed all of the security updates that were applied the same day I installed SP1, restarted the server, and was allowed to run the SharePoint Products Configuration Wizard immediately following the restart.


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    16 сентября 2015 г. 6:34
    Модератор
  • Сегодня снова пытался решить проблему на сервере не выводя его из фермы.

    К сожалению безуспешно.

    Подскажите пожалуйста. Чем чреват вывод сервера на котором крутятся сайты из фермы?

    Сайт будет недоступен? (до повторного подключения в ферму)

    Смогу ли я его не потеряв данные и настройки заново подключить его к ферме?

    В данный момент имею два wfe сервера которые обслуживают различные сайты.

    Есть ли возможность не теряя доступность мигрировать сайт на другой сервер, чтоб я имел возможность безболезненно решать проблему с проблемным сервером.

    Честно говоря. Я не совсем понимаю зависимость выход/вход в ферму, с возможностью устанавливать  на сервер апдейты.

    Дело в том, что досталась в наследство ферма Sharepoint 2013 из 6-ти серверов (зачем???) которые настроены непойми как.

    Версия:15.0.4641.1000

    Анализатор работоспособности просто пестрит ошибками.

    Не работают (некорректно работают) службы/рабочие процессы.

    Быстродействие хромает на обе ноги.

    И вообще ситуация немного плачевная.

    В общем в данный момент я решаю критические ошибки из анализатора (уже практически все хорошо).

    Попутно пытаюсь обновить до одинаковой версии все сервера.

    А потом приступлю к разбору и оптимизации ресурсов.

    Буду благодарен за подсказки и напутствие.

    16 сентября 2015 г. 15:23
  • Как я и подозревал, отключение сервера от фермы окончилось проблемой.

    Из за несовпадения версий и количества обновлений, вернуть его обратно в ферму не получается.

    И обновления на него по прежнему не накатываются.

    Сейчас видимо придется поднять новый сервер и вводить его в домен/ферму и настраивать веб приложение на нем. Старый починить не получается.

    Ошбика подключении к ферме "Объект SharePoint_Admin content_XXXXXX находится в неподдерживаемом состоянии и не может быть использована"

    Может кто сталкивался с подобным?

    Все остальные сервера в данный момент ошибок по соответствию не выдают и работают нормально.

    Во время "шаманств" все более склоняюсь к мнению что ошибки и косяки с обновлениями появились на сервере после установки/переустановки офисного пакета.

    23 сентября 2015 г. 18:56