locked
Windows 2012R2, language bar disappears after shadow RRS feed

  • Вопрос

  • Hi,

    We faced with the problem: when administrator disconnects from his shadow session, language bar in user's session disappears (hot keys stop working too).

    Hardware/Software:
    1. Clients: Win8.1 (pc), WinCE (thinclient)
    2. Servers: Win2012R2 (all hotfixes have been installed)
    3. Roles: RDS
    4. Administrators' pc: Win8.1 (pc)

    Steps to reproduce:
    1. Users open their sessions. Language switching works fine, language bar is on its place.
    2. Administrator connects to active session with command: mstsc /v:%HOSTNAME% /shadow:%SESSIONID% /control /noconsentprompt
    3. User's issue resolved. Administrator closes his shadow window and language bar disappears in the user's session (hot keys also stop working). User has to logoff and then logon again.

    I found that the Remote Assistant has the same issue too (msra /offerRA %USERPCNAME% -> Help -> Disconnect -> lang issue).

    May be someone faced with the same issue too?
    Thank you for your help.


    • Изменено Sintez_ 22 января 2015 г. 9:08
    22 января 2015 г. 9:08

Ответы

  • Hi Amy,

    Thank you for the answer. I found issue and solution.
    The problem was in two registry branches which I deployed to USER by GPO:

    1. HKEY_CURRENT_USER\Keyboard Layout\Preload
    2. HKEY_CURRENT_USER\Keyboard Layout\Toggle

    It's comfortable for use to pre-set these settings to user by administrator. We used to apply them in Win2003 servers (Citrix XenApp 5.0). And I copied these settings to a new system. All works fine except RDP shadow session. I described the issue before. Now I can connect without any keyboard/language problem.

    Thank you :)

    • Помечено в качестве ответа Sintez_ 24 февраля 2015 г. 8:03
    24 февраля 2015 г. 8:03

Все ответы

  • Hi,

    From your description it seems you are talking about below snap, if this is the case then I can say that it’s by design (as language bar will disappear after shadow) and we can’t change it. Regarding Hot keys, for my case it's working fine. please try to restart the client system and again check the result.


    Hope it helps!

    Thanks.

     

    Dharmesh Solanki

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    23 января 2015 г. 3:34
  • Thank you for your answer. Unfortunately, you understood me wrong. I can't post images or links before account verification. I posted a query for it. After that I'll make a full answer with screenshots.

    Thank you.




    • Изменено Sintez_ 23 января 2015 г. 11:51
    23 января 2015 г. 9:49
  • Hi,

    Thank you for your answer. I created screenshots that can explain my issue. You can see that user are able to switch languages and also there is a language bar in the corner. But if I connect to his session (shadow), my language settings cover his language preference. It's by OS design. Then I disconnect from session (close window). And all user's language switching functions disappear (including hotkeys).

    Unfortunately, no one wants to verify my account so can I ask you follow the link to see my screenshot: _ttp://lakra-sintez.ru/shadow.png

    Thank you!

    27 января 2015 г. 6:18
  • Hi,

    I have tested with a Windows Server 2012 R2 Standard Terminal Services server, a Windows 7 and a Windows 8.1 client.

    My test results are when perform shadowing, the local server’s language bar disappears, but the  language bar setting of the shadow session is the same as client side remote session’s as below:

    After the shadow session is closed, local language bar setting comes back:

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Изменено Amy Wang_ 7 февраля 2015 г. 6:29
    7 февраля 2015 г. 6:26
  • Hi Amy,

    Thank you for the answer. I found issue and solution.
    The problem was in two registry branches which I deployed to USER by GPO:

    1. HKEY_CURRENT_USER\Keyboard Layout\Preload
    2. HKEY_CURRENT_USER\Keyboard Layout\Toggle

    It's comfortable for use to pre-set these settings to user by administrator. We used to apply them in Win2003 servers (Citrix XenApp 5.0). And I copied these settings to a new system. All works fine except RDP shadow session. I described the issue before. Now I can connect without any keyboard/language problem.

    Thank you :)

    • Помечено в качестве ответа Sintez_ 24 февраля 2015 г. 8:03
    24 февраля 2015 г. 8:03
  • We have this problem too. Please describe, how did you solve this problem. I tried to delete registry preferences from GPO, but it did not help.
    11 декабря 2015 г. 11:59
  • Hi Amy,

    Sorry for 'necroposting', but

    The thing is the after you disconnect from a [shadow] client's remote session the client gets a disappearing language bar.


    • Изменено Rdnaskel 19 января 2017 г. 15:32
    19 января 2017 г. 15:32