none
Проблема с флэш на клиентских машинах в firefox, opera и chrome RRS feed

  • Общие обсуждения

  • Дорогие коллеги
    Возникла такая проблема. На веб сайте (работает на IIS) перестали отображаться флеш заставки в firefox, opera, chrome. В IE все работает. Когда логинюсь на сервер и там запускаю браузер Firefox, там все работает. Локальные копии страниц с флеш роликами отображаются нормально. В чем может быть дело и как исправить ситуацию? Заранее большое спасибо.
    Василий.
    2 февраля 2010 г. 11:17

Все ответы

  • А этот сайт доступен через Интернет? Проблему проще понять если её увидеть :-) А так можно наугад перебирать варианты... Может к примеру сервер отдаёт неправильный Content-Type в HTTP-заголовке? Если зайти на сервер telnet'ом на 80-й порт и сделать
    HEAD /путь_к_файлу.swf  HTTP/1.1
    Host: имя_сервера

    (потом два раза Enter), то что он выдаст в заголовке? Если не получится, то HEAD попробовать заменить на GET, правда тогда он выдаст и содержимое файла.
    5 февраля 2010 г. 7:30
  • стоит спросить у разработчиков этих браузеров.
    Трухин Юрий Владимирович
    14 марта 2010 г. 10:27
  • стоит спросить у разработчиков этих браузеров.
    Трухин Юрий Владимирович

    Это предложение лишь характеризует вашу "объективность" в данном вопросе. Если разные браузеры не показывают флеш, значит скорее что-то с настройками сервера, а то, что Internet Explorer его всё-таки показывает, может объясняться нестандартным поведением (например может IE игнорирует Content-Type, и определяет тип файла по содержимому, если так, то он маскирует ошибку системного администратора, оказывая ему медвежью услугу - лучше обнаружить и исправить такую ошибку, чем потом узнать, что она уже долгое время создаёт те или иные проблемы - сайт может неправильно отображаться в других браузерах, наверное возможна проблема при индексации сайта поисковиками и т.д.). Может проблема другая, но она явно в настройках сервера, может в путях к файлу и т.п.

    Ладно бы если бы речь шла об особенностях отображения стилей или ещё о чём-то более-менее сложном, тогда вариант, когда только один из браузеров работает правильно, а остальные - нет, вполне возможен и сразу вряд ли стоит его отбрасывать. Но когда речь идёт о простой операции - получить файл и отобразить его при помощи плагина, вряд ли стоит ожидать, что три браузера поступят неверно, и только IE правильно :-) У Firefox, Opera и Chrome разные движки, вы вероятно этого не знали? Как вы думаете, могут ли три разных коллектива разработчиков допустить аналогичные ошибки? :-) В общем, ошибка явно была на сайте, и любой более-менее разбирающийся в обсуждаемом предмете человек придёт к аналогичному выводу. Вы пришли к противоположному - что говорит в лучшем случае о вашей предвзятости.
    16 марта 2010 г. 7:24