none
Не подключается EMS и EMC. Проблема с WinRM RRS feed

Ответы

  • попробовал,

    не знаю что помогло, обновления или выдержка и ваша помощь, но оснастка добавилась. Перед этим поставились обновления  для NetFramework 3.5 и 4 и накопительное обновление 7. Но еще до накопительного обновления Exchange Management Troubleshooter вернул, что всё хорошо и подключился к серверу. EMS и EMC тоже сразу подключились. А вот OWA наоборот перестал работать. :)

    Но это уже другая история

    15 октября 2012 г. 18:43
  • Всё починил. Большое спасибо за участие!

    Не правильно стоял тип авторизации на owa. Выставил в ходе экспериментов. Посмотрел по записям что делал и нашел кривость. 

    16 октября 2012 г. 3:49

Все ответы

  • Проблема подключения только с одного компьютера или с многих?

    Локально на сервере оснастки запускаются и работают?


    Сазонов Илья http://isazonov.wordpress.com/

    15 октября 2012 г. 9:42
    Модератор
  • подключаюсь только на сервере, где стоит MS Exchange 2010
    15 октября 2012 г. 9:48
  • Тогда проверяйте, что удаленно работает WS-Management: на порту 5900 что-то есть? в фаэрволе порт открыт?

    Сазонов Илья http://isazonov.wordpress.com/

    15 октября 2012 г. 10:58
    Модератор
  • порт 5900 никто не слушает,файрвол выключен, служба WinRM - запущена

    15 октября 2012 г. 11:26
  • Добрый день.

    • Проверьте в оснастке IIS запущен ли сайт "Default Web Site"
    • Попробуйте выполнить в командной строке: winrm quickconfig
    Если не поможет, попробуйте запустить Exchange Management Troubleshooter
    15 октября 2012 г. 13:06
    Отвечающий
  • IIS работает. Default Web Site запущен. OWA и сопутствующие работают. Только \powershell не проходит тестирование. Ругается, что недопустимый путь приложения. Думаю в этом дело, но как поправить не знаю.

    winrm quickconfig делал некоторое время назад, не помогло.

    15 октября 2012 г. 13:49
  • Попробуйте пересоздать. Выполните эти команды по очереди в обычном powershell:

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010
    Get-PowerShellVirtualDirectory | Remove-PowerShellVirtualDirectory
    New-PowerShellVirtualDirectory -Name "PowerShell"
    IISRESET /NOFORCE /TIMEOUT:180


    15 октября 2012 г. 13:57
    Отвечающий
  • не чего не изменилось. Результат тот же.

    owa перестал работать :)

    • Изменено Invisus 15 октября 2012 г. 14:24
    15 октября 2012 г. 14:15
  • Что покажет: Exchange Management Troubleshooter
    15 октября 2012 г. 14:36
    Отвечающий
  • покажет, что ни set-user, ни get-user  ему не известны, а без этого:

    "The user account that is attempting to connect is not Remote PowerShell enabled. To check if a user is enabled for Remote PowerShell, you need to open the Exchange Management Shell with an account that has been enabled, and run the following query: (Get-User <username>).RemotePowershellEnabled This will return a True or False. If the output shows False, the user is not enabled for Remote PowerShell. To enable the user, run the following command: Set-User <username> -RemotePowerShellEnabled True" 

    15 октября 2012 г. 14:44
  • Попробуйте выполнить:

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010
    Set-User user_name -RemotePowerShellEnabled:$True
    И опять запустить Troubleshooter.

    15 октября 2012 г. 14:49
    Отвечающий
  • Запустите EMS и выполните:

    Set-User user_name -RemotePowerShellEnabled:$True

    Затем опять запустите Troubleshooter.

    И приведите пожалуйста вывод команды из командной строки:

    netsh winhttp show proxy

    15 октября 2012 г. 15:15
    Отвечающий
  • Имя "Set-user" не распознано как имя командлета...

    netsh - Прямой доступ "без прокси-сервера"

    Сейчас ставлю все обновления, которые были не подписаны во WSUS и не установлены, может быть поможет, лишними не будут.

     
    15 октября 2012 г. 15:24
  • А когда вы запускали команды первый раз, такой ошибки не было?

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010
    Get-PowerShellVirtualDirectory | Remove-PowerShellVirtualDirectory
    New-PowerShellVirtualDirectory -Name "PowerShell"
    IISRESET /NOFORCE /TIMEOUT:180

    15 октября 2012 г. 15:34
    Отвечающий
  • Покажите, что выдаст:

    Get-PSSnapin -Registered

    15 октября 2012 г. 15:40
    Отвечающий
  • [PS] C:\Windows\system32>Get-PSSnapin -Registered
    Name        : FSSPSSnapIn
    PSVersion   : 1.0
    Description : Интерфейс Forefront Server Protection Powershell
    Name        : Microsoft.Exchange.Management.PowerShell.E2010
    PSVersion   : 1.0
    Description : Admin Tasks for the Exchange Server
    Name        : Microsoft.Exchange.Management.PowerShell.Setup
    PSVersion   : 1.0
    Description : Setup Tasks for the Exchange Server
    Name        : Microsoft.Exchange.Management.Powershell.Support
    PSVersion   : 1.0
    Description : Support Tasks for the Exchange Server
    Name        : Microsoft.Forefront.Server.Management.UISupport
    PSVersion   : 1.0
    Description : Интерфейс Forefront Server Protection Powershell
    Name        : Windows.ServerBackup
    PSVersion   : 2.0
    Description : Данная оснастка Windows PowerShell для системы архивации данных Windows Server содержит командлеты, которые использовались для настройки, запуска и управления архивами.
    


    15 октября 2012 г. 15:48
  • Попробуйте еще раз на сервере Exchange:

    Add-PSSnapin -Name "Microsoft.Exchange.Management.PowerShell.E2010"



    15 октября 2012 г. 15:59
    Отвечающий
  • попробовал,

    не знаю что помогло, обновления или выдержка и ваша помощь, но оснастка добавилась. Перед этим поставились обновления  для NetFramework 3.5 и 4 и накопительное обновление 7. Но еще до накопительного обновления Exchange Management Troubleshooter вернул, что всё хорошо и подключился к серверу. EMS и EMC тоже сразу подключились. А вот OWA наоборот перестал работать. :)

    Но это уже другая история

    15 октября 2012 г. 18:43
  • Рад слышать, что заработало.

    А какую ошибку owa выдает?

    15 октября 2012 г. 19:29
    Отвечающий
  • Всё починил. Большое спасибо за участие!

    Не правильно стоял тип авторизации на owa. Выставил в ходе экспериментов. Посмотрел по записям что делал и нашел кривость. 

    16 октября 2012 г. 3:49