none
В Windows server 2012 при старте ВМ ошибка 0x80070001. В загрузчик ставлю исо или без диска. RRS feed

  • Вопрос

  • Сервер со всеми обновлениями. Роль переустанавливал. Машины не стартуют как старые так и только что созданные. Несколько хостов эксплуатируются, так что опыт работы с Hyper-v есть. Для спортивного интереса не хочу переустанавливать сервер.

    Ничего не предвещало, потом как-то раз и ошибка появилась. Заметил когда захотел на сервер мигрировать ВМ с другого хоста. Кластера нет, памяти RAM и HDD достаточно.


    NVM

    19 апреля 2013 г. 18:04

Ответы

Все ответы

  • Import-Module Hyper-V работает?

    20 апреля 2013 г. 17:24
    Отвечающий
  • я могу делать импорт и экспорт, но машины не стартуют. Создал только что новую, в нет нет ничего, ни жесткого диска, ни сети, даже привод убрал.

    Та же ошибка... что-то в недрах windows , так как роль переустанавливал.


    NVM

    21 апреля 2013 г. 5:01
  • Вы так и не ответили, модуль Hyper-V в Powershell загружается? Вы делали in-place upgrade, или это система с "чистой" установкой?
    21 апреля 2013 г. 6:35
    Отвечающий
  • Стоял сервер 2012...на нем работал Hyper-v.... возможно после очередного обновления или без обновления.... Виртуалки перестали запускаться. Я пользуюсь GUI. Апгрейдов никаких не делалось.  Да и какая разница через шел или гуи... Механизмы одинаковые используются.

     Скажите что нужно выполнить с консоли я проверю.


    NVM

    21 апреля 2013 г. 20:32
  • Запустите Powershell c повышенными привилегиями, загрузите модуль Hyper-V

    Import-Module Hyper-V

    попробуйте запустить виртуальную машину

    Start-VM –Name TestVM
    где TestVM, введите имя любой Вашей виртуальной машины, ошибку сюда.

     

    21 апреля 2013 г. 21:06
    Отвечающий
  • Windows PowerShell
    (C) Корпорация Майкрософт, 2012. Все права защищены.

    PS C:\Windows\system32> Import-Module Hyper-V
    PS C:\Windows\system32> Start-VM -Name Test01
    Start-VM : Не удалось запустить "test01". (ИД виртуальной машины D3491CC9-AC86-49AA-858A-7EC0AE00B8DE)
    "test01" не удалось запустить рабочий процесс: Неверная функция. (0x80070001). (ИД виртуальной машины D3491CC9-AC86-49A
    A-858A-7EC0AE00B8DE)
    строка:1 знак:1
    + Start-VM -Name Test01
    + ~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (Microsoft.HyperV.PowerShell.VMTask:VMTask) [Start-VM], VirtualizationOper
       ationFailedException
        + FullyQualifiedErrorId : OperationFailed,Microsoft.HyperV.PowerShell.Commands.StartVMCommand

    PS C:\Windows\system32>

    NVM

    22 апреля 2013 г. 9:52
  • Попробуйте сделать виртуальную машину, в месте, отличном от текущего, например на другом диске. Кстати, текущее расположение виртуальных машин сейчас где?

    22 апреля 2013 г. 12:59
    Отвечающий
  • Пробовал на разных дисках создавать, не влияет. На хосте три диска не зависимых физических.

    NVM

    22 апреля 2013 г. 15:59
  • тему перевожу из другой ветки, если можно админам перенести сюда.

    пишу сюда так как ответа нет.

    http://social.technet.microsoft.com/Forums/ru-RU/WS8ru/thread/73b3121f-891c-4712-9328-b246a67f8f9f/

    Сервер со всеми обновлениями. Роль переустанавливал. Машины не стартуют как старые так и только что созданные. Несколько хостов эксплуатируются, так что опыт работы с Hyper-v есть. Для спортивного интереса не хочу переустанавливать сервер.

    Ничего не предвещало, потом как-то раз и ошибка появилась. Заметил когда захотел на сервер мигрировать ВМ с другого хоста. Кластера нет, памяти RAM и HDD достаточно.


    NVM


    NVM

    24 апреля 2013 г. 9:10
  • Здравствуйте Василий,

    Пишите в старой теме,так как там есть уже шаги исправления проблемы.

    25 апреля 2013 г. 11:09
    Модератор
  • а где шаги исправления проблемы ? я предполагал что в другой ветке подключаться люди работающие с виртуализацией.... 

    NVM

    25 апреля 2013 г. 11:22
  • Переустановка OS на хосте, поскольку ценности в нем нет! Виртуальные машины в сторону, на ленту, на другой сервер. Все!

    25 апреля 2013 г. 11:35
    Отвечающий
  • То есть сообщество бессильно, раз в интернете нет описания этой ошибки....

    На всякий случай  есть одна особенность в хосте, это Windows server 2012 Datacenter. Вдруг кто столкнется с похожим.

    Со стандартом такого не наблюдалось еще.

    Ладно, спортивный интерес закрываем, переустановлю.


    NVM

    25 апреля 2013 г. 11:58
  • обновляю биос на сервере, стоял еще инженерный образец... о результатах напишу

    NVM

    26 апреля 2013 г. 6:45
  • все обновил ничего не изменилось. Переустановил, все теперь работает.

    NVM

    29 апреля 2013 г. 4:42