none
Проблема с autodiscover RRS feed

  • Вопрос

  • Добрый вечер всем

    Вводные: Server 2008 R2 Enterprise + Exchange 2010

    Симптомы: после добавления нового пользователя через EMC логинюсь под ним на сервер RDP в этом же домене, запускаю Outlook, Далее-Далее, определяется имя пользователя и его почтовый ящик, Далее, на следующем экране 3 пункта: Установка сетевого подключения проходит успешно, но в момент "Поиск параметров для ...." Outlook падает. Пробовал под разными пользователями - одно и то же. 

    Решил посмотреть что там отдается по autodiscovery. Открываю браузером  адрес http://autodiscover.domain.su/autodiscover/autodiscover.xml, а там буквально вот так: 

    Вы не имеете разрешения на просмотр этого каталога пли страницы.

    Декодер подсказывает, что имеется ввиду "Вы не имеете разрешения на просмотр этого каталога пли страницы."

    Подозреваю, что проблема на стороне IIS, но куда копать что то не соображу. Помогите плз


    20 марта 2019 г. 18:55

Ответы

  • Обратил внимание, что перед тем как упасть Outlook запрашивает разрешение использовать недоверенный сертификат. После подтверждения Outlook падает.


    Нажмите "Просмотр сертификата" и посмотрите его: совпадает ли зачеркнутое вами имя с именем, для которого выдан сертификат (если в там есть звёздочка - совпадает ли с этой маской) или с одним из дополнительных имен субъекта на вкладке Состав (судя по ошибке, совпадений нет, а потому сертификат не годен). Заодно посмотрите - это тот сертификат, который стоит на сервере Exchange, или Outlook куда-то не туда занесло.

    Слава России!


    • Изменено M.V.V. _ 22 марта 2019 г. 7:49
    • Помечено в качестве ответа Павел Lipser 28 марта 2019 г. 13:45
    22 марта 2019 г. 7:48

Все ответы

  • Добрый день.
    Ошибка дословно гласит:
    "Вы не имеете разрешения на просмотр этого каталога пли страницы."

    1. Из другого места проверьте эту ссылку, должно запросить креды и выдать стандартный XML с 600* ошибкой.
    И кстати - с проблемного сервера OWA открывается нормально?

    2. Если п.1 ок, то проверяйте rdp сервер - нет ли прокси или dlp системы на пути к cas exchange.

    3. Если п.2 не ок, покажите вывод для начала
    get-exchangeserver 'ваш cas сервер' | get-autodiscovervirtualdirectory | fl

    4. Посмотрите внимательно, не сбились ли настройки на виртуальных директориях:
    https://blogs.technet.microsoft.com/exchange/2010/09/23/default-settings-for-exchange-related-virtual-directories-in-exchange-server-2010/
    21 марта 2019 г. 5:44
  • 1. Немного был не прав. Вышеуказанная ошибка появляется пр использовании протокола HTTP. При использовании HTTPS после запроса пароля получаем ErrorCode 600

    2. Все серверы находятся в одной подсети и видят друг-друга напрямую.

    3. Права все проверил, есть небольшие различия на паре папок - в некоторых местах разрешено больше методов проверки аутентификации.

    Судя по п.1 теперь понимаю, что проблема может быть совсем не в autodiscovery, но клиентский outlook продолжает падать в момент получения параметров настройки. Что еще можно предпринять ?

    21 марта 2019 г. 14:24
  • Обратил внимание, что перед тем как упасть Outlook запрашивает разрешение использовать недоверенный сертификат. После подтверждения Outlook падает.

    21 марта 2019 г. 14:34
  • https://testconnectivity.microsoft.com вам в помощь, отличный ресурс, постоянно выручает, все косяки видно.
    22 марта 2019 г. 5:13
  • Обратил внимание, что перед тем как упасть Outlook запрашивает разрешение использовать недоверенный сертификат. После подтверждения Outlook падает.


    Нажмите "Просмотр сертификата" и посмотрите его: совпадает ли зачеркнутое вами имя с именем, для которого выдан сертификат (если в там есть звёздочка - совпадает ли с этой маской) или с одним из дополнительных имен субъекта на вкладке Состав (судя по ошибке, совпадений нет, а потому сертификат не годен). Заодно посмотрите - это тот сертификат, который стоит на сервере Exchange, или Outlook куда-то не туда занесло.

    Слава России!


    • Изменено M.V.V. _ 22 марта 2019 г. 7:49
    • Помечено в качестве ответа Павел Lipser 28 марта 2019 г. 13:45
    22 марта 2019 г. 7:48
  • Проверьте настройки URL

    Get-OwaVirtualDirectory -Server $($server.name) | Select-Object InternalUrl,ExternalUrl 
    Get-EcpVirtualDirectory -Server $($server.name) | Select-Object InternalUrl,ExternalUrl 
    Get-ActiveSyncVirtualDirectory -Server $($server.name) | Select-Object InternalUrl,ExternalUrl 
    Get-WebServicesVirtualDirectory -Server $($server.name) | Select-Object InternalUrl,ExternalUrl 
    Get-OabVirtualDirectory -Server $($server.name) | Select-Object InternalUrl,ExternalUrl 
    Get-MapiVirtualDirectory -Server $($server.name) | Select-Object InternalUrl,ExternalUrl 
    Get-OutlookAnywhere -Server $($server.name) | Select-Object ExternalHostname,InternalHostname,ExternalClientsRequireSsl,InternalClientsRequireSsl 
    Get-ClientAccessService -Identity $($server.name) | Select-Object AutoDiscoverServiceInternalUri


    MCITP, MCSE. Regards, Oleg

    22 марта 2019 г. 12:47
    Модератор
  • Да, одна из проблем была действительно в сертификате - неправильно было указано имя autodiscover.  Также помогло наличие второго сервера в DAG - при его активации настройка нового Outlook происходила без ошибок. После сверки и синхронизации параметров на обоих серверах ошибка пропала.

    Непонятным осталось как проблемный сервер обслуживал клиентов на протяжении полугода с ошибочным сертификатом. Подозреваю, что ошибка была не только в нем.

    28 марта 2019 г. 13:49
  • Непонятным осталось как проблемный сервер обслуживал клиентов на протяжении полугода с ошибочным сертификатом.

    Service Connection Point (SCP) In Exchange 2010…

    MCITP, MCSE. Regards, Oleg

    29 марта 2019 г. 19:45
    Модератор