none
Добавление шаблонов в SharePoint Services RRS feed

  • Вопрос

  • Загрузил с Microsoft шаблоны приложений для WSS 3.0. Следуя инструкциям добавил решения в базу через stsadm, выполнил развертывание. В списке решений они появляются. Но при попытке создать сайт на их основе вкладка "Application templates" не появляется.
    При предыдущей установке WSS в стандартной конфигурации аналогичные действия приводили к желаемому результату. Нынешняя инсталляция была проведена в режиме установки фермы серверов. Отличается ли схема установки решений для одиночного сервера и сервера в составе фермы?
    26 ноября 2008 г. 10:29

Ответы

  • Порядок такой.

     

     

    stsadm -o addsolution -filename C:\ApplicationTemplateCore.wsp

     

    stsadm -o deploysolution -name ApplicationTemplateCore.wsp -allowgacdeployment -immediate

     

    stsadm.exe -o execadmsvcjobs

     

    stsadm -o copyappbincontent

     

    ---------------------------------------------------------

     

     

    stsadm -o addsolution -filename C:\HelpDesk.wsp

     

    stsadm -o deploysolution -name HelpDesk.wsp -allowgacdeployment -immediate

     

    stsadm.exe -o execadmsvcjobs

     

     

    Так заработает. Если непонятно, что для чего спрашивайте.

     

    26 ноября 2008 г. 10:38

Все ответы

  • Порядок такой.

     

     

    stsadm -o addsolution -filename C:\ApplicationTemplateCore.wsp

     

    stsadm -o deploysolution -name ApplicationTemplateCore.wsp -allowgacdeployment -immediate

     

    stsadm.exe -o execadmsvcjobs

     

    stsadm -o copyappbincontent

     

    ---------------------------------------------------------

     

     

    stsadm -o addsolution -filename C:\HelpDesk.wsp

     

    stsadm -o deploysolution -name HelpDesk.wsp -allowgacdeployment -immediate

     

    stsadm.exe -o execadmsvcjobs

     

     

    Так заработает. Если непонятно, что для чего спрашивайте.

     

    26 ноября 2008 г. 10:38
  • К сожалению, не помогло. Удалил и заново развернул решения, в итоге без изменений.
    Итог печальный - второй раз ставлю WSS на чистый сервер с нуля, и все равно какие-то глюки. Причем объяснить их никто не может, разве что "обновите железо" и "перезагрузите сервер".

    P.S. Если долго мучиться, что-нибудь получится. Я фигею, дорогая редакция. Похоже, что шаблон applicationtemplatecore выложенный на MS кривой. Заменил старой версией - вроде как заработало. Правда новые шаблоны при этом не ставятся.

    Ilya Rud - спасибо за помощь.
    26 ноября 2008 г. 11:04
  • Для одиночного сервера надо -immediate менять на -local
    и получиться так
    ---------
    stsadm -o addsolution -filename C:\ApplicationTemplateCore.wsp

    stsadm -o deploysolution -name ApplicationTemplateCore.wsp -allowgacdeployment -local

    stsadm.exe -o execadmsvcjobs 

    stsadm -o copyappbincontent
    --------------------


    23 декабря 2008 г. 6:58