none
IMAP - Server Unavailable. 15. RRS feed

  • Вопрос

  • Внезапно перестал работать IMAP. Почтовый клиент при подключении пишет "Server Unavailable. 15". Попробовал создать нового пользователя с новым ящиком - та-же проблема.

    Поехали telnet'ом:

    * OK The Microsoft Exchange IMAP4 service is ready.
    ? login test1 Qwert12345
    ? OK LOGIN completed.


    Авторизация, как видим, прошла успешно. Далее листинг:

    ? list "" "*"
    * LIST (\HasNoChildren) "/" RSS-&BDoEMAQ9BDAEOwRL-
    * LIST (\HasNoChildren) "/" Trash
    * LIST (\Marked \HasNoChildren) "/" INBOX
    * LIST (\HasNoChildren) "/" &BBQEPQQ1BDIEPQQ4BDo-
    * LIST (\HasNoChildren) "/" &BBcEMAQ0BDAERwQ4-
    * LIST (\HasNoChildren) "/" &BBcEMAQ8BDUEQgQ6BDg-
    * LIST (\HasNoChildren) "/" &BBgEQQRFBD4ENARPBEkEOAQ1-
    * LIST (\HasNoChildren) "/" &BBoEMAQ7BDUEPQQ0BDAEQARM-
    * LIST (\HasNoChildren) "/" &BBoEPgQ9BEIEMAQ6BEIESw-
    * LIST (\HasNoChildren) "/" "&BB0ENQQ2BDUEOwQwBEIENQQ7BEwEPQQwBE8- &BD8EPgRHBEIEMA-"
    * LIST (\HasNoChildren) "/" &BB4EQgQ,BEAEMAQyBDsENQQ9BD0ESwQ1-
    * LIST (\HasChildren) "/" "&BB4ESAQ4BDEEOgQ4- &BEEEOAQ9BEUEQAQ+BD0EOAQ3BDAERgQ4BDg-"
    * LIST (\HasNoChildren) "/" "&BB4ESAQ4BDEEOgQ4- &BEEEOAQ9BEUEQAQ+BD0EOAQ3BDAERgQ4BDg-/&BBoEPgQ9BEQEOwQ4BDoEQgRL-"
    * LIST (\HasNoChildren) "/" "&BB4ESAQ4BDEEOgQ4- &BEEEOAQ9BEUEQAQ+BD0EOAQ3BDAERgQ4BDg-/&BBsEPgQ6BDAEOwRMBD0ESwQ1- &BD4ESA
    Q4BDEEOgQ4-"
    * LIST (\HasNoChildren) "/" "&BB4ESAQ4BDEEOgQ4- &BEEEOAQ9BEUEQAQ+BD0EOAQ3BDAERgQ4BDg-/&BB4ESAQ4BDEEOgQ4- &BEEENQRABDIENQ
    RABDA-"
    * LIST (\HasNoChildren) "/" "&BB8EQAQ1BDQEOwQwBDMEMAQ1BDwESwQ1- &BDoEPgQ9BEIEMAQ6BEIESw-"
    * LIST (\HasNoChildren) "/" &BCMENAQwBDsENQQ9BD0ESwQ1-
    * LIST (\HasNoChildren) "/" &BCcENQRABD0EPgQyBDgEOgQ4-
    ? OK LIST completed.

    Вроде все ок, выбираем папку:

    ? select inbox
    * 1 EXISTS
    * 0 RECENT
    * FLAGS (\Seen \Answered \Flagged \Deleted \Draft $MDNSent)
    * OK [PERMANENTFLAGS (\Seen \Answered \Flagged \Deleted \Draft $MDNSent)] Permanent flags
    * OK [UNSEEN 1] Is the first unseen message
    * OK [UIDVALIDITY 3607] UIDVALIDITY value
    * OK [UIDNEXT 9] The next unique identifier value
    ? OK [READ-WRITE] SELECT completed.

    Смотрим первое сообщение:

    ? fetch 1 all
    ? NO Server Unavailable. 15

    Вот на этом этапе и ошибка. Поиски по сети показали что у большинства эта ошибка возникает еще на этапе авторизации, так что в чем проблема у меня - ума не приложу. В журнале событий связанных с этой проблемой ошибок нет. Может кто сталкивался?


    • Изменено AndreyResler 29 октября 2013 г. 7:29
    28 октября 2013 г. 12:29

Ответы

  • Все, проблема решена. Помог вот этот солюшн:

    http://blogs.technet.com/b/exchange/archive/2010/09/01/3410888.aspx

    пункт 7

    В кратце: самопроизвольно (то ли с обновлением. то ли что еще) поменялось имя домена по умолчанию (атрибут Name) с "contoso.com" на "Внешний домен SBS".

    Изменил обратно на правильное, перезагрузил сервер - IMAP и POP3 заработали.

    Очень хочется спросить программистов, зачем они так сделали.

    • Помечено в качестве ответа AndreyResler 29 октября 2013 г. 10:26
    29 октября 2013 г. 10:26

Все ответы

  • Добрый день!

    Читали http://support.microsoft.com/kb/980049 ?

    29 октября 2013 г. 7:39
  • Читал, но проблема в другом, т.к. OWA работает, и источник MSExchangeIS никаких ошибок не генерирует.

    На всякий случай увеличил кол-во сессий согласно статье - не помогло.

    А вот MS Exchnage Common выдает регулярно следующую ошибку:

    Будет отправлен отчет программы "Доктор Ватсон" для идентификатора процесса 11556 с параметрами E12, c-RTL-AMD64, 14.01.0218.015, M.Exchange.Imap4, M.E.Data.Storage, M.E.D.S.InboundConversionOptions.CheckImceaDomain, System.ArgumentException, 457e, 14.01.0218.012.
    ErrorReportingEnabled: False

    Но что за ошибка - внятно не объясняется

    • Изменено AndreyResler 29 октября 2013 г. 8:29
    29 октября 2013 г. 8:26
  • Много папок и писем у Вашего пользователя? Попробуйте создать тестового пользователя, и подключиться.

    29 октября 2013 г. 8:57
  • Создал пользователя, отправил ему одно письмо, и как раз с ним и проводил диагностику телнетом в первом посте. Т.е. папки только дефолтные, одно письмо в ящике, других подключений IMAP с моей рабочей станции к тому серверу нет.

    Более того, проверил POP3 - оказывается с ним та-же проблема, но ошибка уже "Server Unavailable. 21".

    Web Access при этом, повторюсь, работает

    29 октября 2013 г. 9:17
  • Продолжая разбор полетов, включил логирование imap, и вот такое исключение встречается в логах

    R=""8 NO Server Unavailable. 15"";RpcL=-1;LdapL=-1;Excpt=""imceaDomain must be a valid domain name.

    На домен ругается. Никаких настроек в Exchange перед возникновением проблемы не производилось, что может быть не так с доменами?

    29 октября 2013 г. 9:51
  • Все, проблема решена. Помог вот этот солюшн:

    http://blogs.technet.com/b/exchange/archive/2010/09/01/3410888.aspx

    пункт 7

    В кратце: самопроизвольно (то ли с обновлением. то ли что еще) поменялось имя домена по умолчанию (атрибут Name) с "contoso.com" на "Внешний домен SBS".

    Изменил обратно на правильное, перезагрузил сервер - IMAP и POP3 заработали.

    Очень хочется спросить программистов, зачем они так сделали.

    • Помечено в качестве ответа AndreyResler 29 октября 2013 г. 10:26
    29 октября 2013 г. 10:26