none
Подключение Outlook к Exchange внутренних клиентов RRS feed

  • Общие обсуждения

  • Добрый день, подскажите как решить проблему с Autodiscover, клиент Outlook во внутренней сети получает вот такие настройки (extdom):

    Хотелось бы чтобы он получал такие (intdom):

    Если изменить настройки вручную, после перезапуска Outlook они возвращаются обратно. Вариант отключения на клиенте автонастроек тоже пойдет.

    11 марта 2016 г. 4:22

Все ответы

  • Set-OutlookProvider EXPR –certprincipalname msstd:exchange.intdom.ru

     

    Do not multiply entities beyond what is necessary

    11 марта 2016 г. 4:34
  • Клиент в домене? Нужно чтобы он по scp получал информацию о подключении. Через командлет настраивается на каждом сервере Set-ClientAccessServer -Identity "MBX-01" -AutoDiscoverServiceInternalUri "https://internalname/autodiscover/autodiscover.xml" -AutoDiscoverSiteScope "Mail" Для отключения на клиенте нужно реестр править, как тут написано: http://blogs.technet.com/b/mspfe/archive/2013/05/01/so-you-want-to-block-exchange-2010-autodiscover-why-would-anyone-do-that.aspx

    scientia potentia est
    My blog

    11 марта 2016 г. 4:36
  • [PS] C:\Windows\system32>get-OutlookProvider

    Name                          Server                        CertPrincipalName             TTL
    ----                          ------                        -----------------             ---
    EXCH                          exchange.intdom.ru           msstd:exchange.intdom.ru         1
    EXPR                          exchange.extdom.ru           msstd:exchange.extdom.ru         1
    WEB                                                                                         1

    Внешние клиенты не отвалятся? Если я здесь изменю?

    11 марта 2016 г. 4:41
  • поменяйте местами exch и expr

    И метод аутентификации для внутренних клиентов лучше бы NTLM


    Do not multiply entities beyond what is necessary


    • Изменено Dmitry.I 11 марта 2016 г. 4:42
    11 марта 2016 г. 4:42
  • Клиент в домене, да. Set-ClientAccessServer сделал не помогло.

    Реестр поправил, перезагрузился, автоопределение работает, клиент outlook 2013, win 8.1

    проливал так:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"

    Изначально такой ветки реестра даже небыло...

    11 марта 2016 г. 5:07
  • Зато была такая:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover]
    "ExcludeSCPLookup"="1"
    "ExcludeHttpRedirect"="1"
    "ExcludeHttpsAutodiscoverDomain"="1"
    "ExcludeHttpsRootDomain"="1"
    "ExcludeSrvRecord"="1"

    Но тоже не помогло, продолжает автоопределятся

    11 марта 2016 г. 5:17
  • Аутентификация у меня базовая ее менять не станем.

    Поменял записи, сервак перезагрузил.

    Смотрю автоконфигуратор:

    Протокол: Exchange HTTP

    Сервер: exchange.extdom.ru 

    ...

    Не помогло

    Если открыть состояние подключения Outlook, там видно что клиент ломится на прокси сервер exchange.extdom.ru хотя он во внутренней сети и должен идти на exchange.intdom.ru
    11 марта 2016 г. 5:25
  • Пропишите InternalURL правильный для web-служб.

    Сазонов Илья

    https://isazonov.wordpress.com/

    11 марта 2016 г. 5:30
    Модератор
  • Если речь о данных вкладках, то здесь везде все прописано.

    11 марта 2016 г. 5:35
  • И что у вас прописано в InternalURL ?

    Сазонов Илья

    https://isazonov.wordpress.com/

    11 марта 2016 г. 6:06
    Модератор
  • https://exchange.intdom.ru/owa

    https://exchange.intdom.ru/ecp

    https://exchange.intdom.ru/microsoft-server-active-sync

    http://exchange.intdom.ru/OAB

    11 марта 2016 г. 6:08
  • [PS] C:\Windows\system32>get-OutlookProvider

    Name                          Server                        CertPrincipalName             TTL
    ----                          ------                        -----------------             ---
    EXCH                          exchange.intdom.ru           msstd:exchange.intdom.ru         1
    EXPR                          exchange.extdom.ru           msstd:exchange.extdom.ru         1
    WEB                                                                                         1

    Внешние клиенты не отвалятся? Если я здесь изменю?

    Зачем вы это вообще прописывали?

    Очень редко когда тут нужно что-то прописывать. Попробуйте в $Null выставить значения.


    Сазонов Илья

    https://isazonov.wordpress.com/

    11 марта 2016 г. 6:24
    Модератор
  • [PS] C:\Windows\system32>Set-OutlookProvider EXPR -certprincipalname $Null
    [PS] C:\Windows\system32>Set-OutlookProvider EXCH -certprincipalname $Null
    [PS] C:\Windows\system32>get-OutlookProvider

    Name                          Server                        CertPrincipalName             TTL
    ----                          ------                        -----------------             ---
    EXCH                          exchange.intdom.ru                                             1
    EXPR                          exchange.extdom.ru                                         1
    WEB                                                                                       1

    [PS] C:\Windows\system32>Set-OutlookProvider EXPR -Server $null
    [PS] C:\Windows\system32>Set-OutlookProvider EXCH -Server $null
    [PS] C:\Windows\system32>get-OutlookProvider

    Name                          Server                        CertPrincipalName             TTL
    ----                          ------                        -----------------             ---
    EXCH                                                                                      1
    EXPR                                                                                      1
    WEB                                                                                       1

    Я все правильно понял?

    11 марта 2016 г. 6:31
  • Даже если и так, все равно без изменений
    11 марта 2016 г. 6:40
  • Вообщем решил вопрос настроив GPO для Outlook, и явно вписав туда RPC Proxy Server Name
    11 марта 2016 г. 6:57
  • В Outlook проверку Autodiscover сделайте и покажите какой там вывод

    Сазонов Илья

    https://isazonov.wordpress.com/

    11 марта 2016 г. 7:23
    Модератор
  • <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
          <DisplayName>Гашков Сергей Викторович</DisplayName>
          <LegacyDN>/o=intdom/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=userd2bb84f0</LegacyDN>
          <AutoDiscoverSMTPAddress>fR0dA@extdom.ru</AutoDiscoverSMTPAddress>
          <DeploymentId>070c95d2-58ee-4812-9949-e522502c00a2</DeploymentId>
        </User>
        <Account>
          <AccountType>email</AccountType>
          <Action>settings</Action>
          <Protocol>
            <Type>EXCH</Type>
            <Server>EXCHANGE.intdom.RU</Server>
            <ServerDN>/o=intdom/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EXCHANGE</ServerDN>
            <ServerVersion>7383807B</ServerVersion>
            <MdbDN>/o=intdom/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EXCHANGE/cn=Microsoft Private MDB</MdbDN>
            <AD>intdom-SECOND.intdom.RU</AD>
            <ASUrl>https://exchange.intdom.ru/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://exchange.intdom.ru/EWS/Exchange.asmx</EwsUrl>
            <EcpUrl>https://exchange.intdom.ru/ecp/</EcpUrl>
            <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>
            <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>
            <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>
            <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>
            <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>
            <OOFUrl>https://exchange.intdom.ru/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://exchange.intdom.ru/EWS/UM2007Legacy.asmx</UMUrl>
            <ServerExclusiveConnect>off</ServerExclusiveConnect>
          </Protocol>
          <Protocol>
            <Type>EXPR</Type>
            <Server>exchange.extdom.ru</Server>
            <SSL>On</SSL>
            <AuthPackage>Basic</AuthPackage>
            <ASUrl>https://exchange.extdom.ru/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://exchange.extdom.ru/EWS/Exchange.asmx</EwsUrl>
            <EcpUrl>https://exchange.extdom.ru/ecp/</EcpUrl>
            <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>
            <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>
            <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>
            <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>
            <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>
            <OOFUrl>https://exchange.extdom.ru/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://exchange.extdom.ru/EWS/UM2007Legacy.asmx</UMUrl>
            <ServerExclusiveConnect>on</ServerExclusiveConnect>
          </Protocol>
          <Protocol>
            <Type>WEB</Type>
            <Internal>
              <OWAUrl AuthenticationMethod="Basic">https://exchange.intdom.ru/owa/</OWAUrl>
              <Protocol>
                <Type>EXCH</Type>
                <ASUrl>https://exchange.intdom.ru/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </Internal>
            <External>
              <OWAUrl AuthenticationMethod="Fba">https://exchange.extdom.ru/owa/</OWAUrl>
              <Protocol>
                <Type>EXPR</Type>
                <ASUrl>https://exchange.extdom.ru/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </External>
          </Protocol>
        </Account>
      </Response>
    </Autodiscover>
    11 марта 2016 г. 7:35
  • И проверьте теперь, что у вас выдает Get-OutlookAnyware для ExternalHostName и InternalHostName

    Сазонов Илья

    https://isazonov.wordpress.com/

    11 марта 2016 г. 8:18
    Модератор
  • [PS] C:\Windows\system32>Get-OutlookAnywhere -Server EXCHANGE


    RunspaceId                      : 4f005d8b-8eae-4d6c-b2c7-1aef404863e9
    ServerName                      : EXCHANGE
    SSLOffloading                   : False
    ExternalHostname                : exchange.extdom.ru
    ClientAuthenticationMethod      : Basic
    IISAuthenticationMethods        : {Basic}
    XropUrl                         :
    MetabasePath                    : IIS://EXCHANGE.intdom.RU/W3SVC/1/ROOT/Rpc
    Path                            : C:\Windows\System32\RpcProxy
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : EXCHANGE
    AdminDisplayName                :
    ExchangeVersion                 : 0.10 (14.0.100.0)
    Name                            : Rpc (Default Web Site)
    DistinguishedName               : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=EXCHANGE,CN=Servers,CN=Exchange Adm
                                      inistrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=MGO,CN=Microsoft Exch
                                      ange,CN=Services,CN=Configuration,DC=intdom,DC=RU
    Identity                        : EXCHANGE\Rpc (Default Web Site)
    Guid                            : b0e75df1-7d8c-4461-a382-6bca6e8e0500
    ObjectCategory                  : intdom.RU/Configuration/Schema/ms-Exch-Rpc-Http-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchRpcHttpVirtualDirectory}
    WhenChanged                     : 01.03.2016 11:36:27
    WhenCreated                     : 01.03.2016 11:36:25
    WhenChangedUTC                  : 01.03.2016 6:36:27
    WhenCreatedUTC                  : 01.03.2016 6:36:25
    OrganizationId                  :
    OriginatingServer               : intdom-FIRST.intdom.RU
    IsValid                         : True

    Что-то я не вижу тут InternalHostName...

    11 марта 2016 г. 8:56
  • InternalHostName нет в этой версии, только старших.

    В принципе у вас все настроено правильно.

    Что вас смущает или что у вас не работает?


    Сазонов Илья

    https://isazonov.wordpress.com/

    11 марта 2016 г. 12:21
    Модератор
  • несколько клиентов которые географически удалены, подключены по VPLAN, через "полосатого провайдера", все работало без проблем, до недавнего времени, вероятно они что-то изменили в своих сетях. Работать перестало. Искать отказываются, типа не у них.

    Ну и выяснили, что если указать intdom вместо extdom в настройке самого Outlook, работает, до перезапуска программы, Autodiscover обратно прописывает extdom (см. первые два скриншота).

    11 марта 2016 г. 13:35
  • Собственно на данный момент я этим клиентам через GPO указал intdom. Работает. Ну если все правильно на самом сервере, это хорошо.
    11 марта 2016 г. 13:37
  • И без GPO должны клиенты нормально подключаться и внутри, и снаружи.

    Скорее всего отвалились подключения по RPC. Вы просто пытаетесь переключить клиентов на OutlookAnyware с RPC. Более правильно (рекомендованный способ) это использовать Split DNS и одинаковые имена для внутренних и внешних подключений. Это конечно не вылечит сеть, но работать будет стабильнее и удобнее для пользователей и администраторов.


    Сазонов Илья

    https://isazonov.wordpress.com/




    11 марта 2016 г. 13:39
    Модератор
  • Ну собственно все так и есть... Не понимаю почему клиенты за VPLAN не могут подключится по внешнему имени, у них в настройках сети стоят внутренние DNS сервера, внешняя зона прописана на них. Разрешение имен ходит нормально. Но коннект по внешнему адресу на exchange не идёт...
    11 марта 2016 г. 13:59
  • С клиента проверить, что URL OutlookAnyware доступен.

    Сазонов Илья

    https://isazonov.wordpress.com/

    11 марта 2016 г. 14:21
    Модератор