none
Ошибка при развертывании Windows 8 x86 RRS feed

  • Вопрос

  • Пытаюсь развернуть Windows 8 x86 на Hyper-V, SCCM 2012 R2, Server 2012.
    Загрузка происходит с образа x64, потом применяется образ операционной системы Windows 8 x86.
    После операции применения выскакивает ошибка 0×80070032. 

    Помогите решить проблему!!!

    Заранее Спасибо!

    30 июня 2014 г. 6:52

Ответы

  • смотрите теперь какая ситуация, gen2 в hyper-v поддерживает только windows 8 x64.

    поэтому, когда добавляете x86 образ он не может загрузиться, т.к. в gen2 используется UEFI, а он требует загрузчика х64.

    Либо используйте gen1 с BIOS и boot image x86, либо оставляйте gen2, но тогда надо образ windows 8 заменить на x64.

    зыж начали за установку системы, закончили hyper-v )

    30 июня 2014 г. 9:47
    Модератор

Все ответы

  • российская ассоциация телепатов намекает, что проблема будет ясна, если вы приложите smsts.log )
    30 июня 2014 г. 7:03
    Модератор
  • Простите забыл его приложить )))

    LOGGING: Finalize process ID set to 660 TSBootShell 30.06.2014 13:05:44 664 (0x0298)
    ==============================[ TSBootShell.exe ]============================== TSBootShell 30.06.2014 13:05:44 664 (0x0298)
    Succeeded loading resource DLL 'X:\sms\bin\x64\1033\TSRES.DLL' TSBootShell 30.06.2014 13:05:44 664 (0x0298)
    Debug shell is enabled TSBootShell 30.06.2014 13:05:44 664 (0x0298)
    Waiting for PNP initialization... TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    RAM Disk Boot Path: NET(0)\SMSIMAGES\CMD0000A\BOOT.CMD0000A.WIM TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    Booted from network (PXE) TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    Network(PXE) path: X:\sms\data\ TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    Found config path X:\sms\data\ TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    Booting from removable media, not restoring bootloaders on hard drive TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    X:\sms\data\WinPE does not exist. TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    X:\_SmsTsWinPE\WinPE does not exist. TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    Executing command line: wpeinit.exe -winpe TSBootShell 30.06.2014 13:05:44 676 (0x02A4)
    The command completed successfully. TSBootShell 30.06.2014 13:05:46 676 (0x02A4)
    Starting DNS client service. TSBootShell 30.06.2014 13:05:46 676 (0x02A4)
    Executing command line: X:\sms\bin\x64\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\ TSBootShell 30.06.2014 13:05:47 676 (0x02A4)
    The command completed successfully. TSBootShell 30.06.2014 13:05:47 676 (0x02A4)
    ==============================[ TSMBootStrap.exe ]============================== TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    Command line: X:\sms\bin\x64\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\ TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    Succeeded loading resource DLL 'X:\sms\bin\x64\1033\TSRES.DLL' TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    Succeeded loading resource DLL 'X:\sms\bin\x64\TSRESNLC.DLL' TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    Current OS version is 6.2.9200.0 TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    Adding SMS bin folder "X:\sms\bin\x64" to the system environment PATH TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    PXE Boot with Root = X:\ TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    Executing from PXE in WinPE TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    Loading TsPxe.dll from X:\sms\bin\x64\TsPxe.dll TSMBootstrap 30.06.2014 13:05:47 744 (0x02E8)
    TsPxe.dll loaded TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Device has PXE booted TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Variable Path: \SMSTemp\2014.06.30.13.05.15.0008.{AC7EC471-A797-4705-8AE7-6875C2A31853}.boot.var TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Succesfully added firewall rule for Tftp TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Executing: X:\sms\bin\x64\smstftp.exe -i 10.0.12.2 get \SMSTemp\2014.06.30.13.05.15.0008.{AC7EC471-A797-4705-8AE7-6875C2A31853}.boot.var X:\sms\data\variables.dat TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Command line for extension .exe is "%1" %* TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Set command line: "X:\sms\bin\x64\smstftp.exe" -i 10.0.12.2 get \SMSTemp\2014.06.30.13.05.15.0008.{AC7EC471-A797-4705-8AE7-6875C2A31853}.boot.var X:\sms\data\variables.dat TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Executing command line: "X:\sms\bin\x64\smstftp.exe" -i 10.0.12.2 get \SMSTemp\2014.06.30.13.05.15.0008.{AC7EC471-A797-4705-8AE7-6875C2A31853}.boot.var X:\sms\data\variables.dat TSPxe 30.06.2014 13:05:47 744 (0x02E8)
    Process completed with exit code 0 TSPxe 30.06.2014 13:05:48 744 (0x02E8)
    Succesfully removed firewall rule for Tftp TSPxe 30.06.2014 13:05:48 744 (0x02E8)
    Successfully downloaded pxe variable file. TSPxe 30.06.2014 13:05:48 744 (0x02E8)
    we are booted using PXE TSPxe 30.06.2014 13:05:48 744 (0x02E8)
    we are booted using PXE and we don't use a password or the password is provided by the user TSPxe 30.06.2014 13:05:48 744 (0x02E8)
    Found network adapter "Microsoft Hyper-V Network Adapter" with IP Address 10.0.12.8. TSPxe 30.06.2014 13:05:48 744 (0x02E8)

    30 июня 2014 г. 7:19
  • это только часть лога загрузки winpe по tftp и все ок.

    ошибки 80070032 тут нет. найдете полный лог, выложите на onedrive или любой другой облачный сервис.

    30 июня 2014 г. 7:34
    Модератор
  • Вот ссылка на smsts.log

    http://owncloud.prognoz.ru/public.php?service=files&t=22d8e9b7a0fc1fc77311c8c1acc71121

    30 июня 2014 г. 7:58
  • вы явно, что-то не договариваете. )

    давайте так, запустите ваш TS, дойдите до появления ошибки, нажмите f8, появится командная строка, скопируйте ваш smsts.log и выложите.

    подсказки.

    в командной строке можно выполнить cmtrace32 и посмотреть ваш smsts.log

    Если судить по последнему логу, то он должен быть тут: 

    Set a global environment variable _SMSTSLogPath=X:\WINDOWS\TEMP\SMSTSLog

    подключить сетевую шару:

    net use M: \\SCCMSERVERNAME\C$

    копируем в подключенную шару:

    copy c:\bla_bla_bla\smstslog.log M:

    30 июня 2014 г. 8:10
    Модератор
  • Вот ещё один лог 

    http://owncloud.prognoz.ru/public.php?service=files&t=d83ba4ccb09491ec1ac4f197926f6fb7

    а предыдущий лог был x:\SMSTSLog\smsts.log

    30 июня 2014 г. 8:26
  • вот в этом логе все написано:

    It is not supported to deploy an x86 architecture OS from a amd64 boot image
    Installation of image 1 in package CMD00006 failed to complete.. The request is not supported. (Error: 80070032; Source: Windows) ApplyOperatingSystem

    Deploying a 32-bit operating system from x64 Windows PE is not supported

    CMD00006 - это ваша windows 8 x86, а установка происходит из загрузочного образа winpe x64. В свойствах тасксиквенса выберите загрузочный образ winpe x86.


    30 июня 2014 г. 8:36
    Модератор
  • вот вам табличка для понимания:


    30 июня 2014 г. 8:41
    Модератор
  • а вот при выборе x64, выдает вот такую ошибку

    30 июня 2014 г. 8:56
  • не понял? причем здесь х64, он же у вас был раньше выбран. Может быть х86? Вы доставили образ boot image (x86) на точку распространения?
    30 июня 2014 г. 9:07
    Модератор
  • Ой ошибся, при выборе x86, выдает вот такую ошибку, image boot находится на точке.


    • Изменено yuranpv 30 июня 2014 г. 9:11
    30 июня 2014 г. 9:09
  • в hyper-v виртуальная машина случайно не gen2?
    30 июня 2014 г. 9:24
    Модератор
  • Да gen 2.

    • Изменено yuranpv 30 июня 2014 г. 9:40
    30 июня 2014 г. 9:34
  • смотрите теперь какая ситуация, gen2 в hyper-v поддерживает только windows 8 x64.

    поэтому, когда добавляете x86 образ он не может загрузиться, т.к. в gen2 используется UEFI, а он требует загрузчика х64.

    Либо используйте gen1 с BIOS и boot image x86, либо оставляйте gen2, но тогда надо образ windows 8 заменить на x64.

    зыж начали за установку системы, закончили hyper-v )

    30 июня 2014 г. 9:47
    Модератор
  • Вот ведь как бывает, пошел пробовать.

    Антон, Спасибо Вам большое!!!


    30 июня 2014 г. 9:50
  • пожалуйста, пишите по результатам.

    наглядно выглядит так:

    если gen2 = только win pe x64 и только windows 8 x64

    если gen1 = win pe x86 и windows 8 x86 (все остальные версии согласно табличке выше)


    30 июня 2014 г. 9:53
    Модератор
  • Антон, отписываюсь по результату, все прошло после изменения сетевых настроек.

    Спасибо.


    • Изменено yuranpv 1 июля 2014 г. 13:37
    1 июля 2014 г. 13:36
  • Данная проблема больше связана не с самим ConfigMgr, это ограничения UEFI. С разработчиками достаточно долго идёт обсуждение по данной проблеме.


    Vladimir Zelenov | http://systemcenter4all.wordpress.com

    Отвечающий