locked
WSUS problem with error 0x8024401c RRS feed

  • Вопрос

  • Good day!

    We have windows standard 2016 with WSUS server installed (all updated installed) + Windows 10 LTSB OS client (one from ISO image, one deployed with SCCM with some updates preinstalled). When we are trying to check updates from the OS we get an error 0x8024401c...

    All other clients work ok, this affected only for new clients... this started on the old WSUS server (Windows 2012 R2) and we decided to install Win Server 2016 with new WSUS server and redirect all clients to the new server, but the problem still exists...

    When the client with problem check updates I see high CPU load (up to 100%) on the WSUS server w3wp.exe process.

    Any help please!

    11 июля 2017 г. 7:24

Все ответы

  • Could be due to a bad master image (image setup to check WSUS, and never cleaning it up before sysprep). sysprep does not get rid of the SusClientId of the machine.

    Run this script on one of the affected clients, and see if that fixes your issue.

    net stop bits
    net stop wuauserv
    reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f
    reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f
    reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f
    reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientIDValidation /f
    rd /s /q "%WinDir%\SoftwareDistribution"
    net start bits
    net start wuauserv
    wuauclt /resetauthorization /detectnow



    Adam Marshall, MCSE: Security
    http://www.adamj.org

    12 июля 2017 г. 3:18
  • Been searching for a solution for a while now, kept finding things like increase wsus app pool queu, increase virtual memory for the pool etc etc, nothing worked.

    Our sccm server with wsus kept getting high cpu load after new deployments (but not all the time).
    I wasn't able to figure out what went wrong and the only solution was to reimage and then most of the time the issue went away (no clue why).

    We finally decided to stop using the update agent from SCCM thinking this was the cause.

    Installed a new WSUS server and to our suprise it also got hit with 100CPU load...
    This shifted my search from SCCM issues to Windows 10 client issues and i found this post.
    I ran the script and for the first time i was able to fix a client without a complete re-image.

    I went on to check some of the deployed machines where i blocked wsus until i figured it out and they all have the same SusClientID and Validation.  I have no clue why a reinstall of the same image worked before as it contained that same ID. But i am hopefull that removing these keys wil fix the probleem for all our deployments. (i will see if i can remove the key during the deployment task sequence).

    I will test it further..thank you for your question, and thank you for the suggested solution.





    • Изменено Ray2401 13 июля 2017 г. 19:55
    13 июля 2017 г. 19:50
  • Glad it worked for you. Can I make your life even better?

    Have a peek at my Adamj Clean-WSUS script. It is the last WSUS Script you will ever need.

    http://community.spiceworks.com/scripts/show/2998-adamj-clean-wsus

    What it does:

    1. Remove all Drivers from the WSUS Database.
    2. Shrink your WSUSContent folder's size by declining superseded updates.
    3. Remove declined updates from the WSUS Database.
    4. Clean out all the synchronization logs that have built up over time (configurable, with the default keeping the last 14 days of logs).
    5. Compress Update Revisions.
    6. Remove Obsolete Updates.
    7. Computer Object Cleanup (configurable, with the default of deleting computer objects that have not synced within 30 days).
    8. Application Pool Memory Configuration to display the current private memory limit and easily increase it by any configurable amount.
    9. Run the Recommended SQL database Maintenance script on the actual SQL database.
    10. Run the Server Cleanup Wizard.

    It will email the report out to you or save it to a file, or both.

    Although the script is lengthy, it has been made to be super easy to setup and use. There are some prerequisites and instructions at the top of the script. After installing the prerequisites and configuring the variables for your environment, simply run:

    .\Clean-WSUS.ps1 -FirstRun

    and then

    .\Clean-WSUS.ps1 -InstallTask

    If you wish to view or increase the Application Pool Memory Configuration, you must run it with the required switch. See Get-Help .\Clean-WSUS.ps1 -Examples

    If you're having trouble, there's also a -HelpMe option that will create a log so you can send it to me for support.


    Adam Marshall, MCSE: Security
    http://www.adamj.org

    • Предложено в качестве ответа Elton_Ji 13 августа 2017 г. 15:05
    13 июля 2017 г. 19:54
  • Adamj.org -- Fine! I ran your clean-up scripts that I have been putting off trying. And, it indeed fixed the problem!  Thanks you much!!!!
    • Предложено в качестве ответа AJTek.caMVP 12 сентября 2017 г. 19:17
    12 сентября 2017 г. 19:14
  • You're welcome!!!

    Welcome to WSUS Freedom!


    Adam Marshall, MCSE: Security
    http://www.adamj.org

    12 сентября 2017 г. 19:16
  • hola les comento solucione el problema de la siguiente manera en el pool de WSUS modifique lo siguiente. lo probé en 3 wsus windows server 2016 y se soluciono en todos.

    GENERAL

    Start Mode: AlwaysRunning

    CPU

    Limit (percent): 60

    Rapid-Fail Protection

    "service unavailable": TCPLevel

    Failure interval (minutes):30

    Maximum Failures: 120

    Process Model

    Maximum worker Processes: 0

    Recycling

    Private Memory Limit (KB): 6000000

    suerte.

    • Предложено в качестве ответа Aedoz 29 октября 2018 г. 21:30
    29 октября 2018 г. 21:29