none
Не удается выполнить поиск, так как служба поиска недоступна RRS feed

  • Вопрос

  • Создано два семейства сайтов. Один для портала. Другой – узел личных сайтов.

    Также добавлена служба поиска. Служба поиска настроена и был сделан обход контента.

    На личном сайте поиск заработал. Хотя в Crawl log после полного обхода контента и выходит ошибка:

    http://mysite.dom.local:8080/tagprofile.aspx

    SharePoint returned an empty response. ( SearchID = 71D68DEB-F06C-4139-98A7-9186C22D989D )

     

    А на сайте портала, созданного по шаблону ‘сайт группы’ и на подсайте в этом семействе сайтов поиск не работает. Выходит строка:

    Не удается выполнить поиск, так как служба поиска недоступна. Для получения дополнительных сведений обратитесь к администратору.

    Никакого CorrelationID не показывает. Только вышенаписанная строка.

    Еще заметил, что значение по умолчанию ‘Искать на этом сайте…’ в поле, где вводится строка для поиска не удаляется, если поставить в это поле курсор и сама эта строка отображается черным цветом. Хотя на личном сайте значение по умолчанию ‘Поиск на этом сайте…’ в этом поле очищается и отображается серым цветом.

    Пробовал переустанавливать службу поиска. Не помогает.

    Команда Get-SPEnterpriseSearchStatus выдает, что все компоненты в состоянии Active

    IndexComponent1                                 Active

    Cell:IndexComponent1-SP5e3df030187dI.0.0        Active

    Partition:0                                     Active

    AdminComponent1                                 Active

    QueryProcessingComponent1                       Active

    ContentProcessingComponent1                     Active

    AnalyticsProcessingComponent1                   Active

    CrawlComponent0                                 Active

    Тоже самое (создание семейства сайтов для портала и личных сайтов и службы поиска) было сделано на тестовых серверах. Там все заработало.

    Как определить доступность службы поиска и из-за чего она может быть недоступна?


    • Изменено moskalenkoeu 11 апреля 2016 г. 10:23
    11 апреля 2016 г. 8:40

Ответы

Все ответы

  • Добрый день

    скажите, а служба поиска связана с веб-приложением где находится сайт?

    В ЦА /_admin/ApplicationAssociations.aspx


    мой блог Немного о SharePoint

    11 апреля 2016 г. 9:03
    Модератор
  • похоже на то...

    мой блог Немного о SharePoint

    11 апреля 2016 г. 9:15
    Модератор
  • я бы предложил создать еще один сайт в том же веб-приложении что и проблемный сайт и посмотреть поведение службы поиска.

    мой блог Немного о SharePoint

    11 апреля 2016 г. 9:18
    Модератор
  • Сделал новое семейство сайтов и соответственно сайт http://portal.dom.local/sites/copy в том же приложении. Ситуация аналогичная по поиску - Не удается выполнить поиск, так как служба поиска недоступна. Для получения дополнительных сведений обратитесь к администратору..

    В логах после обхода есть предупреждения по проблемным сайтам:

    http://portal.dom.local/sites/Copy/Style Library/Forms/AllItems.aspxUse

    This item and all items under it will not be crawled because the owner has set the NoCrawl flag to prevent it from being searchable ( SearchID = 564CE04F-0577-4CA1-9158-7F6E2F1A9E98 )

    http://portal.dom.local/Style Library/Forms/AllItems.aspxUse

    Item not crawled due to one of the following reasons: Preventive crawl rule; Specified content source hops/depth exceeded; URL has query string parameter; Required protocol handler not found; Preventive robots directive. ( This item was deleted because it was excluded by a crawl rule. )



    • Изменено moskalenkoeu 11 апреля 2016 г. 10:29
    11 апреля 2016 г. 10:03
  • идей мало.

    можно еще попробовать создать новое веб-приложение и проверить там.

    если все гуд, то пере подключить базы к новому веб-приложению и поменять адрес в AAM, а старое веб-приложение удалить.


    мой блог Немного о SharePoint

    11 апреля 2016 г. 10:46
    Модератор
  • Удалил приложение (они все равно еще практически ничем не заполнено) и создал новое. И там поиск заработал.

    И также значение по умолчанию ‘Искать на этом сайте…’ в поле, где вводится строка для поиска стало теперь 'Поиск на этом сайте...' и удаляется, если поставить в это поле курсор и сама эта строка отображается серым цветом, а не черным.

    Видимо, раньше что-то криво встало. Либо это приложение либо служба поиска

    Большое Спасибо за помощь!

    11 апреля 2016 г. 11:56