none
Виртуальный адаптер Fibre Channel RRS feed

  • Вопрос

  • Добрый день.

    На хосте Windows Server 2012 в Hyper-V создана ВМ с Windows Server 2008R2. На хосте с Windows Server 2012 есть Fibre Channel адаптер подключенный в SAN switch. Созданной ВМ добавлен виртуальный адаптер Fibre Channel.

    Так же есть лента HP MSL2024 подключенная по Fibre Channel к SAN switch(К нему подключен хост Windows Server 2012 с Hyper-V). 

    При первом запуске ВМ с вирутальным Fibre Channel адаптером, ВМ видит ленту, ОС устанавливает драйвера на ленту и все ОК. Но после перезагрузки лента пропадает, и ее больше не видно. Если на ВМ удалить виртуальный Fibre Channel адаптер загрузиться без него, выключить ВМ, опять добавить виртуальный Fibre Channel адаптер, загрузиться с ним. ВМ опять видит ленту, устанавливает драйвер, но после перезагрузки лента опять пропадает.

    27 ноября 2013 г. 6:54

Все ответы

  • В процессе зонирования указаны оба WWPN для виртуальной машины? Драйвер поддерживает Windows Server 2012?

    27 ноября 2013 г. 7:26
    Модератор
  • Расскажите пожалуйста поподробнее о зонировании. 

    При добавлении виртуального адаптера указывается два WWN. 

    Имеется ввиду драйвер, который устанавливается в ВМ?

    27 ноября 2013 г. 7:50
  • У виртуального адаптера два WWPN, использующиеся для живой миграции — при переносе на другой узел становится активный второй идентификатор, при помощи MPIO процессе переключения на него происходит прозрачно. Важно в процессе зонирования указывать оба номера портов.

    Возможно, при рестарте у Вас на фабрике появляется второй, до этого неактивный WWPN.

    27 ноября 2013 г. 8:30
    Модератор
  • Смотрю на коммутаторе SAN:

    Когда добавляю адаптер и запускаю ВМ на коммутаторе видно только один WWPN(Address set A). Лента видна. Перезагружаю ВМ - на коммутаторе виден все тот же один WWPN(Address set A), но после перезагрузки лента не видна.

    Так же было замечено что когда с СХД презентовать LUN, все нормально. Но после перезагрузки ВМ LUN пропадает. Если этот LUN на СХД заново презентовать этой ВМ, то он появляется. 

    27 ноября 2013 г. 9:26
  • Как настраивали Virtual FibreChennel SAN Switch и Virtual FibreChannel? Скриншоты приложите.
    29 ноября 2013 г. 4:34
  • У Вас две vSAN? Следовательно, у Вас есть четыре WWPN. Они тоже все указаны в зонировании? Все-таки склонен к тому, что неверно настроено зонирование.

    29 ноября 2013 г. 6:58
    Модератор
  • Изначально была одна vSAN. Я тестировал на одной. Вчера добавил второй.

    У нас имеется два SAN коммутатора. Соответственно один порт FC подключен к одному коммутатору, второй FC к другому коммутатору. 

    Изначально не было настроено зонирования. Вчера сделал две зоны на обоих SAN коммутаторах. В одной зоне WWPN виртуального сервера и WWPN ленты, в другой зоне все остальное.

    SAN коммутаторы видят только один WWPN виртуального сервера, тот который Address Set A.


    • Изменено avedeshin 29 ноября 2013 г. 7:58
    29 ноября 2013 г. 7:54
  • Зоны в ZoneConfig включили?

    Я бы предложил вам в Brocade настроить сначала Alias'ы для WWPN хостов, ВМ и СХД. После чего настройка зонирования становится вполне удобным и тривиальным процессом. Вам нужно настроить соответственно Зоны Хост-СХД и ВМ-СХД. После чего включить эти зоны в конфиг.

    Собственно совсем недавно настраивал SAN на HP c3000 с 4 х BL460c G7 и HP EVA P6300. Судя по контроллерам у вас такая же или P6350.

    29 ноября 2013 г. 9:03
  • Подсказку про алиасы спасибо.

    Ранее делал как вы и сказали. Создал две зоны. Одна для ВМ и Ленты, другая для остальных. Создал новый ZoneConfig и добавил туда две созданные ранее зоны. Проверил что один из физических хостов перестал видить ленту (данный хост добавил в другую по отношению к ленте зону). 

    После настройки зонирования на SAN коммутаторах, заново добавил vFC на ВМ - лента появилась, после перезагрузки - опять лента пропадает.

    29 ноября 2013 г. 10:38
  • Попробуйте так.

    Создайте Альяс для всей vFC c0:03:ff:00:00:ff:ff:00 и сделайте зону с ним и SAN на обоих коммутаторах и не забудьте зоны добавить в конфиг зон.

    29 ноября 2013 г. 12:58
  • Результат тот же, после ребута лента пропадает.
    29 ноября 2013 г. 18:32
  • В библиотеке TechNet по этому поводу появилась очень занимательное примечание:
    Tape libraries are not supported on virtual machines configured with a Virtual Fibre Channel adapter.

    11 июня 2014 г. 8:39
    Модератор