none
Проблемы с настройками DAG Network Groups RRS feed

  • Вопрос

  • Коллеги, добрый день.

    Разбираюсь с сетевой связностью DAG на два сервера.
    Не получается вообще изменить существующие настройки Dag Networks (там две подсети сделано для mapi и replication)

    На 2 серверах интерфейсы настроены согласно инструкции https://theucguy.net/network-adapter-configurations-for-dag/

    для mapi:
    указаны днс сервер, шлюз, галка регистрации в днс, галка ipv6 отключена,

    для repl: 
    указаны только IP и маска, регистрация в днс отключена, галка ipv6 отключена

    для включен ms failover cluster virtual adapter, оба сервера виртуальные, на VMWare

    get-databaseavailabilitygroupnetwork выдает подсети как misconfigured, и НИ одного интерфейса вообще

    Причем подсеть для репликации определяет как ipv6, хотя это отключено на адаптерах


    Все статьи про включение ручных настроек и т.д. читал, не работает.

    Может к правам organization management нужно еще domain admins права?


    Вывод команды:

    get-databaseavailabilitygroupnetwork | fl

    RunspaceId : bf88015a-5f70-4693-9724-f33bcf497785
    Name : MapiDagNetwork
    Description :
    Subnets : {{*.*.*.192/26,Misconfigured}, {*.*.*.0/25,Misconfigured}}
    Interfaces : {}
    MapiAccessEnabled : False
    ReplicationEnabled : True
    IgnoreNetwork : False
    Identity : DAG01\MapiDagNetwork
    IsValid : True
    ObjectState : New
    RunspaceId : bf88015a-5f70-4693-9724-f33bcf497785
    Name : ReplicationDagNetwork01
    Description :
    Subnets : {{fe80::/64,Misconfigured}}
    Interfaces : {}
    MapiAccessEnabled : False
    ReplicationEnabled : True
    IgnoreNetwork : False
    Identity : DAG01\ReplicationDagNetwork01
    IsValid : True
    ObjectState : New

    21 ноября 2016 г. 13:06

Ответы

  • Получилось исправить

    Что было сделано дополнительно:
    - даны права на А запись в ДНС для учетки кластера + групп Exchange
    - удалены антивирусы Symantec с сервера со свидетелем (почему-то с модулем сетевой защиты) и проблемной ноды
    - после перезагрузки Shutdown/Start весь кластер, всё поднялось.

    23 ноября 2016 г. 7:09

Все ответы

  • Вот эти статьи результата не дали
    https://blogs.technet.microsoft.com/shekhar37k/2014/06/03/dag-network-shows-misconfigured-in-exchange-2013-server/

    http://exchangeserverpro.com/misconfigured-subnets-exchange-2013-dag-network/

    21 ноября 2016 г. 13:34
  • Отключение IPv6 на адаптерах при развертывании DAG - ошибка. Включите обратно. Для Exchange 2013 и выше нет необходимости во вторых интерфейсах для подсети репликации. Можете смело отключать их. И еще. При конфигурировании большинства сервисов Exchange лучше, если учетная запись все же будет входить в Domain Admins. Так по крайней мере эта учетка так же будет и в группе локальных администраторов.

    Do not multiply entities beyond what is necessary

    22 ноября 2016 г. 4:47
  • В итоге имеем такую ситуацию:

    На уровне DAG Exchange - все работает, базы копируются по физике, индекс в норме. При попытке активировать на второй ноде - ошибка, что на уровне кластера FC проблемы.

    + выскочило вот это:
    https://social.technet.microsoft.com/Forums/office/en-US/bbb32c2a-f2be-48dc-9943-f3e45f2ab5f2/dag-object-reference-not-set-to-an-instance-of-an-object?forum=Exch2016SD
    как это можно починить? как я понимаю, на уровне схемы AD сломался доступ к DAG в ECP по GUID

    вариантов я вижу как минимум два
    - удалить ноду из dag, завести заново
    - поднять третью ноду, добавить в dag корректно, вторую удалить

    Все действия, которые не помогли описаны здесь:
    https://www.facebook.com/groups/exchangeserverru/permalink/1172995576149065/
    22 ноября 2016 г. 6:51
  • Т.е. ВСЕ действия, которые рекомендуются для поднятия ноды кластера сделаны - не помогает.
    Нода спамит в лог событиями кластера 1573, 1564, 1653, хотя сетевая доступность полная и видимость папки свидетеля тоже

    Советуют сделать рестарт всего кластера, но рискованно как я понимаю

    22 ноября 2016 г. 7:06
  • Доводилось пару раз из Failover Cluster Manager прожимать Shutdown Cluster и потом его стартовать. Помогало, ничего не ломалось. Ошибки точно не вспомню, но что тоже про недоступность второй ноды и витнесса было, хотя витнесс был доступен и кластерные службы были запущены на обоих нодах.
    22 ноября 2016 г. 7:20
  • Именно в сочетании с DAG Exchange?
    22 ноября 2016 г. 7:31
  • Да. Первый раз тоже побаивался, пока кто то из коллег не подсказал, что уже это проделывал)
    22 ноября 2016 г. 7:35
  • Типовая операция отработки отказа при аварийном восстановлении: net stop clussvc и так далее....


    Do not multiply entities beyond what is necessary

    22 ноября 2016 г. 11:44
  • net stop clussvc

    на какой из нод? на проблемной - без результатов, уже делали.
    на здоровой - это аналог указанного shutdown cluster (т.е. весь кластер погасить) ?

    22 ноября 2016 г. 12:00
  • Получилось исправить

    Что было сделано дополнительно:
    - даны права на А запись в ДНС для учетки кластера + групп Exchange
    - удалены антивирусы Symantec с сервера со свидетелем (почему-то с модулем сетевой защиты) и проблемной ноды
    - после перезагрузки Shutdown/Start весь кластер, всё поднялось.

    23 ноября 2016 г. 7:09
  • Отлично. Не успел вам отписать, что net stop clussvc это остановка службы, а не аналог shutdown cluster))
    • Изменено Ivan.Basov 23 ноября 2016 г. 7:15
    23 ноября 2016 г. 7:15