none
S/MIME по ГОСТ в OWA RRS feed

  • Общие обсуждения

  • Добрый день, коллеги!

    На днях перешел с Exchange Server 2010 на Exchange Server 2013 и поимел серьёзные проблемы с использованием российского криптопровайдера "КриптоПро CSP" в качестве СКЗИ для защиты OWA (HTTPS) и в качестве средства электронной подписи (S/MIME).

    В наличии есть Exchange Server 2013 SP1 CU7 с ролями CAS и MBX в одной "коробке".

    В OWA подписываю (БЕЗ шифрования письма) письмо ГОСТовской электронной подписью (используя S/MIME) и отправляю на почтовый ящик на этом же сервере. Ящик-получателя открываю с помощью Microsoft Outlook 2010 (со всеми обновлениями) и письмо с электронной подписью не видится и не открывается вот с такими надписями:

    "Невозможно отобразить элемент в области чтения. Откройте элемент для чтения его содержимого."

    Пытаюсь открыть письмо и вот какую ошибку получаю:

    "Невозможно открыть элемент. Система безопасности не может найти ваше цифровое удостоверение."

    Если открывать письмо в OWA, то оно отлично читается.

    Если подписывать в Outlook 2010 и отправлять в Outlook 2010 или OWA, то всё отлично видится, читается и проверяется.

    Т.е. проблема именно с тем, как OWA 2013 SP1 CU7 подписывает сообщения, что видит их только сама.

    Копал в сторону "Set-SmimeConfig -OWAEncryptionAlgorithms", но безуспешно. Из доступных криптоалгоритмов только RC2, DES, 3DES, AES128, AES192, AES256. Пробовал все включать, отдельные комбинации, но результат нулевой. Полагаю, что должен быть в списке отдельный алгоритм GOST, который по какой то причине был исключен.

    Прошу приближенных к команде разработчиков Exchange Server посодействовать в исправлении этого досадного бага.

    PS: В OWA на Exchange Server 2010 такой проблемы не было. S/MIME с использованием ГОСТовских электронных подписей работал на ура и читался везде (OWA, Outlook 2007/2010/2013).


    MCP, MCSA, MCSA: Messaging

    24 марта 2015 г. 13:28