none
Создание личных сайтов в SharePoint Server 2016 RRS feed

  • Вопрос

  • Добрый день.

    Поднял новый SP сервер 2016. Подключил к нему БД контента от 2013 шарика. Всё ок. Проблема в другом.

    Не могу настроить личные сайты пользователя так как мне нужно. Постараюсь пояснить:

    Портал откликается вот по такому адресу: http://sps2016 Посадил его на 80-ый порт.

    Но мне нужно, чтобы адрес размещения личных сайтов пользователя был такой: http://people.mydomain.ru/...  (где, mydomain.ru - домен организации) а не тот, что предлагает шарик в виде: http://sps2016:<какой то кучерявый порт>/.... и т.д.

    Теперь по порядку, что я делаю:

    1) Создаю НОВОЕ web-приложение "peopleapp" с именем IIS-сайта "people.mydomain.ru" и общедоступным URL-ом... а теперь внимание! :)

        если URL будет вида:  http://sps2016:<какой то кучерявый порт>/ - то дальнейшая настройка по документации приводит к созданию личных сайтов, но если

                URL будет вида:  http://people.mydomain.ru/ (то что мне надо) - то web-приложение тоже будет создано, но в дальнейшем, после настройки остальных шагов, попытки перейти по этому адресу вызовут ошибку отображения страницы. Т.е. шарик не будет знать такого адреса.

    У меня есть под рукой боевой портал, где настроено всё как надо, но я уже всё там излазил. Не могу понять что я упустил.

    Если понятно объяснил - подскажите что не так делаю?

    1 февраля 2017 г. 12:15

Ответы

Все ответы

  • Добрый день

    а Вы добавили  http://people.mydomain.ru/  в DNS или в локальный hosts?

    что значит "Т.е. шарик не будет знать такого адреса."?


    мой блог Немного о SharePoint

    • Помечено в качестве ответа VARD32 2 февраля 2017 г. 8:02
    1 февраля 2017 г. 13:11
    Модератор
  • Нет, не добавлял.

    Ну я не понимаю, как шар узнает, что адрес http://people.mydomain.ru/ - это не настоящий, что портал развернут в http://sps2016

    1 февраля 2017 г. 13:19
  • мое понимание как это работает:

    в браузере набираем адрес

    браузер спрашивает у DNS (если не записано в hosts) какой ip у сервера который имеет требуемый адрес

    далее браузер обращается на сервер SP по IP 

    запрос от браузера принемает IIS и смотрит какой хост у адреса 

    далее в зависимости от хоста и/или порта попадает на разные сайты которые уже обслуживает SP. 

    SP проверяет какой хост и сверяет его с AAM, и отвечает или нет.


    мой блог Немного о SharePoint

    1 февраля 2017 г. 13:48
    Модератор
  • Думаю, что Ваше понимание верное.

    Но моя проблема кроется немного в другом. Если кратко, я не могу создать два веб-приложения с разными URL-адресами и одним и тем же 80-ым портом.

    Начитавшись форумов M$ я понимаю этот процесс так (если что - поправьте меня):

    Цель: создание личных сайтов пользователя.

    Что делаю:

    1) Создаю Новое (ещё одно) веб-приложение. При создании приложения указываю в качестве параметров следующее:

              - Наименование сайта IIS (т.е. то как будет называться сайт в коллекции Sites сервера IIS).Даю ему название "people.mydomain.ru"

               - Порт на котором будет сидеть сайт. Предлагаемое значение (например 31456) меняю на 80.

               - Путь к каталогу inetpub. В конце пути меняю 80 на people (т.к. 80-ый порт основного веб-приложения уже занял эту папку)

               - URL: По умолчанию там стоит имя портала (такое: http://sps2016:31456/) Заменяю на                 http://people.mydomain.ru:80/

               - наименование веб-приложения: По умолчанию стоит "Sharepoint:31456". Меняю на "peopleapp"

    Заполняю учетные записи, и т.д. Жму ок.

    Жду.

    Начинается процесс создания приложения и,... "Что-то пошло не так..."

    Мол уже используется такое веб приложение. (хотя оно создается впервые)

    Что не так я делаю?

    1 февраля 2017 г. 15:34
  • что говорят логи ?

    мой блог Немного о SharePoint

    1 февраля 2017 г. 19:21
    Модератор
  • Скажите, мне необходимо понимать один момент.

    Возможно такое в SharePoint когда два разных сайта с двумя разными пулами приложений сидят на 80-м порту?

    2 февраля 2017 г. 2:25
  • Я уже начинаю сомневаться в целесообразности всего этого. Т.к. основная задача у меня стоит в том, чтобы мигрироваться с 2013 на 2016 сервер.

    Как я уже говорил, базу контента я подключил успешно, и сайт 2016-го выглядит вполне себе живым, но вот как быть с личными сайтами пользователей!?

    Их скорее всего тоже надо будет мигрировать. Не подскажете, это вообще возможно?

    2 февраля 2017 г. 2:32
  • Возможно такое в SharePoint когда два разных сайта с двумя разными пулами приложений сидят на 80-м порту?

    Ну у меня то работает. и не только у меня :)

    мой блог Немного о SharePoint

    2 февраля 2017 г. 7:00
    Модератор
  • предлагаю все же попробовать еще раз.

    в момент когда появится ошибка,взять id и посмотреть в логах что там происходит.


    мой блог Немного о SharePoint

    2 февраля 2017 г. 7:03
    Модератор
  • Вы правы - дело было в DNS-Записи. 

    Подскажите пожалуйста. Внезапно пропала возможность создать службу Excel Services Application а также Access Services и Visio Graphics Services. 

    Они точно были. Где посмотреть что не так?

    Спасибо.


    • Изменено VARD32 2 февраля 2017 г. 7:08
    • Помечено в качестве ответа VARD32 2 февраля 2017 г. 8:01
    • Снята пометка об ответе VARD32 2 февраля 2017 г. 8:01
    2 февраля 2017 г. 7:04
  • что значит "Пропала возможность"? нет в этом списке?



    мой блог Немного о SharePoint

    2 февраля 2017 г. 7:18
    Модератор
  • Нет в списке выпадающем по кнопке New... Т.е. я создать не могу приложение-службу.

    По кнопке Connect есть только Access Services


    • Изменено VARD32 2 февраля 2017 г. 7:24
    2 февраля 2017 г. 7:23
  • возможно все дело в лицензии?

    SharePoint 2016 Feature comparison Standard VS Enterprise


    мой блог Немного о SharePoint

    2 февраля 2017 г. 7:28
    Модератор
  • о....

    А где её активировать в Enterprise ? На самом шаре можно? Хотя бы на 180 дней...

    2 февраля 2017 г. 7:31
  • нужен ключ 

    меняется он в ЦА /_admin/Conversion.aspx


    мой блог Немного о SharePoint

    • Помечено в качестве ответа VARD32 2 февраля 2017 г. 8:02
    2 февраля 2017 г. 7:35
    Модератор
  • еще, хорошо бы отметить ответ на основной Ваш вопрос, что бы коллеги легко могли найти ответ.

    мой блог Немного о SharePoint

    2 февраля 2017 г. 7:49
    Модератор
  • Да, конечно. Спасибо Вам.
    2 февраля 2017 г. 8:02
  • Эхх.. Excel всё равно не появился. Прочитал в инете статью, где оказывается службы Excel были исключены из поставки шарика 2016.

    Их придется включать как то отдельно. Через установку Office Online ((

    Вот эта статья:

    http://community.bamboosolutions.com/blogs/bambooteamblog/archive/2016/07/11/excel-services-application-in-sharepoint-2016.aspx

    2 февраля 2017 г. 8:36
  • Ещё Work Management Service Application выкосили ((
    2 февраля 2017 г. 9:34