none
Ошибка в Connectivity Analyzer, не подключается мобильный Outlook на Андройд к Exchange 2010 RRS feed

  • Общие обсуждения

  • Добрый день,

    Столкнулся с проблемой подключения последнего Outlook на Андройде к Exchange 2010. При это старая версия Outlook и почта Google работает, только надо указать почтовый сервер руками.

    Трижды проверил все настройки autodiscover и записи в DNS. Все ок.

    Заметил, что testconnectivity.microsoft.com выдает ошибку:

    Testing HTTP Authentication Methods for URL https://mail.firma.ru/Microsoft-Server-ActiveSync.

    The HTTP authentication test failed.

    Additional Details

    An HTTP 500 response was returned from Unknown.
    HTTP Response Headers:
    Content-Length: 162
    Content-Type: text/html
    Date: Thu, 21 Nov 2019 10:39:18 GMT
    Server: Microsoft-IIS/8.5

    Elapsed Time: 199 ms.

    Что-то можно проверить и куда капнуть?

    У нас 2 сервера Exchange 2010, в разных офисах. На одном сервере:

    [PS] C:\Windows\system32>Test-WebServicesConnectivity
    Creating a new session for implicit remoting of "Test-WebServicesConnectivity" command...

    CasServer  LocalSite     Scenario        Result  Latency(MS) Error
    ---------  ---------     --------        ------  ----------- -----
    EX1       Default-Fi... GetFolder       Ошибка              [System.InvalidOperat...

    на другом:

    [PS] C:\Windows\system32>Test-WebServicesConnectivity

    CasServer  LocalSite     Scenario        Result  Latency(MS) Error
    ---------  ---------     --------        ------  ----------- -----
    EX2        Default-Fi... GetFolder       Удач...      187.49
    EX2        Default-Fi... SyncFolderItems Удач...      124.98
    EX2        Default-Fi... CreateItem      Удач...      187.49
    EX2        Default-Fi... SyncFolderItems Удач...      171.87
    EX2        Default-Fi... DeleteItem      Удач...      156.26
    EX2        Default-Fi... SyncFolderItems Удач...      187.49

    Не знаю связаны эти ошибки или нет.

    Помогите.

    Спасибо.

    21 ноября 2019 г. 10:57

Все ответы

  • Вроде базовая включена, где посмотреть?
    21 ноября 2019 г. 11:44
  • Трижды проверил все настройки autodiscover и записи в DNS. Все ок.

    Судя по симптомам, скорее всего - как раз не ОК. "Exchange ActiveSync Autodiscover" в testconnectivity.microsoft.com проверяли?

    PS Настройки аутентификации можно проверить (а при необходимости - скопировать информацию сюда) командой Get-ActiveSyncVirtualDirectory | fl Name, *Auth* в EMS


    Слава России!

    21 ноября 2019 г. 11:54
  • на обоих серверах одно и тоже:
    [PS] C:\Windows\system32>Get-ActiveSyncVirtualDirectory | fl Name, *Auth*
    Creating a new session for implicit remoting of "Get-ActiveSyncVirtualDirectory" command...


    Name                                : Microsoft-Server-ActiveSync (Default Web Site)
    MobileClientCertificateAuthorityURL :
    BasicAuthEnabled                    : True
    WindowsAuthEnabled                  : True
    ClientCertAuth                      : Ignore
    InternalAuthenticationMethods       : {}
    ExternalAuthenticationMethods       : {}

    Name                                : Microsoft-Server-ActiveSync (Default Web Site)
    MobileClientCertificateAuthorityURL :
    BasicAuthEnabled                    : True
    WindowsAuthEnabled                  : True
    ClientCertAuth                      : Ignore
    InternalAuthenticationMethods       : {}
    ExternalAuthenticationMethods       : {}

    Test Connectivity Exchange ActiveSync Autodiscover проходит, не проходит тест просто Exchange  ActiveSync. 

    21 ноября 2019 г. 12:10
  • Может влиять на это отключенный ipv6 на обоих серверах?
    21 ноября 2019 г. 12:41
  • Test Connectivity Exchange ActiveSync Autodiscover проходит

    А URL, который возвращает Autodiscover - он совпадает с тем, который нужно настраивать для доступа вручную?

    Слава России!

    21 ноября 2019 г. 14:12
  • А URL, который возвращает Autodiscover - он совпадает с тем, который нужно настраивать для доступа вручную?

    да. ввожу mail.firma.ru

    The Microsoft Connectivity Analyzer is testing Exchange ActiveSync.
    The Exchange ActiveSync test failed.

    Testing HTTP Authentication Methods for URL https://mail.firma.ru/Microsoft-Server-ActiveSync.
    The HTTP authentication test failed.
    Additional Details
    An HTTP 500 response was returned from Unknown. HTTP Response Headers: Content-Length: 162 Content-Type: text/html Date: Thu, 21 Nov 2019 15:10:54 GMT Server: Microsoft-IIS/8.5
    Elapsed Time: 20203 ms.


    21 ноября 2019 г. 15:26
  • УЗ под который вы тестируете - это обычная пользовательская УЗ или обладает админскими полномочиями в RBAC?
    21 ноября 2019 г. 15:44
  • УЗ под который вы тестируете - это обычная пользовательская УЗ или обладает админскими полномочиями в RBAC?

    Обычный пользователь, под админом я делал наследование прав и получал такую же ошибку.

    В первом сообщение я указал ошибку при выполнении Test-WebServicesConnectivity на одном из серверов, думаю ошибки могут быть связаны или нет? решение найти не получается. (

    21 ноября 2019 г. 16:05