none
Странное поведение Windows Media в Vista: Работает только с файлами длиной менее 700 Mb RRS feed

  • Общие обсуждения

  • Уважаемые знатоки ! Помогите пожалуйста решить проблему.

    После очередного обновления (я не отследил, когда именно это случилось), все плейеры на моем ноутбуке перестали проигрывать длиные файлы (вилеофильмы), если размер файла превышает приблизительно 700 мегабайт.

    Если меньше - все работает нормально.

    Как это выглядит. Запускаю фильм (файл с размером 1400 мегабайт). Появляются титры. Затем, после первого кадра выскакивает надпись, что работа плейера прекращена в связи с ошибкой.

    Я пытался переустанавливать кодеки (сейчас стоит последний DivX), пытался ставить другие плейеры - никакой разницы, что бы ни делал - картина остается неизменной.

    Может кто-нибудь сталкивался с такой проблемой ? 

    Данные системы :

    Ноутбук : ASUS W7J

    Система : Windows Vista Home Premium Service Pack 2 ( 89578-OEM-7332157-00043)

    Кодеки :  DivX pro codek 6.9.2

    Вот что показывает "журнал", кгда я пытаюсь просмотреть фильм при помощи DivX player :

    Имя журнала:   Application
    Подача:        Application Error
    Дата:          04.04.2010 19:18:24
    Код события:   1000
    Категория задачи:(100)
    Уровень:       Ошибка
    Ключевые слова:Классический
    Пользователь:  Н/Д
    Компьютер:     Мария-ПК
    Описание:
    Сбойное приложение DivX Plus Player.exe, версия 10.1.0.428, штамп времени 0x4ba3fab6, сбойный модуль unknown, версия 0.0.0.0, штамп времени 0x00000000, код исключения 0xc0000005, смещение ошибки 0x00000000, ИД процесса 0x10f0, время запуска приложения 0x01cad40a042e11d0.
    Xml события:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-04-04T15:18:24.000Z" />
        <EventRecordID>11260</EventRecordID>
        <Channel>Application</Channel>
        <Computer>Мария-ПК</Computer>
        <Security />
      </System>
      <EventData>
        <Data>DivX Plus Player.exe</Data>
        <Data>10.1.0.428</Data>
        <Data>4ba3fab6</Data>
        <Data>unknown</Data>
        <Data>0.0.0.0</Data>
        <Data>00000000</Data>
        <Data>c0000005</Data>
        <Data>00000000</Data>
        <Data>10f0</Data>
        <Data>01cad40a042e11d0</Data>
      </EventData>
    </Event>

    Вот что показывает "журнал", когда я пытаюсь просмотреть фильм при помощи Windows Media Player :

    Имя журнала:   Application
    Подача:        Application Error
    Дата:          02.04.2010 21:41:13
    Код события:   1000
    Категория задачи:(100)
    Уровень:       Ошибка
    Ключевые слова:Классический
    Пользователь:  Н/Д
    Компьютер:     Мария-ПК
    Описание:
    Сбойное приложение wmplayer.exe, версия 11.0.6002.18111, штамп времени 0x4aa91411, сбойный модуль unknown, версия 0.0.0.0, штамп времени 0x00000000, код исключения 0x80000004, смещение ошибки 0x00000000, ИД процесса 0xf38, время запуска приложения 0x01cad28b7f52fa40.
    Xml события:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-04-02T17:41:13.000Z" />
        <EventRecordID>11238</EventRecordID>
        <Channel>Application</Channel>
        <Computer>Мария-ПК</Computer>
        <Security />
      </System>
      <EventData>
        <Data>wmplayer.exe</Data>
        <Data>11.0.6002.18111</Data>
        <Data>4aa91411</Data>
        <Data>unknown</Data>
        <Data>0.0.0.0</Data>
        <Data>00000000</Data>
        <Data>80000004</Data>
        <Data>00000000</Data>
        <Data>f38</Data>
        <Data>01cad28b7f52fa40</Data>
      </EventData>
    </Event>

    Хотелось бы понять, почему это происходит и как с этим бороться. Пока нигде не нашел.

    5 апреля 2010 г. 4:50

Все ответы

  • Попробуйте переустановить драйвер видеоадаптера.

    5 апреля 2010 г. 21:32
  • Попробуйте переустановить драйвер видеоадаптера.


    Попробовал. Ничего не изменилось.
    6 апреля 2010 г. 13:04
  • Кодек-паки стоят? Попробуйте удалить. Если, конечно, они удалятся. :(

    6 апреля 2010 г. 14:08
    Модератор
  • Кодек-паки стоят? Попробуйте удалить. Если, конечно, они удалятся. :(


    Это первое, что я попробовал сделать (полностью удалил кодек-пак и инсталлировал новый). Сейчас у меня все кодеки самые свежие.  Результат тот же. Интуиция подсказывает, что дело не в кодеках, а что-то в самой Висте. Только вот где ?
    6 апреля 2010 г. 14:17
  • Только вот где ?

    Практически наверняка - в кодеках.
    6 апреля 2010 г. 15:47
    Модератор
  • При установке кодек-пака НЕ СТАВЬТЕ входящие в его состав проигрыватели. Если полностью удалить пакет кодеков (не переустановить а удалить) проблема сохраняется?

    Все вышесказанное является моим личным мнением, не имеющим отношения к корпорации Майкрософт.
    Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    9 апреля 2010 г. 9:43
    Модератор