none
Изменение локальной политики через regedit RRS feed

  • Вопрос

  • Как "применить" настройки политики, если я задал параметры путем редактирования реестра?

    В частности, я задал необходимые настройки службы WSUS в HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate, после чего запустил gpupdate. Но я  что-то не вижу, чтобы машина засветилась на сервере WSUS.  Может я упустил какой-то параметр? Или отредактированную через реестр политику надо как-то по-другому применять?

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]  
    "WUServer"="http://wsus"  
    "WUStatusServer"="http://wsus"  
    "ElevateNonAdmins"=dword:00000001  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]  
    "NoAutoUpdate"=dword:00000000  
    "NoAutoRebootWithLoggedOnUsers"=dword:00000001  
    "AutoInstallMinorUpdates"=dword:00000001  
    "UseWUServer"=dword:00000001  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]  
    "AUOptions"=dword:00000003  
     
    13 февраля 2009 г. 1:13

Все ответы

  • gpupdate /force

    Потом ребут. Машина должна сообщить о себе всусу через несколько часов, но никак не сразу.
    13 февраля 2009 г. 2:49
  • /force тоже делал. Ждал сутки. Не вышел каменный цветок.
    13 февраля 2009 г. 5:42
  • А служба Windows Update запущена на клиенте?

    Вот содержимое ветки на моей машине.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
    "WUServer"="http://fangorn:8530"
    "WUStatusServer"="http://fangorn:8530"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoUpdate"=dword:00000000
    "AUOptions"=dword:00000004
    "ScheduledInstallDay"=dword:00000000
    "ScheduledInstallTime"=dword:0000000c
    "UseWUServer"=dword:00000001
    "NoAutoRebootWithLoggedOnUsers"=dword:00000001
    "RescheduleWaitTimeEnabled"=dword:00000001
    "RescheduleWaitTime"=dword:0000000a
    "RebootRelaunchTimeoutEnabled"=dword:00000001
    "RebootRelaunchTimeout"=dword:000001a4


    Кажись ясно в чём причина. Порт у тебя неверный. Нужно :8530
    13 февраля 2009 г. 6:30
  • можно использовать шаблоны групповой политики и применять их локально О_о мб!

    Oloth Teken'duis
    17 февраля 2009 г. 10:00
  •  Почему 8530? Где-то читал, что 80 порт рекомендуется, ибо через все остальные по-моему сам механизм обновлений обновляться не будет... без заморочек.
    У желания 1000 возможностей, у нежелания 1000 причин!!!
    20 февраля 2009 г. 15:16
  • 8530 порт по умолчанию при установке WSUS.
    Как-то жалко отдавать WSUSу 80-ый порт, обычно он чем-то занят.

    > сам механизм обновлений обновляться не будет
    пытался найти нечто подобное, не получилось.... источник доверенный?

    Значит, я так понимаю, вы перенастроили сайт всуса именно на 80-ый порт?
    команда:

    telnet <servername> 80

    выявляет, что порт слушается? А 8530?

    Только одна машина не хочет заявить о себе всусу?
    Пробовали выполнять принудительное нахождение сервера командой wuauclt.exe /detectnow ?

    24 февраля 2009 г. 17:29