none
Обновление Windows 10 Home с версии 1809 до 1903 постоянно зависает на 60% RRS feed

  • Вопрос

  • Обновление Windows 10 Home с версии 1809 до 1903 устанавливается в системе, затем компьютер перезагружается и установка обновления продолжается. Но затем постоянно на 60% обновление зависает с ошибкой "Windows setup could not configure one or more system components", компьютер перезагружается и происходит откат обновления обратно до версии 1809.

    При попытке установить обновление с помощью Media Creation Tool происходит то же самое, но в конце при входе в Windows дополнительно выдается сообщение об ошибке 0xC1900101 - 0X30018 "ошибка на этапе установки FIRST_BOOT во время операции SYSPREP_SPECIALIZE".

    Я нашел на англоязычном сайте похожую ошибку, но там нет решения, так же сам создал там тему

    https://answers.microsoft.com/en-us/windows/forum/all/windows-10-build-1809-build-1903-windows-setup/bb95d8cb-07c1-4a86-94dc-22b07b7523f4

    https://answers.microsoft.com/en-us/windows/forum/windows_10-update/windows-10-update-from-1809-to-1903-stuck-on-60/40bbd490-b56e-4c3b-8ca2-b7577dbd2b89?tm=1562352739878

    Искал в интернете по логам информацию, выяснил, что проблема возможно связана с неправильной настройкой или функционированием таких компонентов Windows (панель управления=>программы и компоненты=>включение или отключение компонентов Windows), как Net Framework 4.7 и его подкаталогов службы WCF (активация по HTTP, активация по TCP, совместное использование портов TCP) или компанента "службы IIS" (Internet Information Service).

    У меня на компьютере IIS полностью отключен и не включается с сообщением об ошибке 0x800F0922 "не удалось применить требуемые изменения". В подкаталоге службы WCF активация по HTTP выключена и не включается с таким же сообщением об ошибке, а остальные подпункты включены и не выключаются так же с таким же сообщением.

    Раньше я отключал "ненужные" по моему мнению службы и программы Windows, возможно удалил не те файлы или отключил что-нибудь нужное для установки обновления.

    Выкладываю логи (если что-то еще понадобиться могу скинуть) (в папке Rollback ошибок нет)

    Не могу скинуть ссылки, поэтому выложу отрывки:

    Ключевые отрывки из LOG файлов:

    CBS:

    2019-07-06 13:29:19, Info                  CSI    00000c77 Begin executing advanced installer phase 39 index 0 (sequence 0)
        Old component: [l:0]''
        New component: [l:0]''
        Install mode: delta
        Smart installer: true
        Installer ID: {79675b3f-2054-4efd-aa9d-e1830916be47}
        Installer name: 'ServiceModelReg Installer'
    2019-07-06 13:29:19, Info                  CSI    
    00000c78@2019/7/6:07:29:19.859 ServiceModelReg Installer Committing 
    with: component: 1 version: 4.0.30319 64bit: true install: true delta: 
    false
    
    2019-07-06 13:29:19, Info                  CSI    
    00000c79@2019/7/6:07:29:19.859 ServiceModelInstaller::ExecuteInstaller 
    Executing WasInstaller.
    
    2019-07-06 13:29:19, Info                  CSI    00000c7a@2019/7/6:07:29:19.859 InstallWasProtocol: protocolName: 'net.tcp'
      identity: 'S-1-5-80-3579033775-2824656752-1522793541-1960352512-462907086'
      bindingInformation: '808:*'
    
    2019-07-06 13:29:19, Error                 CSI    00000c7b (F) 
    CWebServerHandlers::ConfigureListener GetAdminSectionFailed failed: 
    sectionName: 'system.applicationHost/listenerAdapters' errorCode: 
    HRESULT_FROM_WIN32(ERROR_INVALID_DATA)
    [gle=0x80004005]
    2019-07-06 13:29:19, Error                 CSI    
    00000c7c@2019/7/6:07:29:19.937 (F) 
    base\wcp\plugins\servicemodelregai\dll\servicemodelregai.cpp(353): Error
     NTSTATUS_FROM_WIN32(ERROR_INVALID_DATA) originated in function 
    Windows::WCP::WCF::ServiceModelInstaller::ExecuteInstaller
     expression: wasInstaller.Install()
    [gle=0x80004005]
    2019-07-06 13:29:20, Info                  CBS    Could not get active 
    session for current session file logging [HRESULT = 0x80004003 - 
    E_POINTER]
    2019-07-06 13:29:20, Info                  CBS    Could not get file 
    name for current session file logging [HRESULT = 0x80004003 - E_POINTER]
    2019-07-06 13:29:20, Info                  CBS    Failed to retrieve CBS
     log environment variable size for offline WER report. [HRESULT = 
    0x800700cb - ERROR_ENVVAR_NOT_FOUND]
    2019-07-06 13:29:20, Info                  CBS    Not able to add CBS 
    log files to Windows Error Report. [HRESULT = 0x800700cb - 
    ERROR_ENVVAR_NOT_FOUND]
    2019-07-06 13:29:20, Info                  CSI    00000c7d@2019/7/6:07:29:20.973 CSI Advanced installer perf trace:
    CSIPERF:AIDONE;{79675b3f-2054-4efd-aa9d-e1830916be47};(null);1102142us
    2019-07-06 13:29:20, Info                  CSI    00000c7e End executing advanced installer (sequence 0)
        Completion status: HRESULT_FROM_WIN32(ERROR_INVALID_DATA) 
    
    2019-07-06 13:29:20, Error      [0x018046] CSI    00000c7f (F) Failed 
    execution of queue item Installer: ServiceModelReg Installer 
    ({79675b3f-2054-4efd-aa9d-e1830916be47}) with HRESULT 
    HRESULT_FROM_WIN32(ERROR_INVALID_DATA).  Failure will not be ignored: A
     rollback will be initiated after all the operations in the installer 
    queue are completed; installer is reliable[gle=0x80004005]

    Setuperr:

    2019-07-06
     13:29:19, Error                 CSI    00000c7b (F) 
    CWebServerHandlers::ConfigureListener GetAdminSectionFailed failed: 
    sectionName: 'system.applicationHost/listenerAdapters' errorCode: 
    HRESULT_FROM_WIN32(ERROR_INVALID_DATA)
    [gle=0x80004005]
    2019-07-06 13:29:19, Error                 CSI    
    00000c7c@2019/7/6:07:29:19.937 (F) 
    base\wcp\plugins\servicemodelregai\dll\servicemodelregai.cpp(353): Error
     NTSTATUS_FROM_WIN32(ERROR_INVALID_DATA) originated in function 
    Windows::WCP::WCF::ServiceModelInstaller::ExecuteInstaller
     expression: wasInstaller.Install()
    [gle=0x80004005]
    2019-07-06 13:29:20, Error      [0x018046] CSI    00000c7f (F) Failed 
    execution of queue item Installer: ServiceModelReg Installer 
    ({79675b3f-2054-4efd-aa9d-e1830916be47}) with HRESULT 
    HRESULT_FROM_WIN32(ERROR_INVALID_DATA).  Failure will not be ignored: A
     rollback will be initiated after all the operations in the installer 
    queue are completed; installer is reliable[gle=0x80004005]
    2019-07-06 13:29:21, Error                 CSI    00000cae (F) 
    Installer: ServiceModelReg Installer    Binary Name: 
    servicemodelregai.dll    ErrorCode: 8007000d    Phase: 39    Mode: 
    Delta    Component: NONE[gle=0x80004005]
    2019-07-06 13:29:21, Error                 CSI    
    00000cb0@2019/7/6:07:29:21.492 (F) 
    onecore\base\wcp\componentstore\com\advancedinstallerstore.cpp(568): 
    Error HRESULT_FROM_WIN32(ERROR_ADVANCED_INSTALLER_FAILED) originated in 
    function 
    Windows::COM::CComponentStore::IAdvancedInstallerAwareStore_ResolvePendingTransactions
     expression: static_cast<DWORD>(14099L)
    [gle=0x80004005]
    2019-07-06 13:29:21, Error                 CSI    00000cb1 (F) 
    HRESULT_FROM_WIN32(ERROR_ADVANCED_INSTALLER_FAILED) #123# from 
    Windows::COM::CComponentStore_IAdvancedInstallerAwareStore::ResolvePendingTransactions(dwFlags
     = (DontFailIfPrimitivesPending|IndicatePrimitiveRollback),
     Progress = NULL, Phase = 0, Disposition = (unknown enumerant 0)' | 
    '0)[gle=0x80073713]
    2019-07-06 13:29:21, Error                 CBS    Startup: Failed to 
    process advanced operation queue, startupPhase: 0. [HRESULT = 0x80073713
     - ERROR_ADVANCED_INSTALLER_FAILED]
    2019-07-06 13:29:21, Error      [0x030149] CMI    Callback_CBS_Do_OnlineInstall:Calling startup processing failed 0x80073713
    2019-07-06 13:29:21, Error      [0x030153] CMI    Callback_CMI_ConfigInstall: CBS startup processing failed.

Ответы

  • UPDATE

    Спасибо за предложения, самостоятельно решил проблему, дело было в невозможности запуска службы WAS "Служба активации Windows", из - за этого не могло установится обновление, вылетая с ошибкой установки TCP activation
    Файл в каталоге System32\inetsrv\config\ApplicationHost.config был пустой (без текста), заменил его на файл applicationhost.config.clean.install из той же папки (можно найти его в интернете думаю, если нет в папке) и все стало в порядке, служба запустилась, обновление Windows до 1903 установилось. Надеюсь, кому - нибудь поможет эта информация, тему можно закрывать. 
    • Изменено Aaa Aaa Aaa 6 июля 2019 г. 19:00
    • Помечено в качестве ответа Vector BCOModerator 6 июля 2019 г. 20:44
    • Изменено Vector BCOModerator 6 июля 2019 г. 20:46 удален белый квадрат
    6 июля 2019 г. 19:00
  • Уфф, это было тяжело... Проблема была в одном из ключей из скриншота по адресу

    C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys

    Пришлось изменить у него владельца (без этого файл не удалялся) и удалить его, после этого служба запустилась без проблем.

    Вот ссылка, которая помогла найти проблему:

    https://www.hanselman.com/blog/FixedWindowsProcessActivationServiceWASIsStoppingBecauseItEncounteredAnError.aspx

    Огромное спасибо за помощь, может быть кому нибудь поможет мое решение.


    • Изменено SQxModerator 7 июля 2019 г. 20:00 удалены пробелы
    • Помечено в качестве ответа SQxModerator 7 июля 2019 г. 20:00
    7 июля 2019 г. 19:42

Все ответы

  • у вас антивирус установлен (сторонний)? если да попробуйте удалить

    дополнительно прогонитеdism /online /cleanup-image /restorehealth и sfc /scannow

    оптимизаторы/ускорители/клинеры используете? если да, то оптимальным решением будет установка ос с нуля, так как упомянутые тулзы приводят систему в неработоспособное состояние


    The opinion expressed by me is not an official position of Microsoft


    Модератор
  • Антивирус ESET NOD32, отключал на время установки, не помогает, попробую удалить

    sfc /scannow не помогает, все в порядке в системе

    dism /online /cleanup-image /checkhealth без ошибок

    dism /online /cleanup-image /restorehealth выполнял, тоже не помогает

    (все выполнял до попытки установки обновления)

    клинером вроде бы пару раз раньше воспользовался, уже точно не помню.

    А если устанавливать с нуля (у меня есть скачанный ISO образ с файлом setup.exe) через setup.exe, то мои приложения удалятся насколько я понимаю? То есть будет чистая ОС с моими файлами, но установленных приложений из старой ОС не будет? Или возможно как то обновить ОС без потери приложений другими методами через ISO образ?

    • Изменено Aaa Aaa Aaa 6 июля 2019 г. 9:23
    • Изменено Vector BCOModerator 6 июля 2019 г. 20:47 удалены 2 белых квадрата
  • обновить можно с сохранением приложений а установка с нуля на то и с нуля, что на выходе вы получите чистую ос без ничего. отключение антивирусов не помагает, так как они устанавливают часто свои прослойки в ос которые обновление не может правильно переварить

    The opinion expressed by me is not an official position of Microsoft

    Модератор
  • То есть если я запущу setup.exe из образа ISO и выполню установку, мои старые приложения не сохранятся? Простите за глупость, но не хотелось бы случайно удалить все, поэтому переспрашиваю.

    Может удастся обойтись без переустановки, выявив проблему в лог файлах

    Возможно, проблема в net.tcp (правда я не уверен)

    InstallWasProtocol: protocolName: 'net.tcp'
      identity: 'S-1-5-80-3579033775-2824656752-1522793541-1960352512-462907086'
      bindingInformation: '808:*'

    2019-07-06 13:29:19, Error                 CSI    00000c7b (F) CWebServerHandlers::ConfigureListener GetAdminSectionFailed failed: sectionName: 'system.applicationHost/listenerAdapters' errorCode: HRESULT_FROM_WIN32(ERROR_INVALID_DATA)
    [gle=0x80004005]<del>
    </del>

    Может можно переустановить IIS или восстановить Net Framework или еще что нибудь придумать по log файлам...

    • Изменено Aaa Aaa Aaa 6 июля 2019 г. 9:56
    • Изменено Vector BCOModerator 6 июля 2019 г. 20:45 удален белый квадрат
  • Приветствую.

    В вашем случае проше будет установить ос с нуля.


    Я не волшебник, я только учусь. MCTS, CCNA. Если Вам помог чей-либо ответ, пожалуйста, не забывайте нажать на кнопку "Отметить как ответ" или проголосовать за "полезное сообщение". Disclaimer: Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции работодателя. Вся информация предоставляется как есть, без каких-либо на то гарантий. Блог IT Инженера, Яндекс Дзен, YouTube, GitHub.

    6 июля 2019 г. 11:55
    Модератор
  • То есть если я запущу setup.exe из образа ISO и выполню установку, мои старые приложения не сохранятся? Простите за глупость, но не хотелось бы случайно удалить все, поэтому переспрашиваю.

    Может удастся обойтись без переустановки, выявив проблему в лог файлах

    Возможно, проблема в net.tcp (правда я не уверен)

    InstallWasProtocol: protocolName: 'net.tcp'
      identity: 'S-1-5-80-3579033775-2824656752-1522793541-1960352512-462907086'
      bindingInformation: '808:*'

    2019-07-06 13:29:19, Error                 CSI    00000c7b (F) CWebServerHandlers::ConfigureListener GetAdminSectionFailed failed: sectionName: 'system.applicationHost/listenerAdapters' errorCode: HRESULT_FROM_WIN32(ERROR_INVALID_DATA)
    [gle=0x80004005]<del>
    </del>

    Может можно переустановить IIS или восстановить Net Framework или еще что нибудь придумать по log файлам...

    установка с нуля пожразумевает что при помощи media creatio tool'a вы записываете образ на флешку, после чего загружаетесь с нее и производите установку. В случае любых опасений стоит создать копию важных файлов (опасения не безосновательны).

    по идее iis'a на win 10 home нет, простые операции восстановления вы пробовали. Попробуйте удалить антивирус и после обновить биос, и после перезагрузки попробуйте еще раз обновиться. Ошибки в логе общего характера ссылающиеся на то что у установщика нехватает прав и/или необходимый функционал поврежден

    У вас все доступные обновы установлены на 1809?

    upd: iis таки есть в домашних сборках. интересный нюанс...


    The opinion expressed by me is not an official position of Microsoft

    6 июля 2019 г. 17:43
    Модератор

  • Может можно переустановить IIS или восстановить Net Framework или еще что нибудь придумать по log файлам...


    Здравствуйте,

    Уточните пожалуйста вы пользуетесь IIS? Многие на различных форумах жаловались, что с установленным компонентом IIS не удается обновиться до 1903 (с кодом ошибки 0xC1900101-0x30018). Уточните пожалуйста, если отключить службу "Application host Helper Service" перед обновловление (отключить и установить режим запуска disabled) удается ли обновиться?

    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    6 июля 2019 г. 18:52
    Модератор
  • UPDATE

    Спасибо за предложения, самостоятельно решил проблему, дело было в невозможности запуска службы WAS "Служба активации Windows", из - за этого не могло установится обновление, вылетая с ошибкой установки TCP activation
    Файл в каталоге System32\inetsrv\config\ApplicationHost.config был пустой (без текста), заменил его на файл applicationhost.config.clean.install из той же папки (можно найти его в интернете думаю, если нет в папке) и все стало в порядке, служба запустилась, обновление Windows до 1903 установилось. Надеюсь, кому - нибудь поможет эта информация, тему можно закрывать. 
    • Изменено Aaa Aaa Aaa 6 июля 2019 г. 19:00
    • Помечено в качестве ответа Vector BCOModerator 6 июля 2019 г. 20:44
    • Изменено Vector BCOModerator 6 июля 2019 г. 20:46 удален белый квадрат
    6 июля 2019 г. 19:00
  • UPDATE

    Спасибо за предложения, самостоятельно решил проблему, дело было в невозможности запуска службы WAS "Служба активации Windows", из - за этого не могло установится обновление, вылетая с ошибкой установки TCP activation
    Файл в каталоге System32\inetsrv\config\ApplicationHost.config был пустой (без текста), заменил его на файл applicationhost.config.clean.install из той же папки (можно найти его в интернете думаю, если нет в папке) и все стало в порядке, служба запустилась, обновление Windows до 1903 установилось. Надеюсь, кому - нибудь поможет эта информация, тему можно закрывать.
    Спасибо за детали решения, возможно ваше решение поможет другим пользователям со схожей проблемой.

    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    6 июля 2019 г. 19:10
    Модератор

  • Файл в каталоге System32\inetsrv\config\ApplicationHost.config был пустой (без текста), заменил его на файл applicationhost.config.clean.install из той же папки (можно найти его в интернете думаю, если нет в папке) и все стало в порядке,

    Спасибо за детали решения, возможно ваше решение поможет другим пользователям со схожей проблемой.  

    В правильных опенсорсных установщиках, если обнаруживается некорректный или отсутствующий конфигуратор, предлагается поставить или ставится сам дефолтный уже лет 100 как. Кто бы транслировал случай разработчикам, чтобы проблема вообще не возникала.
    • Изменено RH6M6 7 июля 2019 г. 5:43
  • Система успешно обновилась до 1903, но теперь та самая служба (служба активации Windows WAS) (насколько я понимаю, она не связана с лицензированием, а отвечает за хостинг сайтов и связь с IIS) не запускается с другим сообщением об ошибке "Ошибка 15": "Системе не удается найти указанный диск"

    Может можно посмотреть где то логи установки служб в Windows для более подробной информации, я не знаю, где их посмотреть. Или как нибудь переустановить службу WAS и ее файлы и записи в реестре Windows. Прошу помочь.

  • Посмотрите в событиях системы (eventvwr.msc), какой путь указан?

    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    7 июля 2019 г. 14:32
    Модератор
  • Путь не нашел, но вот что пишется в журнале событий:

    Сначала

    The Windows Process Activation Service (WAS) encountered an error while handling key generation. This will prevent WAS from starting corrently. The data field contains the error number.

    Затем

    Служба "Служба активации Windows" завершена из-за ошибки
    Системе не удается найти указанный диск.

    Может как то еще можно посмотреть путь в просмотре событий? Я вроде все там прощелкал, не нашел именно путь

    7 июля 2019 г. 16:59
  • Покажите пожалуйста результат следующей команды в командной строке (cmd.exe):
    reg query "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WAS" -s



    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    7 июля 2019 г. 17:15
    Модератор
  • Файл в каталоге System32\inetsrv\config\ApplicationHost.config был пустой (без текста), заменил его на файл applicationhost.config.clean.install из той же папки . 
    Также проверьте файл который вы ранее заменили, возможно в не указаны неверные настройки.

    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    7 июля 2019 г. 17:16
    Модератор
  • Выкладываю:

    C:\WINDOWS\system32>reg query "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WAS" -s
    
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WAS
        DependOnService    REG_MULTI_SZ    RPCSS
        Description    REG_SZ    @%windir%\system32\inetsrv\iisres.dll,-30002
        DisplayName    REG_SZ    Служба активации Windows
        ErrorControl    REG_DWORD    0x1
        FailureActions    REG_BINARY    8051010000000000000000000300000014000000010000000000000001000000000000000000000000000000
        ImagePath    REG_EXPAND_SZ    %windir%\system32\svchost.exe -k iissvcs
        ObjectName    REG_SZ    localSystem
        RequiredPrivileges    REG_MULTI_SZ    SeAssignPrimaryTokenPrivilege\0SeAuditPrivilege\0SeBackupPrivilege\0SeChangeNotifyPrivilege\0SeCreateGlobalPrivilege\0SeDebugPrivilege\0SeImpersonatePrivilege\0SeIncreaseQuotaPrivilege\0SeRestorePrivilege\0SeTcbPrivilege
        ServiceSidType    REG_DWORD    0x0
        Start    REG_DWORD    0x2
        SvcHostSplitDisable    REG_DWORD    0x1
        Type    REG_DWORD    0x20
    
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WAS\Parameters
        GenerateKeys    REG_DWORD    0x1
        AccessDeniedMessage    REG_SZ    Error: Access is Denied.
        InstallPath    REG_EXPAND_SZ    %windir%\system32\inetsrv
        MajorVersion    REG_DWORD    0xa
        MinorVersion    REG_DWORD    0x0
        ServiceDll    REG_EXPAND_SZ    %windir%\system32\inetsrv\iisw3adm.dll
    
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WAS\Parameters\ListenerAdapters


    Сам тоже смотрел эти записи в реестре, вроде все нормально, думал может поменять %windir% на %systemroot% (также не знаю, зачем стоит символ "@" перед первым %windir%, может в этом дело)

    Менял и подставлял в папку inetsrv несколько разных файлов (со старого windows из бэкапа обновления) administration.config, administrationhost.config и redirection.config, безрезультатно, та же самая ошибка. Так что дело скорее всего в реестре, но там тоже вроде все нормально. Еще попробую детально посмотреть administrationhost.config

    • Изменено Aaa Aaa Aaa 7 июля 2019 г. 17:25
    7 июля 2019 г. 17:22

  • Сам тоже смотрел эти записи в реестре, вроде все нормально, думал может поменять %windir% на %systemroot% (также не знаю, зачем стоит символ "@" перед первым %windir%, может в этом дело)

    Лучше ничего не немять в реестре, так как может привести к Bsod.

    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    7 июля 2019 г. 18:15
    Модератор
  • 1) Посмотрите также логи в следующем каталоге, может там будут какие-то детали:

    %SystemDrive%\inetpub\logs\LogFiles 

    или

    %SystemDrive%\Windows\system32\LogFiles\W3SVC
    2) Проверьте также пожалуйста , чтобы все зависящие службы (службы WAS) также были запущены. Например: W3SVC



    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    • Изменено SQxModerator 7 июля 2019 г. 18:21 добавлено
    7 июля 2019 г. 18:18
    Модератор
  • У меня в компонентах Windows показывает, что IIS не установлен вообще. В списке служб W3SVC нет, в реестре есть данные о ней. Папка

    %SystemDrive%\inetpub\logs\LogFiles 

    отсутствует (нет папки logs, inetpub есть)

    Папка

    %SystemDrive%\Windows\system32\LogFiles\W3SVC

    тоже отсутствует

    А служба WAS точно зависит от W3SVC? При запуске WAS вроде не требует ее, нужна только RPC (Удаленный вызов процедур), у меня RPC включена. W3SVC это часть служб IIS и получается, что WAS не зависит от W3SVC, а наборот, W3SVC зависит от WAS.

    EDIT

    Установил службу W3SVC, не запускается с ошибкой "Ошибка 1068: Не удалось запустить дочернюю службу", то есть она зависит от WAS и поэтому не запускается. Соответственно LOG папка тоже пустая

    7 июля 2019 г. 18:54
  • Вот лог событий в Process Monitor при установке WAS (отфильтровал, как смог), может быть поможет (правой кнопкой на рисунке => открыть изображение, на всякий случай, сам просто не сразу разобрался как увеличить)


    • Изменено Aaa Aaa Aaa 7 июля 2019 г. 19:09
    • Изменено SQxModerator 7 июля 2019 г. 19:26 Удалены лишние пробелы.
    7 июля 2019 г. 19:07

  • 1) проверьте пожалуйста если присутствует файл:
    %windir%\system32\inetsrv\iisw3adm.dll

    2) проверьте если имеется какие-то ошибки в следующем файле:
    %SystemDrive%\windows\iis.log
    3) убедитесь, чтобы присутствовала папка по умолчанию для Application Pool
    %SystemDrive%\inetpub\temp\apppools 

    4) проверьте пожалуйста, если имеется следующий файл:
    %SystemDrive%\Windows\System32\inetsrv\Config\applicationHosts.config.tmp. 
    если его нет, то попробуйте временно переименовать файл конфигурации applicationHosts.config в applicationHosts.config.tmp и проверить если служба WAS запускается?


    Avis de non-responsabilité:
    Mon opinion ne peut pas coïncider avec la position officielle de Microsoft.

    Bien cordialement, Andrei ...

    MCP

    • Изменено SQxModerator 7 июля 2019 г. 19:32 добавлено
    7 июля 2019 г. 19:29
    Модератор
  • Уфф, это было тяжело... Проблема была в одном из ключей из скриншота по адресу

    C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys

    Пришлось изменить у него владельца (без этого файл не удалялся) и удалить его, после этого служба запустилась без проблем.

    Вот ссылка, которая помогла найти проблему:

    https://www.hanselman.com/blog/FixedWindowsProcessActivationServiceWASIsStoppingBecauseItEncounteredAnError.aspx

    Огромное спасибо за помощь, может быть кому нибудь поможет мое решение.


    • Изменено SQxModerator 7 июля 2019 г. 20:00 удалены пробелы
    • Помечено в качестве ответа SQxModerator 7 июля 2019 г. 20:00
    7 июля 2019 г. 19:42