none
Игры в Windows 7 во весь экран (Проблема)

    Вопрос

  • Не запускаются игры в Windows 7 на весь экран, как решить проблему? Игра не в окне а именно не на весь экран открыта по бокам чернота. Спасибо
    6 июня 2009 г. 11:09

Ответы

  • Проблему решил,тупо поставив старый драйвер от nvidia 158.28 от 29.06.2007г. который поставлялся с видюхой(8600GT)
    Теперь все игры независимо какое разрешение ни поставить в них заполняют весь экран,выводы делайте сами.
    5 августа 2009 г. 16:48

Все ответы

  • У меня такая бяка была только в двух играх- FlatOut и FlatOut Ultimate Carnage- когда разрешение экрана ставил 1024х768 4:3- сверху и снизу черные полосы, видеокарта 8800 GT AMP! 512, монитор трубка 19", рекомендуемое разрешение 1280х1024, но обычно пользуюсь 1024х768 :
    1. В FlatOut так и осталось, т.к. она только раз при первом запуске спросила про разрешение - я поставил 1024х768 4:3- и ппц.
    2. FlatOut Ultimate Carnage при каждом запуске спрашивает про разрешение и соотношение сторон- в качестве эксперимента поставил 1280х1024 5:4- сразу полный экран, никаких черных полос
    3. На встроенной Radeon 3200 такого не было
    Так вот это я к тому, что можно попробовать поэкспериментировать с разрешением и соотношением сторон

    Будет интересно, напишу какие игры у меня шли без проблем
    6 июня 2009 г. 11:30
  • Сейчас попробую поэксперементировать! У меня ноутбук с разрешением экрана 1280 x 800. WARCRAFT 3 и WoW запускаются по центру экрана по бокам черные полосы(( Помню в Windows Vista была фунция совместимости когда нажимаешь правой кнопкой на раб столе и там в Меню Настройка Графики выбираешь соотношения запуска приложений в WIndows 7 не нашел такой функции.
    6 июня 2009 г. 11:41
  • К сожалению ничего не получается(
    6 июня 2009 г. 11:51
  • А драйвера от nVidia пробовали? У меня 9800 и нет проблем с играми!

    http://ru.download.nvidia.com/Windows/186.08/186.08_desktop_win7_winvista_32bit_international_beta.exe

    6 июня 2009 г. 12:54
  • У меня видеокарта Radeon 3470 Mobility , уже качаю новые с AMD.COM для WIndows 7 и сейчас буду пробовать)
    6 июня 2009 г. 13:00
  • Жесть дрова с ATI тормознутые игры еще больше тормозят ппц)) верну те которые винда сама поставила. Проблема с экраном остается до сих пор(
    6 июня 2009 г. 13:24
  • Просто есть игры с разрешением только 4:3, но например FlatOut 2 - это не касается, там в настройках игры можно выбирать формат экрана: 4:3 или 16:9, по умолчанию стоит разумеется 4:3, во FlatOut Ultimate Carnage насколько я знаю такая настройка тоже присутствует.

    Если ответ Вам помог, нажмите на изображение зеленой галочки - «пометить как ответ». Если ответ был для Вас полезен, Вы можете пометить это сообщение как «полезное», нажав на ссылку "проголосовать за полезное сообщение" в правом верхнем углу сообщения.
    • Предложено в качестве ответа iovlev 7 июня 2009 г. 12:56
    6 июня 2009 г. 18:52
  • Поскольку Nvidia выложила новую бету драйверов 186.08, решил поставить:
    1. Удалил полностью старую версию со старым Физиксом
    2. Поставил новую 186.08
    3. Поскольку для FlatOut появилось вроде как новое оборудование, игра снова при запуске запросила выбрать параметры- выбрал 1280х1024- пошла в полный экран
    4. FlatOut Ultimate Carnage также при 1024х768- черные полосы, при 1280х1024- полный экран
    5. Непонятно почему упал на 0,1 индекс видео???
    6. Ати-шная последняя вроде как 9.5? У меня на "встройке" 3200 с 9.5 проблем не было, просто в общем и целом "дури" не хватало, поэтому поставил пока 8800
    7. Эх, жаль нет возможности поставить кроссфайером пару 4830 или 4850- судя по тестам в сети круче, чем 4870

    Так вот это я к тому, что можно попробовать удалить все версии драйверов, кроме тех, что ставит сама 7-ка, потом накатить снова, потом запустить игру- может она запросит выбрать параметры?
    Кстати, в "Пуске" в меню игры нет настроек? Или в папке с игрой нет программы типа cofig или setup?
    6 июня 2009 г. 19:42
  • А мне наоборот удобнее с черной полосой. Некоторые игры не поддерживают разрешение 1280x800, поэтому с черными полосами  картинка выглядит четче. ;-)
    7 июня 2009 г. 16:44
  • Если игра не поддерживает широкоэкранный режим, а монитор широкоэкранный, то будут полосы по бокам. Иначе изображение придется растянуть и все будет сплющеным и, конечно, менее четким.

    Если же игра не поддерживает 4:3 режим, а монитор 4:3, то будут полосы сверху и снизу. Иначе изображение придется растянуть и все будет вытянутым и менее четким.

    Если есть желание получить сплющеное/вытянутое и менее четкое изображение, то это можно сделать несколькими путями:

    1. В драйвере видеоадаптера. Например Нвидиа имеет такую фичу.
    2. В мониторе (или в биос на лаптопах).

    Если у кого то еще остался CRT монитор, то растягивать/плющить надо в настройках самого монитора.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Предложено в качестве ответа Adanedhel 9 июня 2009 г. 10:01
    7 июня 2009 г. 19:18
  • У меня такая же проблема ноутбук асус м50са. Как решить эту проблему. дрова качал не помогло, в контрол центре ничего подобного нет. ати как всегда. нах я тока брал этот ати сидел всю жизнь на нвидиа....
    26 июля 2009 г. 21:38

  • patsany,toje takaya problema,ctavil wind 7 i igry idut na pol ekran,chto delaty?
    27 июля 2009 г. 14:15

  • patsany,toje takaya problema,ctavil wind 7 i igry idut na pol ekran,chto delaty?
    ничего. играть как есть.
    27 июля 2009 г. 14:20
  • да я не поверю что никто не исправил это. может есть софтина или причина какая нить. всем пофиг чтоли?
    27 июля 2009 г. 22:35
  • Ничего исправить тут нельзя поскольку ничего не сломано. Полосы по бокам - совершенно нормально если игра работает в 4:3, а монитор 16:9...10 как сегодня принято.
    Если устраивает сплющеная картинка то надо просто включить растяжку в настройках монитора.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    28 июля 2009 г. 0:24
  • на ноуте никак не растянеш изобрпажения. просто у тя паходу нвидиа и ты не замарачиваешся. А вот у меня проблема и настроки типа вид скрин не катят
    31 июля 2009 г. 15:32
  • На ноутах настройки растяжки обычно находятся в БИОС. Так что обычно можно растянуть даже на ноуте - хотя конечно всегда есть исключения.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    31 июля 2009 г. 16:10
  • гирс оф вар и кризис идут номрано а все другие такой бок. на висте всё было нормано
    31 июля 2009 г. 16:18
  • Значит эти две игры работают в широкоформатном режимеме, а остальные - в 4:3. И растяжка отключена (а на Виста была включена либо в драйверах либо в мониторе).
    Что делать: включить растяжку.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    31 июля 2009 г. 17:27
  • ничё не включал ни в биосе ни в драйвере на висте. а тут ставил и с диска и новый дрова и в драйвере смотрел нет там такой опции растяжки. тут нада как то чтоб драйвер понял что ета игра не на весь экран. мож дело в аэро?
    31 июля 2009 г. 20:08
  • Значит драйвер растягивал изображение по умолчанию.

    Нет, дело не в аэро.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    31 июля 2009 г. 22:05
  • так как быть ждать драйвер чтоли или через этот можно как то сделать?
    1 августа 2009 г. 11:09
  • Мне отсюда не видно какой "этот драйвер" имеется в виду. Если это Nvidia то в текушей версии драйвера для семерки есть пункт "Adjust desktop size and position" где можно выбрать различные варианты растяжки. Например можно поставить "Use NVIDIA scaling".

    Можно так же настроить растяжку в мониторе. Вот например как это выглядит в моем мониторе (картинка не моя): http://img176.imageshack.us/i/untitled1mr9.jpg/

    Меню называется Wide mode и позволяет выбрать такие варинты:
    1:1  - изображение пикель в пиксель. Все что меньше родного разрешения будет занимать часть экрана с полосами по бокам и сверху/снизу.
    Aspect - изображение будет растянуто по размеру монитора с сохранением оригнального соотношения сторон.
    Full - изображение будет растянуто на весь экран независимо от оригинального разрешения.

    Последний вариант именно то что желают все любители игрушек в данной теме.

    Для других мониторов - см. инструкцию. В лаптопах такие настройки обычно в биос.



    This posting is provided "AS IS" with no warranties, and confers no rights.
    1 августа 2009 г. 17:33
  • это ати мобильный 3650 драйвер 9.7 пробывал эти опции не получается всеравно.
    2 августа 2009 г. 11:04
  • По мне так удобно сделано, что игры не поддерживающие широкоформатное разрешение запускаются с рамками по бокам на широкофрматных мониторах в 7ой винде в отличии от ХР.
    Но веть можно принудительно запускать игры с нужным разрешением и есть кучи способов этого достич.
    Программы, изменение файлов *.ini *.cfg настроек в самой игре, команды в свойствах ярликов в стиле...
    "D:\Games\Battlefield 2\BF2.exe" +menu 1 +fullscreen 1 +szx 1680 +szy 1050  и тд.  в частности батлфилд популярная игрушка, но ширики она не видит. Зато можно ее обмануть.
    Кучи тем есть посвященных на такие темы и к контретным играм тоже. Просто нада пользоваться поиском

    2 августа 2009 г. 12:34
  • такие парамеры не все игры подержывают. насильно заставить бы. или прога мож есть я гворю про виде карту на ноут буке. на науте екран не растягивается
    2 августа 2009 г. 12:53
  • Дак ко всем играм одну и туже настройку не привязать. В каждой игре свои приблуды, и к каждой игре свой подход к настройке.
    2 августа 2009 г. 13:03
  • Кстати, вот тут http://social.technet.microsoft.com/Forums/ru-RU/windows7ru/thread/36a07fee-314c-482a-ab9f-3db76c9a5d94 товарищ решил проблему с разрешениями в W7.
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    3 августа 2009 г. 5:36
  • В большинстве лаптопов растяжка включаетс в БИОС. Называется по разному, например "LCD screen expansion" как тут (картинка не моя):

    http://www.werkema.com/img/laptop/bios2.jpg

    Если нет (и нет растяжки в драйвере конкретной карты) - то не судьба.




    This posting is provided "AS IS" with no warranties, and confers no rights.
    3 августа 2009 г. 16:12
  • Во-первых Ваша ссылка не работает. А во-вторых Вы уже описали свою проблему разработчикам вот тут?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    5 августа 2009 г. 11:42
  • Во-первых Ваша ссылка не работает. А во-вторых Вы уже описали свою проблему разработчикам вот тут ?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    нет там я ничего не описывал.
    5 августа 2009 г. 11:53
  • Проблему решил,тупо поставив старый драйвер от nvidia 158.28 от 29.06.2007г. который поставлялся с видюхой(8600GT)
    Теперь все игры независимо какое разрешение ни поставить в них заполняют весь экран,выводы делайте сами.
    5 августа 2009 г. 16:48
  • Проблема решается легко, я просто зашёл в Пуск > Игры , и туда перетащил ярлык с рабочего стола (от старой игры, котораЯ ранее запускалась в окне).Теперь запуская оттуда игры они на полный экран. Просто ОС 7 видит старые игры как обычные программы.

    15 августа 2009 г. 11:38
  • нифига не получается. Может внатуре поставить драйвера с диска? Некоторые говрят можно а каталист контроле выставить типа растягивать на весь экран, тока я такого там не нашел!
    18 августа 2009 г. 13:34
  • можно сделать вывод - для каждого случая нужен свой бубен с шаманом. универсального решения нет. где-то игры сами позволяют их растянуть. где-то надо найти строго одну версию драйверов. где-то копаться в настройках железа. широчайший простор для экспериментов!
    18 августа 2009 г. 17:02

  • Если же игра не поддерживает 4:3 режим, а монитор 4:3, то будут полосы сверху и снизу. Иначе изображение придется растянуть и все будет вытянутым и менее четким.

    Если у кого то еще остался CRT монитор, то растягивать/плющить надо в настройках самого монитора.


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Режим 4:3 как раз только на CRT мониторах и остался (1024х768). На следующих за ними LCD мониторах 5:4(1280х1024) и далее.
    • Предложено в качестве ответа shedou 23 ноября 2009 г. 19:59
    • Отменено предложение в качестве ответа Ilya TumanovMicrosoft employee, Moderator 15 октября 2010 г. 2:08
    19 августа 2009 г. 4:41
  • Ну так что, решил кто-то что-то? У меня с Dirt 2 фича. Если ставить родное разрешение - 1366х768 (16:9), то игра безбожно тормозит, т.к. ноут слабенький. Я поставил 1024х768 и тут эти полосы по бокам. На ХР все нормально растягивалось. Видюха ATI Radeon Mobility HD 3200 интегрированная. В Каталисте ничего не нашел. Биос вообще шлак на ноуте (Compaq 615). Перетаскивал в "Игры" нифига не помогает. ОС Windows 7 Ultimate x86. Перечислите еще раз все варианты, попорбую все, может что-то поможет...
    14 июля 2010 г. 15:49
  • Я решил!

    1)кликаешь по рабочему столу правой кнопкой мыши,вызываешь каталист.

    2)Notebook Panel Properties

    3)в окне Scalling Options выбираешь Full Screen

    4)жмешь Apply

    5)закрываешь каталист

    P.S.использовал стандартные дрова.игры на весь экран,но сплющенное изображение.

    надеюсь что помог советом)))

    • Предложено в качестве ответа Axarion 9 января 2011 г. 16:53
    15 октября 2010 г. 1:47
  • если кому еще нужно

     

     

    Чтобы изменить разрешение экрана warcraft 3, нужно:

    1. Убедиться, что разрешение, которое Вы хотите поставить на Warcraft 3 поддерживается Вашей видеокартой.

    2. Сделать резервную копию реестра, т.к. все работы будут производиться именно в нем.
    ПУСК – Выполнить – набираем (без ковычек) «regedit» – Открывается окно и в нем выбираем в меню Файл – Экспорт

    3. Меняем разрешение Warcraft в ручную

    ПУСК – Выполнить – набираем (без ковычек) «regedit»

    В появившемся окне открываем
    HKEY_CURRENT_USER > Software > Blizzard Entertainment > Warcraft III > Video

    4. В правой колонке появляются файлы, которые нужно изменить:
    Кликаем по нему правой кнопкой мыши – Изменить – Выбрать «Десятичное» – ввести новое значение (например):
    reswidth = 1600 – ширина экрана
    resheight = 900 – высота экрана

    Примеры широкоформатынх разрешений для Warcraft 3:
    852×480 16:9 Широкий экран
    1280×720 16:9 Широкий экран
    1280×800 16:9 Широкий экран
    1365×768 16:9 Широкий экран
    1440×900 16:10 Широкий экран
    1680×1050 16:10 Широкий экран
    1920×1200 16:10 Широкий экран
    31 января 2011 г. 15:33
  • Спасибо большое вы мне очень помогли =)
    16 января 2012 г. 6:25
  • проблему нужно решить поставив пропорции экрана 4:3. это можно сделать программой которая ставиться вместе с драйвером видеокарты.
    • Предложено в качестве ответа likemoody 15 августа 2012 г. 16:08
    15 августа 2012 г. 16:08