none
Скачет скорость копирования по локальной сети(XP & Vista) RRS feed

  • Вопрос

  • Есть 2 PC.
    Первый  - сервак (качает/раздает торренты).
    XP SP3 x86, интегрированный гигабитный сетевой контроллер.
    Intel P31, Core 2 Duo E6750 2,67ГГц, 3ГГБ RAM, HDD 750ГГБ.
    Второй - игровой, кино и т.д.
    Intel P35, Core 2 Quad Q9450 2,66ГГц, 4ГГБ RAM, HDD 2x500ГГБ.
    Vista SP1 Ultimate x86. интегрированный гигабитный сетевой контроллер.

    Оба компа подключены к роутеру через гигабитный свитч, специально для того, чтоб между ними была сеть на гигабит. Подключение устанавливается - 1Гбит/с. Все патч корды 6 категории(прозвонил LAN тестером). Скачаны последние обновления.

    Проблема:
    При копировании с первого на второй скорость может достигать 60 - 80 мегабайт в секунду, а может быть как при 100Мбитном соединении 7-12 мегабайт в секунду.
    Например копирую фильм в HDTV на 10 гигабайт, копируется на скорости 60-80 метров в секунду, проходит минут 5 после завршения копирования, начинаю копировать тот же самый фильм и скорость составляет 10 мегабайт в секунду. Компьютеры между копированиями не перезагужаю. Выключаю антивирусы и прочую лабуду - обе системы бездействуют. В общем скорость скачет.
    По началу, не разобравшись казнил гигабитный свитч, воткнув в него отвертку. Когда купил второй свитч, понял, казнил невинного. Для чистоты эксперимента взял на работе Intel PRO/1000 PT Server Adapter PCI-Express EXPI9400PT. Ставил ее и в первый и во второй компы, чтоб исключить сетевые адаптеры из списка подозреваемых. Результат тот же самый, что и с интегрированными сетевухами. Менял дрова для всех адаптеров, скачивал у производителей чипов, матерей. Переустанавливал обе операционки. Отключал "Разностное сжатие" в Vista.

    Если на обоих компах стоит XP - скорость стабильная, но не более 30 мегабайт в сек. Хочу быстрее.

    Возможно есть какая-то служба, или сервис. Подскажите, я уже заикался искать в чем проблема.
    16 октября 2008 г. 9:09

Все ответы

  • Такое ощущение что драйвер или свитч переключается на 100 мбпс. Что будет если компьютеры соединить напрямую?

    16 октября 2008 г. 19:48
    Модератор
  • Проверил 3 свитча, на серваке сейчас уже 3-я мама по счету стоит. На игровом компе 2 гигибитных порта, попробовал оба. Не думаю что проблема хардверная. Где то есть галочка, про которую я не знаю.
    Попробую напрямую, не думаю что поможет.

    16 октября 2008 г. 20:09
  • Такое падение скорости едва ли может быть вызвано чем то выше драйверов карты. Наиболее вероятный варинат что кто то сваливается на 100 мб режим. Может свич, может любая из карт. Причем это даже не значит что кто то из них неисправен.

    16 октября 2008 г. 21:33
    Модератор
  • А если выставить в свойствах карточек и портов на свиче принудительно гигабит ? обычно стоит по дефолту авто определение, может заработает ? только наверное иногда лаги будут, не зря же переключалось на сотню.

    17 октября 2008 г. 22:13
  • Выставлял 1Гбит вручную на обих компах. Сейчас стоит автоопределение - соединяется на 1Гигабит стабильно.
    И так и так -одинаковая песня. Предположим,что если одна из сетевух слетает до 100мегабит, наверное ей нужно переподключиться? а переподключений не наблюдается.
    18 октября 2008 г. 6:29
  • Ну вовсе не факт что нужно. Вот Wi-Fi например меняет скорость на ходу без разрыва соединения.

    18 октября 2008 г. 6:49
    Модератор
  • Может быть все это как-то связанно с автонастройке протокола TCP/IP?

     

    Попробуйте его выключить и посмотреть станет ли скорость более стабильной.

     

    Code Snippet
    netsh interface tcp set global autotuning=disabled

     

     

    Если станет стабильней, то наверное стоит поисследовать данную функциональность и поиграть с опциями автонастройки.

    18 октября 2008 г. 7:12
  • Напрямую все красиво, проверил сегодня. Гонял правда не долго, 100 гиг перекинул где-то.

    Доставлю в сервак сетевуху и получится 2PC с 2-мя сетевыми картами каждый. Между собой по гигабиту будут дружить, а в инет пускай через свитч ходят.

    Приходится городить огород из сетевых карт, но выбора нет.
    19 октября 2008 г. 18:44
  • сделал autotuning=disabled
    сразу не скажу, нужно время.

    19 октября 2008 г. 18:50
  • Если на прямую все работает то настройки ОС скорее всего не при чем (и соответвенно манипуляции с netsh не помогут). Просто кто то переходит на 100 мбит по какой то причине.

     

    Гигабит вообще довольно капризен - плохо обжатые разъемы,  слишком длинные кабели, дешевый свич - и все, 100 мбит. Причем похоже в драйверах нет обратного перехода.

     

     

    19 октября 2008 г. 19:05
    Модератор
  • Согласен, если скорость просела до 10 мегабайт, то до 60 она уже не вырастет. Помогает переустановка драйвера сетевухи или ребут.
    20 октября 2008 г. 9:18
  • сделал autotuning=disabled
    сразу не скажу, нужно время.




    не, не помогло.
    20 октября 2008 г. 16:45
  • Что и не удивительно.

    20 октября 2008 г. 18:03
    Модератор
  • Кажется разобрался.....





    Sorry господа, проблема не решена, поработало нормально денек и с новой силой рушит мне мозг.
    22 октября 2008 г. 19:27
  • На прямую работает?

    23 октября 2008 г. 20:32
    Модератор
  • работать работает, на 100 мегабит
    26 октября 2008 г. 11:03
  • Т.е. и при прямом соединении перескакивает на соотку? Самое время менять кабель и карточки.

     

    26 октября 2008 г. 16:51
    Модератор
  • перескакивает
    хочу начать с кабеля, не могу найти патч-корд в продаже 6 категории экранированный 10м.
    самому придется делать наверно

    если кто знает Product Code на кабель пожалуйста скажите.
    27 октября 2008 г. 11:15